none
Web Service & IIS

    Question

  • Bonjour,

    J'utilise Visual Studio 2012 pour développer un Web Sercice en C#.
    Lorsque je fais un simple Web Service Standard, donc le HelloWorld par défaut, si je l'exécute j'arrive bien sur la page permettant de lancer le WS.
    Mais si je l'exécute une 2e fois ça ne fonctionne plus, j'arrive sur l'écran initial d'IIS, avec juste une image (le logo IIS).
    Parfois j'arrive à l'écran du WS et parfois pas ... je ne sais plus comment faire.

    Si vous avez une idée ?

    Merci d'avance pour votre aide.
    Youri

    vendredi 7 décembre 2012 14:13

Réponses

Toutes les réponses

  • Bonjour,

    ça sent le bug VS2012 ça, non ?

    En tout cas, ce n'est pas très grave en soit. il te suffit de paramétrer un port statique dans le propriétés web du projet, et de mettre un marque page dans ton navigateur : http://localhot:XXXX/webservice.svc

    Cordialement.

    vendredi 7 décembre 2012 15:03
  • Oula je me suis trompé c'est VS 2O1O en fait, désolé.

    Comment je dois faire pour paramétrer un port statique dans le projet ?

    En fait quand j'arrive sur la page du WS, l'URL est de type localhost.
    Et quand j'arrive sur la page IIS c'est URL avec une adresse IP.

    vendredi 7 décembre 2012 15:55
  • Tout est dans les propriétés du projet web contenant ton web service.


    vendredi 7 décembre 2012 16:15
  • Ça ne change rien.

    Page spécifique était déjà coché.
    Et le Port spécifique ça ne change rien.

    Sur le PC du bureau j'ai ce problème, sur mon PC personnel pas de problème.

    vendredi 7 décembre 2012 17:10

  • Et quand j'arrive sur la page IIS c'est URL avec une adresse IP.

    Est-ce que c'est bien d'adresse IP de ton PC ?

    Est-ce que tu as plusieurs cartes réseau  ?

    samedi 8 décembre 2012 10:10
  • De toute façon, si tu change l'url dans ton navigateur, tu parviens tout de même à deboguer ton web service non ?

    C'est pour cela que je t'ai proposé de fixer le port : tu peux mettre un marque page dans ton navigateur pour accéder immédiatement à ton web service.

    A voir aussi si l'option "Démarrer un programme externe" n'est pas utile, du genre :

    - tu mets le chemin d'accès à Internet Explorer

    - dans "Agument de la ligne de commande", tu mets l'adresse de ton web service.

    samedi 8 décembre 2012 10:13
  • Pour le moment sur mon PC personnel j'arrive à débugger mon WS sans problème.
    Sur le PC du bureau j'ai laissé tomber.

    Mais tes informations me sont très utiles merci.

    Maintenant je vais probablement continuer via un autre post dans un autre forum car j'ai quelques problèmes sur la logique de mon application.

    Merci pour ton aide.
    Youri

    samedi 8 décembre 2012 10:18