none
OutputPath property is not set

    Question

  • Hi,

    I have a solution that contains multiple projects and often get this error when I try and deploy the main project (_PPC_ViewPoint):

    ------ Build started: Project: _PPC_ViewPoint, Configuration: Debug Any CPU ------
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(481,9): error : The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Configuration=''  Platform='AnyCPU'
    Done building project "_PPC_DataEngineDotNet.csproj" -- FAILED.
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(481,9): error : The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Configuration=''  Platform='AnyCPU'
    Done building project "_PPC_DataEngineHelper.csproj" -- FAILED.

    To deploy this, I have to go right click first on _PPC_DataEngineDotNet and select Deploy, then wait until it deploys ok, do the same to _PPC_DataEngineDotNet and then I can actually deploy
     _PPC_ViewPoint.

    To me, I am doing just what the environment should do... looking at the dependancies, building and deploying in turn as required.

    All projects have an 'OutputPath', which is bin\debug or bin\release.

    Any ideas what might be wrong?

    Thanks :)
    lundi 16 janvier 2006 20:40

Réponses

  • Hi,
         This is known issue in the RTM build, where you have multiple projects in a solution. If you have added project to project references in your startup project and unchecked the build option for other projects (referred by your startup project) then you will end up with this error. The following repro steps and the workaround will make it clearer:

    Repro:
    1) Create a Device application (DevApp1)
    2) Add another device application (DevApp2) in the same solution.
    3) Add Project reference (DevApp2) in DevApp1.
    4) Build the solution.
    5) Open configuration manager and uncheck the build option for DevApp2.
    6) Open Program.cs( of DevApp2)
    7) Build the solution, build fails.
    8) You will get the error message “The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Configuration=''  Platform='AnyCPU' “

    Workaround:
    1) Open the configuration Manager.
    2) Check the build option for the DevApp2( All the P2P references)
    3) Build the solution. Build will succeed.
    4) Open the configuration manager.
    5) Uncheck the build option for DevApp2.
    6) Don’t click on any of the DevApp2 hierarchy otherwise the user will end up into the same error message.

        We understand it is very painful for an end user and this is one thing we would like to fix in the next release.
    Regards,
      Manish

    mardi 17 janvier 2006 04:18

Toutes les réponses

  • Hi,
         This is known issue in the RTM build, where you have multiple projects in a solution. If you have added project to project references in your startup project and unchecked the build option for other projects (referred by your startup project) then you will end up with this error. The following repro steps and the workaround will make it clearer:

    Repro:
    1) Create a Device application (DevApp1)
    2) Add another device application (DevApp2) in the same solution.
    3) Add Project reference (DevApp2) in DevApp1.
    4) Build the solution.
    5) Open configuration manager and uncheck the build option for DevApp2.
    6) Open Program.cs( of DevApp2)
    7) Build the solution, build fails.
    8) You will get the error message “The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Configuration=''  Platform='AnyCPU' “

    Workaround:
    1) Open the configuration Manager.
    2) Check the build option for the DevApp2( All the P2P references)
    3) Build the solution. Build will succeed.
    4) Open the configuration manager.
    5) Uncheck the build option for DevApp2.
    6) Don’t click on any of the DevApp2 hierarchy otherwise the user will end up into the same error message.

        We understand it is very painful for an end user and this is one thing we would like to fix in the next release.
    Regards,
      Manish

    mardi 17 janvier 2006 04:18
  • I am experience the same problem now and I end up guessing and having trial and error jus to make my application build. I have 3 Device Class Libraries and 2 Device Windows Application. SP1 already installed and it seems the problem still exists.

    Issues was reported January 2006 and its May 2006 already so its surprising its not addressed yet. I hope the CF team can take a closer look at this because this is really painful and caues buid failures.

    thanks.
    dimanche 7 mai 2006 07:49
  • Just encoutered the error during command line builds.

    * Problem: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(481,9): error : The OutputPath property is not se
    t for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Conf
    iguration='Release_Java20'  Platform='AnyCPU' 0 Warning(s)
        1 Error(s)
    *   Reason: The project PropertyGroup (no conditions)  needs to be in the build file BEFORE configs PropertyGroups (with cond)
    *   Solution: Edit MSBuild file and move The project PropertyGroup before configs PropertyGroups

     

    mercredi 9 août 2006 20:43
  • Can you please specify witch sections in file I have to move?

    Whitch section is Project propertygroup and witch is configs propertygroups

     

    mercredi 11 octobre 2006 20:24
  • I tried these two workarounds in vain.

    I have  a huge solution with mixed web, compact framework and winforms projects with multiple dependencies and no solution yet.

    Errors are all for my CF projects and of the form :

    Error 255 The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Configuration=''  Platform='AnyCPU' MyNamespaces.CF

    jeudi 9 novembre 2006 12:36
  •  
    I found at least one solution for this issue.   The specific error I received:
     
    warning : The OutputPath property is not set for this project. Please check to make sure that you have specified a valid Configuration/Platform combination. Configuration='Release' Platform='AnyCPU'
     
     
    Notice the 'Release' configuration setting in the error message? We currently have 4 build configurations, Dev, SIT, UAT and Prod and have deleted the out-of-the-box Debug and Release solutions, so this was definitely unexpected.
     
    I then snooped around my project and solution files (in notepad) and noticed something in the solution file (*.sln) under the 'GlobalSection(ProjectConfigurationPlatforms) = postsolution' section of the file.  This specific solution has 12 projects - it turns out that the configuration platform mappings for one those projects was out of whack.  Lo and behold it was related to an invalid mapping from our new Prod configuration to the no longer used (and deleted) Release configuration.
     
      {A5CCEA04-DA69-4FDA-AD34-EDBFCBA47EB9}.Prod|Any CPU.ActiveCfg = Release|Any CPU
      {A5CCEA04-DA69-4FDA-AD34-EDBFCBA47EB9}.Prod|Any CPU.Build.0 = Release|Any CPU
     
     I then changed it to this:
     
      {A5CCEA04-DA69-4FDA-AD34-EDBFCBA47EB9}.Prod|Any CPU.ActiveCfg = Prod|Any CPU
      {A5CCEA04-DA69-4FDA-AD34-EDBFCBA47EB9}.Prod|Any CPU.Build.0 = Prod|Any CPU
     
    And validated that all other project configurations were mapped correctly, checked it in, reran the build and everything was good.
     
    Hope that helps someone. 
     
    jeudi 14 juin 2007 18:21
  • Hi,

     

    We have all the referenced projects - build option - checked. Still however build continues to give the error. Can you please state other possible solution to this issue.

     

    Regards,

    Anand

     

    jeudi 11 octobre 2007 15:14

  • I had this problem.  My solution file had become corrupted.  I had rebooted with VS running and tried to save the solution file during the shutdown and I guess it didn't save correctly.  The solution was missing a few projects that should have been included.  I readded the missing projects and the error went away.
    mardi 23 octobre 2007 16:11
  • I too had this problem when compiling 'proj1'. Proj1 has references to proj2 and proj3. There was no obvious corruption is either the sln or csproj file. I ended up having to remove the references to proj2 and proj3, and them add them back again. This solved the problem.

    mardi 8 avril 2008 15:29
  •  

    I had the same problem and after a bit of searching I noticed something.

     

    My situation I have multiple solutions that sometimes share projects. The problem for me was that in the solution that had the problem, I was missing a couple of projects that one of the listed projects was dependent upon.

     

    To check for this just open the references folder in all projects and see does any of them have an exclamation icon.

     

    Good luck!

     

    Michael

    samedi 7 juin 2008 13:49
  • Like so many of the postings you see here, this has been one of the more frustrating issues we have had to deal with using Visual Studio 2005 (for the record, we have not run into this situation, yet, in VS 2008).

     

    We're not sure if this led to our issues with this exception, but we have a design flaw in one of our programs that causes a circular reference ..... assembly A needs assembly B, and assembly B needs assembly A.  When we've got some free time we're planning to go back and refactor the code to elminiate this.

     

    But, we have been able to elminate the exception by performing the following two steps:  1) we noticed that when Adding References to projects if you "browsed to the file" and select the DLL explicitly (versus, simply using the "projects" tab and selecting from the presented list), and 2) change each project's Assembly Version (project properties > application > assembly information) so that the last textbox will have a specific value (remove the "*" and change it an actual number).

     

    For example, the default value would have been "1.0.0.*" ......... we changed ours to "1.0.0.0".  All of a sudden, we'd be able to re-compile each project, and then the entire solution, without any problems. 

     

    Not sure why this made the difference, but after countless hours of searching the Internet, newsgroups, local user groups, etc., etc. ....... we're not going to argue with success.

     

    On an unrelated tech support case with Microsofft's Developer Support, I was talking with a tech and they mentioned this is something that MS engineers are not really sure of the cause (this was about a year and a half ago), but they were going to try to eliminiate in VS 2008.  The one suggestion he did have for me was to create a new Solution, and import in all the various projects (admitedly, we never tried this because we have 23 projects in our solution - it's a general library we use for our various projects).  But if was his "official" recommendation at the time.

     

     

    samedi 7 juin 2008 16:34
  •  

    I've just got this problem in VS2008. I have a new solution re-using existing projects and like everybody else I have a custom configuration.
    jeudi 24 juillet 2008 11:50
  • Resolved. I was missing dependencies. i.e. I needed to add some more projects to the solution and ensure all references were met.

     

    Its a very misleading message in these circumstances.

    jeudi 24 juillet 2008 12:25
  • I had the same problem - I am glad I noticed this thread

     

    One project had a reference to another project which wasn't in the solution.

     

    I added the missing project and it solved the issue

     

    Thanks

    lundi 22 septembre 2008 23:42
  • The problem still exists in VS2008 SP1 and in VS 2005.

     

    I have found another workaround to this problem and since I have spent so many hours finding this workaround, I will share this with the rest of the world, so others might save some time.

     

    Background for why we found the error in the first place

    1. We have one build all solution containing more than 100 projects, a combination of WinForms and class libraries.

    2. One or more of the projects uses an old win32 dll file for encryption purposes

    3. When our .NET applications are installed on a Windows 2008 server the projects using this old Win32 dll breaks, because our project are compiled with Platform Target "Any CPU".

    4. We have decided to compile all projects with Platform Target "x86" until we can get rid of this old win 32 dll dependency, and tests have shown, that our .NET applications then runs on a Windows Server 2008 when this is done.

     

    First attempt: Making a clean solution

    I tried to start up a clean solution with configurations "Debug" and "Release" and Platform Targets "Any CPU" and "x86", both with just one project I got the error:

    "The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination.  Configuration='Release'  Platform='x86'"

    This occured as soon as I tried to build the solution with just one existing project with the Active Solution Platform set to "x86".

     

    I tried several approaches to find out what the problem was, which might be useful for the Microsoft Team searching for the bug, and therefore I will explain in the following what I found.

    When I changed the Active Solution Platform in the solution to "x86", saved the solution, unloaded the project and reloaded the project again, the project references to System.Xml and similar built in System.xxx DLL's showed up with a warning and changed properties. Whether or not this is related to this problem I do not know, but since Microsoft according to a previous post in this thread are uncertain as to where the problem is, this information might be able to help to find and eliminitate this very annoying bug.

     

    The workaround that I got to work

    But anyway, in my situation I really want all projects to be targeted to the Platform "x86". My workaround ended up being the following:

    1. To build my solution using Configuration "Release" and Active Solution Platform "Any CPU".

    2. For each project I have set the Platform Target to x86 (on the Build Tab under Project Properties) under the Active Solution Platform "Any CPU". This can be setup in one of the following ways:

    a. manually through VS2008

    b.by making an Import file (or alter the existing one) to all projects that import the following settings

    <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">

    <PlatformTarget>x86</PlatformTarget>

    </PropertyGroup>

    c. By adding the above code to each csproj file that needs to be targeted to Platform Target "x86"

     

    In case you end up having the same problem and needs a workaround please feel free to use the above workaround :-)

     

    On a personal note I really hope this issue will be solved by Microsoft, or at least that they will provide a better error message that tells us what the real problem is, as previous posts in this thread indicates, that the error is unrelated to the OutputPath  property,

     

    Best regards

    Peter Bech Hansen, Denmark

    Senior Systems Developer

    jeudi 30 octobre 2008 10:26
  • Hi all,

    I had same problem, and i learn how to fix it :). When i got this error, i was building projects by different build configuration. Problem is that project (call it project A), that report error, has project references to another projects (call them project B and project C), which build configuration is not same as build configuration for project A. All you have to do is to change this build configuration for projects B and D in Configuration manager
     
    Hope, this solve your problem. It worked for me

    Best regards

    Ivana
    jeudi 26 mars 2009 15:06
  • Hi,

    I found a simple workaround for this issue:

    1) Go to Project properties -> Build tab -> Output Path textbox
    2) Change "bin\Release\" to "bin\Release2\"
    3) Build
    4) Change "bin\Release2\" to "bin\Release\"
    5) Build

    Should fix this issue.

    Thanks!
    • Proposé comme réponse Vaccanoll lundi 17 août 2009 21:51
    lundi 15 juin 2009 19:41
  • @ dliedke

    That worked great and saved me a load of time.

    Thanks!
    lundi 17 août 2009 21:49
  • I had this issue, and I had to go into the project files in a text editor, and move the custom configuration group up to the top of the file (right above the debug and release configuration sections), then it ran.

    mercredi 26 mai 2010 19:06
  • This sh*t is f*cking ridiculous.

    The error is flagship microsoft.... completely misleading, useless, and totally sucks the life out of everyone. F*ck you bill gates. F*ck you in the face with a pie.

     

    I've tried all of your workarounds, not a single one fixes the issue. I've had to completely re-do my entire solution to get this working, and it took nearly 14 hours, cause visual studio can't import a f*cking folder. i mean seriously...

     

     

    WHEN THE F*CK ARE YOU GOING TO FIX YOUR GODDAMN CR*P SOFTWARE?!? Oh wait... 2010 is out. That's right, you're going to make me pay for the sequel to this piece of SH*T, and endure a whole new set of life draining errors.

     

    @Microsoft: If I could one day take a massive steamy sh*t on your lawn, I think that only if I made you watch me do so, would you have then made up for the amount of life you have taken from me, with super-fail, bogus, error messages. F*ck you sincerely.

     

    I wish I could report myself for abuse, because I know some ____ is going to find himself offended by this. F*ck you too forum troll. And f*ck this bad word filter. Microsoft deserves tenfold what has righteously escaped my mouth today.
    • Proposé comme réponse dcyuri7 jeudi 8 juillet 2010 11:34
    jeudi 8 juillet 2010 11:16
  • Thanks lambls!

    The snooping bit helped me as well.

    I found that there was an entry missing in my sln file for the project reporting the outputpath error.

    The one in bold below was not there. When i added it, the error went away.

    This error had popped up after migrating to 64 bit dev machine and setting the solution platform to x86 in VS2008.

      {815304A7-3440-4C89-B480-CAD02F60CA05}.Debug|Any CPU.ActiveCfg = Debug|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Debug|Any CPU.Build.0 = Debug|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Debug|x86.ActiveCfg = Debug|x86
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Debug|x86.Build.0 = Debug|x86
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Build|Any CPU.ActiveCfg = Quick Debug|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Build|Any CPU.Build.0 = Quick Debug|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Build|x86.ActiveCfg = Quick Debug|x86
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Build|x86.Build.0 = Quick Debug|x86
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Debug|Any CPU.ActiveCfg = Quick Debug|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Debug|Any CPU.Build.0 = Quick Debug|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Debug|x86.ActiveCfg = Quick Debug|x86
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Quick Debug|x86.Build.0 = Quick Debug|x86
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Release|Any CPU.ActiveCfg = Release|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Release|Any CPU.Build.0 = Release|Any CPU
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Release|x86.ActiveCfg = Release|x86
      {815304A7-3440-4C89-B480-CAD02F60CA05}.Release|x86.Build.0 = Release|x86

     Hope that helps someone also.

    vendredi 10 septembre 2010 15:32
  • I had the same problem - I am glad I noticed this thread

     

    One project had a reference to another project which wasn't in the solution.

     

    I added the missing project and it solved the issue

     

    Thanks

    This was my problem and worked for me, as well.  Thanks!
    mercredi 3 novembre 2010 16:22
  • I had this same warning message.  On the same line as the warning message the IDE also indicates which project the message is coming from.  Close the solution, open the .proj file for that project using a text editor, search for the 'OutputPath' tag, and verify that the path in that tag is actually valid.  Mine was not so I changed it to a valid path, saved the change, and then reloaded my solution.  The warning disappeared, problem solved.
    mercredi 1 décembre 2010 22:53
  • I had the same error, but different cercumstances than I have seen in the forum. I inheritted a large project and was setting up my Dev environment and ran into this error. I didn't have ANY additional project references in either project1 or project2. It just so happens that the original developer used to toss in other projects into his code for testing, then delete them and build. There was some legacy of his most recent cut and paste in the solution, but the config manager and project properties didn't show any signs of that artifact being there.

    To solve the problem I re-added the project1 to project2 (project2 was having the build error) and rebuilt. It worked.

    I then deleted project1 from project2(solution2, actually, but you know what I mean) and rebuilt. It worked and the error went away.

    So it seems there is some vague reference artifact that isn't cleaned up in all cases when adding or changing projects in a solution. Just re-add or re-delete the project causing the problem and that seems to fix it.

    jeudi 10 février 2011 18:50
  • Able to resolve my build error- Just followed the solution posted by Peter Bech Hansen, Denmark

    Great thread, saved tons of time

    vendredi 25 février 2011 15:43
  • This was the best thread I found on the topic of this error so I'd like to add what worked for me.

    I had added a new configuration, but not added or changed any references or done anything else, but after trying and checking everything else, I removed and re-added all the projects referenced by my main project, then cleaned and built (rebuild did not work) and it worked.

    I didn't try this initially since I had not touched the references at all, so I thought others might like to know it is worth trying.

    vendredi 4 novembre 2011 02:22
  • Same problem and same error message here ;-(

     

    Debug and Release builds were OK only our custom "Stage" build failed

    Reason: newly added project had no "Stage" PropertyGroup 

    Solution: just add missing  PropertyGroup in newly added project (in project file) and problem gone.

     

    <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Stage|AnyCPU' ">
    ...
    </PropertyGroup>
    


     


    • Modifié pedja d jeudi 1 décembre 2011 18:56 typo
    jeudi 1 décembre 2011 18:56
  • This worked for me.  I had the issue after converting a project created in VS2008 to VS2010.  Following the steps above fixed my Build issues.
    Jon Kaloz
    jeudi 5 janvier 2012 15:52
  • there is another easy solution

    go to properties of the project, select Build, from drop down- select All Configurations and you will see Output Path empty, put the right path here and thats it.


    Senior Software Engineer/Technical consultant Datel Systems and Software - Dubai - UAE.

    lundi 13 février 2012 11:56
  • (Alternative cause of the problem & solution to this)

    I also experienced a similar issue at compilation:

    ------ Build started: Project: Proj1, Configuration: DebugTest x86 ------

    c:\WINDOWS\Microsoft.NET\Framework\v3.5\Microsoft.Common.targets(539,9): error : The OutputPath property is not set for this project.  Please check to make sure that you have specified a valid Configuration/Platform combination. Configuration='DebugTest'  Platform='x86'
    Done building project "Proj2.csproj" -- FAILED.

    The issue appeared after creating a new branch of my solution. All the OutputPath properties were correctly setup, in fact the issue was the Project Reference Path to dependant projects in the .csproj file. Edit manually your .csproj and look for the <ProjectReference Include="..."> tags. Make sure the full paths in the Include attribute are correct.

    <ItemGroup>
        <ProjectReference Include="..\Configuration\Proj2.csproj">
          <Project>{...}</Project>
          <Name>Proj2</Name>
        </ProjectReference>
    
    </ItemGroup>

    In this case, after updating the path in ProjectReference, the error disappears. 
    Hope this helps.

    Thanks
    Bertrand

    vendredi 1 juin 2012 08:20