none
Déployer une application avec sql server compact

    Question

  • Bonjour,

    j'ai réalisé une application avec visual C#, la base de données est sous SQL Server;

    l'application doit être mise en réseau .

    je ne sais comment réaliser la connection a la base de données?

    dois je installer SQL server sous toutes les stations?

    la base de données sera hébergé par une station et les autres doivent accéder à celle ci.

    Merci


    Marcelle NGOUNOU

    jeudi 6 septembre 2012 09:26

Réponses

  • Bonjour

    Voici un lien sur comment vous devez configurer SQL SERVER EXPRESS pour accepter des connections sur TCP\IP (réseau). Pour EXPRESS ce n’est pas configurée  pendant l’installation.

    Ca dépend  aussi de la version de SQL SERVER EXPRESS

    http://blogs.msdn.com/b/sqlexpress/archive/2005/05/05/415084.aspx

     

    Cordialement,

    Aurel


    Aurel BERA, Microsoft
    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    • Marqué comme réponse marclas vendredi 21 septembre 2012 09:38
    jeudi 20 septembre 2012 11:20
  • bonsoir,

    de retour...

    effectivement en faisant le test sur mon Pc, tout est ok.

    alors je me suis lancé sur une connection sur le poste serveur... ou j ai appliqué les memes politiques..

    pour mon code, j'ai simplemnt remplacé l'adresse IP de ma station par celle de la station serveur...

    et paff!!! Retour au point départ car j'ai le message d'erreur 

    ""A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    je ne sais pas 

    le poste serveur est dans le groupe de travail : XXXXX, le PC serveur 169.254.83.98,...

    je ne sais ou se trouve l'erreur...

    cordialement


    Marcelle NGOUNOU

    Bonsoir,

    Que donne la méthode d'Aurel ?

    Vous retrouverez l'outil de configuration SQL Server par le menu démarrer > Tous les prorammes > Microsoft SQL Server 2008 R2 > Outils de configuration > Gestionnaire de configuration SQL Server.

    Activation TCP/IP :

    Accepter les interfaces réseaux :

    Ah j'oubliais :

    Avez-vous ouvert le port 1433 de votre parefeu Windows ou autre d'une part ?

    Ensuite je viens de voir une de vos réponse concernant le connectionstring suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous êtes en SQL-Express, votre adresse serveur doit être de la forme suivante <nom hote ou IP>\<nom instance SQL>.

    Par défaut lorsque vous installez SQL Express l'instance ce nomme SQLEXPRESS si vous n'avez pas changé. De ce fait votre connectionstring sera le suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98\SQLEXPRESS;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous utilisez le port par défaut pas nécessaire de l'indiquer dans la chaine.

    Est-ce que ça résout le problème ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !




    bonjour,

    Le service est bien demarre et les protocoles aussi.

    jai porte une petite modif sur le Natif client ou j'ai ajoute le numero de port.... 

    Maintenant,... je reussi pas a me connecter encore mais une petite evolution car le message d'erreur a evolue, il est le suivant:

    "Login failed for user "ReclamRPT\Invite" (Je suis sur mon poste de code)

    -----je crois qu'en ce moment le poste "serveur" est utilise par l'operateur "Invite" ce qui genere l'erreur,

    ----Je pense qu'il faudrait qu'a partir de mon compte, je puisse ouvrir la session avec une authentification Sqlserver

    sur le poste serveur, j ai bien pu me connecter avec ce type de compte...mais a partir de mon poste

    en precisant nom du serveur=NomStation,Authentification SQLServer,Connexion et mot de passe (Celui qui m'a permis d'ouvrir la connexion sur le poste serveur),

    j'ai l'erreur impossible de se conecter a reclamRPT (tout a leur j avais le long message...)....

    cordialemen


    Marcelle NGOUNOU

    Bonjour,

    Il faut ajouter l'utilsateur Windows dans les connexions SQL via SQL Management Studio (voir SD-20666\adminout) :

    Ensuite lui donner les autorisations sur la base de donnée, exemple :

    (ajout) :

    Est-ce que le compte invité est activé ? (car il est désactivé par défaut)

    Est-ce que cela fonctionne ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !



    • Modifié Lyamine vendredi 21 septembre 2012 09:14
    • Marqué comme réponse marclas vendredi 21 septembre 2012 09:36
    vendredi 21 septembre 2012 08:54
  • bonsoir,

    de retour...

    effectivement en faisant le test sur mon Pc, tout est ok.

    alors je me suis lancé sur une connection sur le poste serveur... ou j ai appliqué les memes politiques..

    pour mon code, j'ai simplemnt remplacé l'adresse IP de ma station par celle de la station serveur...

    et paff!!! Retour au point départ car j'ai le message d'erreur 

    ""A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    je ne sais pas 

    le poste serveur est dans le groupe de travail : XXXXX, le PC serveur 169.254.83.98,...

    je ne sais ou se trouve l'erreur...

    cordialement


    Marcelle NGOUNOU

    Bonsoir,

    Que donne la méthode d'Aurel ?

    Vous retrouverez l'outil de configuration SQL Server par le menu démarrer > Tous les prorammes > Microsoft SQL Server 2008 R2 > Outils de configuration > Gestionnaire de configuration SQL Server.

    Activation TCP/IP :

    Accepter les interfaces réseaux :

    Ah j'oubliais :

    Avez-vous ouvert le port 1433 de votre parefeu Windows ou autre d'une part ?

    Ensuite je viens de voir une de vos réponse concernant le connectionstring suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous êtes en SQL-Express, votre adresse serveur doit être de la forme suivante <nom hote ou IP>\<nom instance SQL>.

    Par défaut lorsque vous installez SQL Express l'instance ce nomme SQLEXPRESS si vous n'avez pas changé. De ce fait votre connectionstring sera le suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98\SQLEXPRESS;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous utilisez le port par défaut pas nécessaire de l'indiquer dans la chaine.

    Est-ce que ça résout le problème ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !




    bonjour,

    Le service est bien demarre et les protocoles aussi.

    jai porte une petite modif sur le Natif client ou j'ai ajoute le numero de port.... 

    Maintenant,... je reussi pas a me connecter encore mais une petite evolution car le message d'erreur a evolue, il est le suivant:

    "Login failed for user "ReclamRPT\Invite" (Je suis sur mon poste de code)

    -----je crois qu'en ce moment le poste "serveur" est utilise par l'operateur "Invite" ce qui genere l'erreur,

    ----Je pense qu'il faudrait qu'a partir de mon compte, je puisse ouvrir la session avec une authentification Sqlserver

    sur le poste serveur, j ai bien pu me connecter avec ce type de compte...mais a partir de mon poste

    en precisant nom du serveur=NomStation,Authentification SQLServer,Connexion et mot de passe (Celui qui m'a permis d'ouvrir la connexion sur le poste serveur),

    j'ai l'erreur impossible de se conecter a reclamRPT (tout a leur j avais le long message...)....

    cordialemen


    Marcelle NGOUNOU

    Bonjour,

    Il faut ajouter l'utilsateur Windows dans les connexions SQL via SQL Management Studio (voir SD-20666\adminout) :

    Ensuite lui donner les autorisations sur la base de donnée, exemple :

    (ajout) :

    Est-ce que le compte invité est activé ? (car il est désactivé par défaut)

    Est-ce que cela fonctionne ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !



    Bonjour,

    MERCI j'avais oulie cette etape..

    C fait et tout est OK

    Cordialement


    Marcelle NGOUNOU

    vendredi 21 septembre 2012 09:36

Toutes les réponses

  • bonjour,

    j'ai trouvé ce lien qui est fort interresant

    http://msdn.microsoft.com/en-us/library/bb219481(d=printer,v=sql.90).aspx

    toutefois,

    en pratiquant, je me rends compte que je n'ai pas le System.Data.SQlServerCe dans mes références....

    Pourtant il figure bien dans le repertoire de SQL server compact Edition

    Merci de m'aider!!


    Marcelle NGOUNOU

    jeudi 6 septembre 2012 13:40
  • Bonjour,

    as-tu fait un click droit sur référence, ajouter puis en choisissant la DLL System.Data.SQlServerCe ?

    Tu peux regarder ce thread.


    fred on youTube

    fred


    • Modifié fred75 jeudi 6 septembre 2012 22:03
    jeudi 6 septembre 2012 22:01
  • Bonjour,
     
    Je ne suis pas sûr que SQL CE soit le plus indiqué pour partager une
    base. Même si, à priori, la dernière version supporte les connexions
    simultanées dans le cadre d'une application web.
     
    Je pense qu'il serait plus raisonnable d'installer SQL Server Express
    sur le poste "serveur".
     
    Il est possible que le nombre de connexions en mode authentification
    windows soit limité par le système si ce n'est pas un système serveur.
    Je n'ai pas testé cela.
    Cela devrait passer en authentification SQL sans limitation.
     

    Fred
    vendredi 7 septembre 2012 07:18
  • Bonjour,

    Je me suis posé plusieurs fois la question et http://msdn.microsoft.com/fr-fr/library/ms171763(v=sql.90) semble confirmer :

    "Lorsque vous ouvrez une base de données qui se trouve dans un partage de fichiers, la seule option disponible est le mode de fichier DB_MODE_SHARE_EXCLUSIVE."

    Donc en clair :
    - SQL Server Compact est destiné exclusivement à avoir une base de données accédée par un processus local (éventuellement plusieurs utilisateurs mais depuis la même machine par exemple dans le cadre d'une appli Web)
    - pour une appli multi-utilisateur (par exemple une application Windows depuis plusieurs machines), il est probablement nécessaire de passer à SQL Server Express (et donc dans ce cas, SQL Server Express est installée sur une machine qui jouera le rôle de serveur base de données et les autres machines se connecteront à cette même base, attention par défaut SQL Server Express est configuré pour ne pas accepter les connexions d'autres machines voir http://msdn.microsoft.com/fr-fr/library/ms165647(v=sql.90).aspx).


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".


    dimanche 9 septembre 2012 11:56
  • Bonjour,

    Merci pour toutes vos explications,

    Mais comme on dit chez moi "le tour ci" j'ai besoin de pas à pas.

    EN fait s'agit il d'installer SQL server Express 2008 sur le poste "serveur" ou SQL Server 2008 (Dont je dispose)?

    Merci


    Marcelle NGOUNOU

    dimanche 9 septembre 2012 16:42
  • Bonjour,

    Si vous avez SQL Server 2008 c'est encore mieux que la version express donc je vous conseille de l'installer sur le poste "serveur".

    Il y a pleins de vidéo sur le pas à pas de l'installation de SQL Serveur sur YouTube si vous avez des soucis


    fred on youTube

    fred

    dimanche 9 septembre 2012 17:23
  • Bonjour,
     
    Pour répondre précisément il faut plus d'informations.
    Toutes les éditions de SQL server ne peuvent pas s'installer sur un OS
    non serveur.
    L'avantage de la version Express, qui sera sans doute suffisante pour
    vos besoins, est qu'elle est gratuite et sans limitation de connexions.
    Les versions payantes de SQL server ont divers modes de licences, et en
    particulier un mode qui est d'avoir une licence d'accès pour chaque
    connexion.
    Quelle est votre édition de SQL Server ?
     

    Fred
    lundi 10 septembre 2012 07:23
  • bonjour,

    je dispose de SQL SERVER 2008 Express edition SP1

    cordialement


    Marcelle NGOUNOU

    lundi 10 septembre 2012 08:51
  • bonjour,

    l'application que je souhaite déployer est réalisé sous VS2010 C#,

    j'ai pu publier mon application (on omettant crystal report qui genere une erreru)

    l'application s'installe

    Mais je se retrouve pas le dossier dans le quel il est installé.

    en fait nulle part il ne m'est proposé de choisir l'endroit ou je voudrais installer mon application

    ceci est problématique car je voudrais changer les informations de connexion à la base de données car le nom de l'intance change sur la machine ("Serveur") ou j'effectue l'installation.

    Merci


    Marcelle NGOUNOU

    jeudi 13 septembre 2012 15:09
  • Bonjour,

    Les application publiées via ClickOnce sont déployées dans le répertoire de l'utilisateur.

    Vous devez modifier la chaîne de connection du fichier .config avant de lancer la publication ClickOnce.

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    jeudi 13 septembre 2012 22:09
  • Si votre installation est effectuée avec ClickOnce, le répertoire d'installation est "caché" (une appli ClickOnce n'a pas tous les droits d'une appli classique).

    De plus, si la chaine de connexion à votre base de données est dépendante de l'installation, il est préférable de ne pas utiliser les fichiers de configuration pour stocker cette information. Il est préférable de "calculer" cette chaine. Par exemple, au lancement de votre appli, vous déterminez par le code cette chaine de connexion.


    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    vendredi 14 septembre 2012 05:19
  • bonjour,

    Richard, ta proposition est bonne et c'est vrai que ceci pourrait éviter des erreurs... (si mon fichier de config devient corrompu...).

    Moi je vois bien ce que je voudrais

    etapes:

    1- Localiser SQL SERVER

    2-Localiser le Base de données (qui porte Xnom)

    3- Se connecter à cette base de données

    4-Si connexion OK alors Que l'appli s'ouvre!

    Mais le Hic c'est bien comment impléménter cela???

    Car déja quant je fais juste un réseau simple en ecrivant le chemin d'accès ... Paf!! erreur : Chemin réseau non trouvé!!


    Marcelle NGOUNOU

    dimanche 16 septembre 2012 11:31
  • Bonjour,

    Comment connectez vous à votre base de données ? (Pouvez-vous nous montrer le code qui pose problème ?).

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    dimanche 16 septembre 2012 21:29
  • Bonjour,

    le code ci joint

                    

            public static void InitConnexionMobile()
            {
                try
                {
                    //instancier l'objet de connexion
                    m_Connexion = new SqlConnection(Properties.Settings.Default.cnStr);

                    //instancier l'objet de connexion réseau
                    //m_Connexion = new SqlConnection(@"Data Source = |DataDirectory|\RECLACSR-DB.mdf");

                    //instancier l'objet de connexion mono
                    //m_Connexion = new SqlConnection(@"Data Source = |DataDirectory|RECLACSR-DB.mdf");
                    //Ouvrir la connexion à la bd
                    m_Connexion.Open();

                    //creer la commande et indiquer le type de commande
                    m_commande = m_Connexion.CreateCommand();
                    m_commande.CommandType = CommandType.StoredProcedure;
                }
                catch (Exception ex)
                {
                    //lever une exception et l'ecrire dans le journal d'événement windows
                    EventLog.GetEventLogs(ex.Message);
                }

            }

    y a que la connexion a partir des paramètres par défaut qui fonctionne.

    cordialment


    Marcelle NGOUNOU

    lundi 17 septembre 2012 03:50
  • bonjour Richard,

    si ce repertoir est "caché"... comment y avoir accès car malgré le fait d'avoir activé les apramtres affichés les dossiers cachés...RIEN

    ou alors y' a un til un autre moyend e deployment qui me permettrait de mieux gerer mon déployement? (afin de pouvoir calculer la chaine de connexion..)?

    cordialement


    Marcelle NGOUNOU

    mardi 18 septembre 2012 04:56
  • Si le chemin est relatif à l'emplacement de l'exe, vous pouvez utiliser :

    System.IO.Path.GetDirectory(System.Reflection.Assembly.GetExecutingAssembly.Location)

    Cela vous donne le répertoire de l'exe.


    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    mardi 18 septembre 2012 05:56
  • Bonjour,

    Est-ce que vous avez testé les solutions proposées ? Merci de partager avec nous les résultats, afin que d'autres personnes avec le même problème puissent profiter de cette solution.

    Cordialement,

    Aurel


    Aurel BERA, Microsoft
    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    mercredi 19 septembre 2012 08:08
  •  

    Bonjour

    Voici un lien sur votre problème:

    http://msdn.microsoft.com/fr-fr/library/dd981045(v=sql.100).aspx

    Pour traduire en français vous pouvez utiliser http://www.bing.com/translator/

    Merci de partager avec nous les résultats, afin que d'autres personnes avec le même problème puissent profiter de cette solution.

    Cordialement, 


    Aurel BERA, Microsoft
    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    mercredi 19 septembre 2012 09:43
  • Bonjour,

    Pour le moment,
    j'ai installé SQL server Express 2008, SP1 sur la station devant etre "Serveur"

    et elle héberge la base de donnée.

    Comment faire pour que les autres stations, à travers mon application puisse accéder à SQL SERVER,
    car malgré ce code dans mon code...rien (au niveau de code déja ca marche pas)
    "
                    Properties.Settings.Default.MaChaineConnexion = "Network Library=DBMSSOCN;" +
                                                                    "Data Source=169.254.96.55,1433;" +
                                                                    "Initial Catalog=RECLACSR-DB;Integrated Security=SSPI";
    "

    j'ai bien configuré SQL server pour qu'il accepte les connexion a distance, et activé tout les propriété TC/IP

    l'erreur suivante s’affiche à l'execution
    "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - Une tentative de connexion a échoué car le parti connecté n’a pas répondu convenablement au-delà d’une certaine durée ou une connexion établie a échoué car l’hôte de connexion n’a pas répondu.)"

    cordialement,


    Marcelle NGOUNOU

    jeudi 20 septembre 2012 04:57
  • Si le chemin est relatif à l'emplacement de l'exe, vous pouvez utiliser :

    System.IO.Path.GetDirectory(System.Reflection.Assembly.GetExecutingAssembly.Location)

    Cela vous donne le répertoire de l'exe.


    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    Bonjour,

    Dis s'agit il de l'exe en cours ou de celui installé sur le PC tiers?

    car c'est bien lui ()celui du PC tiers) que je cherche avec ses paramètres de configuation

    cordialement


    Marcelle NGOUNOU

    jeudi 20 septembre 2012 04:58
  • Bonjour

    Ici on parle du chemin sur la machine ou le programme est exécuté.

    Si la BD est dans la même répertoire que le fichier .exe vous devez initialiser la chaine de connections  avec

    m_Connexion = new SqlConnection(System.IO.Path.GetDirectory(System.Reflection.Assembly.GetExecutingAssembly.Location) + “nom_bd.mdf”);

    Cordialement,

     


    Aurel BERA, Microsoft
    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    jeudi 20 septembre 2012 09:10
  • bonjour,

    en local, tout se passe bien. et la BD est bien sur le serveur en local (Pste de developpement)

    je veux partir de ce poste pour le Poste Tiers AA sur leauel, j ai installe SQLserver et ou est/sera heberge la Bd.

    ce poste a pour adresse IP 169.254.83.98

    et la je voudrais faire ma chaine de connection de telle sorte que l'on se connecte sur ce poste AA eyant la BD

    alors j'ecris ceci dans mon code:

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    mais j 'ai lerreur

    "A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    PS Ma chaine de connexion locale est : "Properties.Settings.Default.MaChaineDeConnexion = "server=(local)\\SQLEXPRESS;database=RECLACSR-DB;Integrated Security=SSPI;User ID=CompteSAD; Password=pswd_sad";"

    en remplacant par : en remplacant dans mon code de chaine de connection local par :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.50 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI"

    169.254.83.50 etant l'IP du poste local, je ne parviens pas a me connecter la meme erreur s'affiche

    Cordialement


    Marcelle NGOUNOU

    jeudi 20 septembre 2012 10:58
  • Bonjour

    Voici un lien sur comment vous devez configurer SQL SERVER EXPRESS pour accepter des connections sur TCP\IP (réseau). Pour EXPRESS ce n’est pas configurée  pendant l’installation.

    Ca dépend  aussi de la version de SQL SERVER EXPRESS

    http://blogs.msdn.com/b/sqlexpress/archive/2005/05/05/415084.aspx

     

    Cordialement,

    Aurel


    Aurel BERA, Microsoft
    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    • Marqué comme réponse marclas vendredi 21 septembre 2012 09:38
    jeudi 20 septembre 2012 11:20
  • Bonjour,

    sur mon poste de developpement c OK (la connexion avec adresse IP!)

    Now je vaiss m'attaquer a l'autre station...

    j'Arrive...


    Marcelle NGOUNOU

    jeudi 20 septembre 2012 11:46
  • bonsoir,

    de retour...

    effectivement en faisant le test sur mon Pc, tout est ok.

    alors je me suis lancé sur une connection sur le poste serveur... ou j ai appliqué les memes politiques..

    pour mon code, j'ai simplemnt remplacé l'adresse IP de ma station par celle de la station serveur...

    et paff!!! Retour au point départ car j'ai le message d'erreur 

    ""A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    je ne sais pas 

    le poste serveur est dans le groupe de travail : XXXXX, le PC serveur 169.254.83.98,...

    je ne sais ou se trouve l'erreur...

    cordialement


    Marcelle NGOUNOU

    jeudi 20 septembre 2012 19:11
  • bonsoir,

    de retour...

    effectivement en faisant le test sur mon Pc, tout est ok.

    alors je me suis lancé sur une connection sur le poste serveur... ou j ai appliqué les memes politiques..

    pour mon code, j'ai simplemnt remplacé l'adresse IP de ma station par celle de la station serveur...

    et paff!!! Retour au point départ car j'ai le message d'erreur 

    ""A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    je ne sais pas 

    le poste serveur est dans le groupe de travail : XXXXX, le PC serveur 169.254.83.98,...

    je ne sais ou se trouve l'erreur...

    cordialement


    Marcelle NGOUNOU

    Bonsoir,

    Que donne la méthode d'Aurel ?

    Vous retrouverez l'outil de configuration SQL Server par le menu démarrer > Tous les prorammes > Microsoft SQL Server 2008 R2 > Outils de configuration > Gestionnaire de configuration SQL Server.

    Activation TCP/IP :

    Accepter les interfaces réseaux :

    Ah j'oubliais :

    Avez-vous ouvert le port 1433 de votre parefeu Windows ou autre d'une part ?

    Ensuite je viens de voir une de vos réponse concernant le connectionstring suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous êtes en SQL-Express, votre adresse serveur doit être de la forme suivante <nom hote ou IP>\<nom instance SQL>.

    Par défaut lorsque vous installez SQL Express l'instance ce nomme SQLEXPRESS si vous n'avez pas changé. De ce fait votre connectionstring sera le suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98\SQLEXPRESS;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous utilisez le port par défaut pas nécessaire de l'indiquer dans la chaine.

    Est-ce que ça résout le problème ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !




    • Modifié Lyamine vendredi 21 septembre 2012 05:30
    jeudi 20 septembre 2012 20:56
  • Bonjour,
     
    Vous spécifiez le port dans la chaîne de connexion.
    Dans ce cas, il faut s'assurer que le serveur SQL écoute bien sur ce
    port. Par défaut, il écoute sur un port dynamique que renvoie le SQL
    Browser au client via le port 1434 (de mémoire).
    Dans la configuration de SQL Server (Outils de configuration) activez le
    tcp ip, puis, pour faire simple, dans la rubrique IP All (tout en bas de
    l'onglet adresses des propriétés TCP IP, mettez à blanc la propriété TCP
    Dynamic Ports et 1433 dans TCP Port.
    Après ceci, vous pourrez également désactiver le service SQL Browser qui
    ne sert plus à rien.
     
    Assurez-vous que le Firewall du poste accepte les connexions entrantes
    sur le port 1433.
     
    Vous utilisez l'authentification Windows. Comme signalé dans un
    précédent post, testez bien que vous n'êtes pas limité en nombre de
    connexions simultanées. Je n'ai pas vérifié ce point, mais il est
    possible que vous soyez soumis aux même restrictions que pour le partage
    de fichiers ou d'imprimantes (5 ou  10 selon le système je crois). Si
    c'est le cas, passez en authentification SQL Server.
     
    D'autre part, en authentification Windows, vous dépendez du type de
    réseau (Active Directory ou non). L'utilisateur du poste client a-t-il
    des droits de connexion au SQL server ? S'il n'y a pas d'active
    directory, il faut que les utilisateurs Windows soient les mêmes sur le
    poste client et le poste serveur. Bref, beaucoup de choses à penser et à
    configurer.
     

    Fred
    vendredi 21 septembre 2012 05:53
  • bonsoir,

    de retour...

    effectivement en faisant le test sur mon Pc, tout est ok.

    alors je me suis lancé sur une connection sur le poste serveur... ou j ai appliqué les memes politiques..

    pour mon code, j'ai simplemnt remplacé l'adresse IP de ma station par celle de la station serveur...

    et paff!!! Retour au point départ car j'ai le message d'erreur 

    ""A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    je ne sais pas 

    le poste serveur est dans le groupe de travail : XXXXX, le PC serveur 169.254.83.98,...

    je ne sais ou se trouve l'erreur...

    cordialement


    Marcelle NGOUNOU

    Bonsoir,

    Que donne la méthode d'Aurel ?

    Vous retrouverez l'outil de configuration SQL Server par le menu démarrer > Tous les prorammes > Microsoft SQL Server 2008 R2 > Outils de configuration > Gestionnaire de configuration SQL Server.

    Activation TCP/IP :

    Accepter les interfaces réseaux :

    Ah j'oubliais :

    Avez-vous ouvert le port 1433 de votre parefeu Windows ou autre d'une part ?

    Ensuite je viens de voir une de vos réponse concernant le connectionstring suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous êtes en SQL-Express, votre adresse serveur doit être de la forme suivante <nom hote ou IP>\<nom instance SQL>.

    Par défaut lorsque vous installez SQL Express l'instance ce nomme SQLEXPRESS si vous n'avez pas changé. De ce fait votre connectionstring sera le suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98\SQLEXPRESS;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous utilisez le port par défaut pas nécessaire de l'indiquer dans la chaine.

    Est-ce que ça résout le problème ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !




    bonjour,

    Le service est bien demarre et les protocoles aussi.

    jai porte une petite modif sur le Natif client ou j'ai ajoute le numero de port.... 

    Maintenant,... je reussi pas a me connecter encore mais une petite evolution car le message d'erreur a evolue, il est le suivant:

    "Login failed for user "ReclamRPT\Invite" (Je suis sur mon poste de code)

    -----je crois qu'en ce moment le poste "serveur" est utilise par l'operateur "Invite" ce qui genere l'erreur,

    ----Je pense qu'il faudrait qu'a partir de mon compte, je puisse ouvrir la session avec une authentification Sqlserver

    sur le poste serveur, j ai bien pu me connecter avec ce type de compte...mais a partir de mon poste

    en precisant nom du serveur=NomStation,Authentification SQLServer,Connexion et mot de passe (Celui qui m'a permis d'ouvrir la connexion sur le poste serveur),

    j'ai l'erreur impossible de se conecter a reclamRPT (tout a leur j avais le long message...)....

    cordialemen


    Marcelle NGOUNOU

    vendredi 21 septembre 2012 08:47
  • bonsoir,

    de retour...

    effectivement en faisant le test sur mon Pc, tout est ok.

    alors je me suis lancé sur une connection sur le poste serveur... ou j ai appliqué les memes politiques..

    pour mon code, j'ai simplemnt remplacé l'adresse IP de ma station par celle de la station serveur...

    et paff!!! Retour au point départ car j'ai le message d'erreur 

    ""A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    je ne sais pas 

    le poste serveur est dans le groupe de travail : XXXXX, le PC serveur 169.254.83.98,...

    je ne sais ou se trouve l'erreur...

    cordialement


    Marcelle NGOUNOU

    Bonsoir,

    Que donne la méthode d'Aurel ?

    Vous retrouverez l'outil de configuration SQL Server par le menu démarrer > Tous les prorammes > Microsoft SQL Server 2008 R2 > Outils de configuration > Gestionnaire de configuration SQL Server.

    Activation TCP/IP :

    Accepter les interfaces réseaux :

    Ah j'oubliais :

    Avez-vous ouvert le port 1433 de votre parefeu Windows ou autre d'une part ?

    Ensuite je viens de voir une de vos réponse concernant le connectionstring suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous êtes en SQL-Express, votre adresse serveur doit être de la forme suivante <nom hote ou IP>\<nom instance SQL>.

    Par défaut lorsque vous installez SQL Express l'instance ce nomme SQLEXPRESS si vous n'avez pas changé. De ce fait votre connectionstring sera le suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98\SQLEXPRESS;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous utilisez le port par défaut pas nécessaire de l'indiquer dans la chaine.

    Est-ce que ça résout le problème ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !




    bonjour,

    Le service est bien demarre et les protocoles aussi.

    jai porte une petite modif sur le Natif client ou j'ai ajoute le numero de port.... 

    Maintenant,... je reussi pas a me connecter encore mais une petite evolution car le message d'erreur a evolue, il est le suivant:

    "Login failed for user "ReclamRPT\Invite" (Je suis sur mon poste de code)

    -----je crois qu'en ce moment le poste "serveur" est utilise par l'operateur "Invite" ce qui genere l'erreur,

    ----Je pense qu'il faudrait qu'a partir de mon compte, je puisse ouvrir la session avec une authentification Sqlserver

    sur le poste serveur, j ai bien pu me connecter avec ce type de compte...mais a partir de mon poste

    en precisant nom du serveur=NomStation,Authentification SQLServer,Connexion et mot de passe (Celui qui m'a permis d'ouvrir la connexion sur le poste serveur),

    j'ai l'erreur impossible de se conecter a reclamRPT (tout a leur j avais le long message...)....

    cordialemen


    Marcelle NGOUNOU

    Bonjour,

    Il faut ajouter l'utilsateur Windows dans les connexions SQL via SQL Management Studio (voir SD-20666\adminout) :

    Ensuite lui donner les autorisations sur la base de donnée, exemple :

    (ajout) :

    Est-ce que le compte invité est activé ? (car il est désactivé par défaut)

    Est-ce que cela fonctionne ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !



    • Modifié Lyamine vendredi 21 septembre 2012 09:14
    • Marqué comme réponse marclas vendredi 21 septembre 2012 09:36
    vendredi 21 septembre 2012 08:54
  • bonsoir,

    de retour...

    effectivement en faisant le test sur mon Pc, tout est ok.

    alors je me suis lancé sur une connection sur le poste serveur... ou j ai appliqué les memes politiques..

    pour mon code, j'ai simplemnt remplacé l'adresse IP de ma station par celle de la station serveur...

    et paff!!! Retour au point départ car j'ai le message d'erreur 

    ""A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured  to allow remote connections.  (provider: TCP Provider, error: 0 - Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.)"

    je ne sais pas 

    le poste serveur est dans le groupe de travail : XXXXX, le PC serveur 169.254.83.98,...

    je ne sais ou se trouve l'erreur...

    cordialement


    Marcelle NGOUNOU

    Bonsoir,

    Que donne la méthode d'Aurel ?

    Vous retrouverez l'outil de configuration SQL Server par le menu démarrer > Tous les prorammes > Microsoft SQL Server 2008 R2 > Outils de configuration > Gestionnaire de configuration SQL Server.

    Activation TCP/IP :

    Accepter les interfaces réseaux :

    Ah j'oubliais :

    Avez-vous ouvert le port 1433 de votre parefeu Windows ou autre d'une part ?

    Ensuite je viens de voir une de vos réponse concernant le connectionstring suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98 ,1433;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous êtes en SQL-Express, votre adresse serveur doit être de la forme suivante <nom hote ou IP>\<nom instance SQL>.

    Par défaut lorsque vous installez SQL Express l'instance ce nomme SQLEXPRESS si vous n'avez pas changé. De ce fait votre connectionstring sera le suivant :

    Properties.Settings.Default.MaChaineDeConnexion = "Network Library=DBMSSOCN;Data source=169.254.83.98\SQLEXPRESS;Initial Catalog=RECLACSR;" +
                    //            "User ID=CompteSAD; Password=pswd_sad;Integrated Security=SSPI";

    Comme vous utilisez le port par défaut pas nécessaire de l'indiquer dans la chaine.

    Est-ce que ça résout le problème ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !




    bonjour,

    Le service est bien demarre et les protocoles aussi.

    jai porte une petite modif sur le Natif client ou j'ai ajoute le numero de port.... 

    Maintenant,... je reussi pas a me connecter encore mais une petite evolution car le message d'erreur a evolue, il est le suivant:

    "Login failed for user "ReclamRPT\Invite" (Je suis sur mon poste de code)

    -----je crois qu'en ce moment le poste "serveur" est utilise par l'operateur "Invite" ce qui genere l'erreur,

    ----Je pense qu'il faudrait qu'a partir de mon compte, je puisse ouvrir la session avec une authentification Sqlserver

    sur le poste serveur, j ai bien pu me connecter avec ce type de compte...mais a partir de mon poste

    en precisant nom du serveur=NomStation,Authentification SQLServer,Connexion et mot de passe (Celui qui m'a permis d'ouvrir la connexion sur le poste serveur),

    j'ai l'erreur impossible de se conecter a reclamRPT (tout a leur j avais le long message...)....

    cordialemen


    Marcelle NGOUNOU

    Bonjour,

    Il faut ajouter l'utilsateur Windows dans les connexions SQL via SQL Management Studio (voir SD-20666\adminout) :

    Ensuite lui donner les autorisations sur la base de donnée, exemple :

    (ajout) :

    Est-ce que le compte invité est activé ? (car il est désactivé par défaut)

    Est-ce que cela fonctionne ?

    Cordialement


    Merci de valider par "Proposer comme réponse" si celle-ci répond a votre demande !



    Bonjour,

    MERCI j'avais oulie cette etape..

    C fait et tout est OK

    Cordialement


    Marcelle NGOUNOU

    vendredi 21 septembre 2012 09:36
  • MERCI A TOUS

    JE CROIS QU IL FAUDRAIT QUE JE FASSE UN MEMO DU PAS A PAS 

    CA AIDERA BIEN 

    MERCI

    CORDIALEMENT


    Marcelle NGOUNOU

    vendredi 21 septembre 2012 09:38