none
AntiXssLibrary 4.2 - Unable to add to GAC

    Question

  • Version 4.2 of the AntiXssLibrary was released yesterday to patch a security vulnerability.  After installing, though, I see there are now 3 versions of the AntiXSSLibrary.dll for each of the .NET versions.  I've found that if you attempt to add any of these 3 dll's to the GAC you get the following error: "Invalid file or assembly name."

    I checked the file properties for the DLL and see that the OriginalFileName for each is listed as: AntiXSSLibrary20.dll,  AntiXSSLibrary35.dll, and AntiXSSLibrary40.dll.  I then renamed the dll to correspond with the OriginalFileName listed and now I am able to add the assembly to the GAC.  The drawback, however, is now the file name has changed so I need to update my build script accordingly as well.

    I assume this is a mistake in the release? 
    mercredi 11 janvier 2012 18:28

Réponses