none
Issue with binding in new Blend Preview 5.

    Question

  • I installed the new preview for silverlight 5 today since the last one expired last month. I am now having an issue with binding. For example, If I click the square box beside with for an element, go to databinding, click element property tab, my OK button is grayed out even if I have a matching type selected.

    So I will have a button, try to bind its width to another button's width, but the OK button is always grayed out. I can type the binding in manually in the source. Then, if I go back and try to do databinding on that element, the OK button is ungrayed out and I can databind to other things like normal.

    Monday, April 02, 2012 1:28 PM

All replies

  • The Binding "OK" Button is also grayed out on Blend 4 with the Windows 8 Consumer Preview Evaluation Copy.

    ~Christine

    Edit...

    If you go into the XAML and start the binding in the XAML code...

    <TextBlock HorizontalAlignment="Left" TextWrapping="Wrap" Text="{Binding }" VerticalAlignment="Top" Margin="0,19.96,0,0"/>

    Then the button will become enabled. 

    Wednesday, April 04, 2012 11:09 PM
  • Some input would be much appreciated, Microsoft.
    Thursday, April 05, 2012 2:56 PM
  • I have this same issue with the OK button being disabled.  But for me, Christine's work around does not work.  The OK button becomes enabled, but the data binding is not created properly upon closing the dialog.

    I am using Expression Blend 4 with .NET Framework 4.5 RC and Visual Studio 2012 RC installed.


    • Edited by Moozhe Saturday, July 28, 2012 3:02 AM
    Saturday, July 28, 2012 3:01 AM
  • I have this same issue with the OK button being disabled.  But for me, Christine's work around does not work.  The OK button becomes enabled, but the data binding is not created properly upon closing the dialog.

    I am using Expression Blend 4 with .NET Framework 4.5 RC and Visual Studio 2012 RC installed.


    Christine's work around doesn't work for Christine either. :)  I've just gotten in the habit of starting the binding that way and manually coding it.

    They were aware of the issue a month or so ago.  I hope a fix is available soon.

    ~Christine


    My Gallery

    Saturday, July 28, 2012 6:23 PM
  • I have the same problem also with a red box around the Binding Direction.  Just binding 2 textboxes together with the Text property.  If you enter some binding by hand, then Expression will accept the rest of the bindings.

    Navy Firefighting Engineer


    Wednesday, August 01, 2012 1:51 AM
  • I had the same problem but I solved it with the Element Property Binding :

    • Proposed as answer by DSONG Monday, February 11, 2013 3:27 AM
    Friday, November 02, 2012 10:57 AM
  • Use "Element Property Binding..." to build a binding (any kind), then “Data Binding...” will show 【OK】enabled!Now you can use Data Binding...
    Monday, February 11, 2013 3:31 AM
  • Same issue here. the OK button is grayed out and trying to something as simple as binding the content of a label to the content of another label produces an error "The property value is not valid"

    No Response from Microsoft more then a year later???


    BTW - This is the same in 2013 also.
    • Edited by PaulWheeler Wednesday, November 20, 2013 2:28 PM
    Tuesday, November 19, 2013 3:51 PM