none
HTML5 Video - Internet Explorer restricted this webpage from running scripts or ActiveX controls

    Question

  • I have the following code in a static HTML file:

    <!DOCTYPE HTML>
    <html>
    <head>
     <title>New Video Tag Test</title>
    </head>
    <body>
     <h1>Html5 Video Tag</h1>
     <video controls="controls" width="400">
      <source src="movie.mp4" type="video/mp4" />
      Your browser does not support the video tag.
     </video>
    </body>
    </html>

    When I preview the page in IE9, I get a message / popup at the bottom of the browser:

    "Internet Explorer restricted this webpage from running scripts or ActiveX controls" and there is a button "Allow blocked content"

    Why is this popup appearing?

    PS. My extpectaion is that considering HTML5 incorprates a video tag, and IE9 supports HTML5, there should be no popup to the end user / visitor becuase this would only scare them into possibly believing there is something nasty on the web page.

     

     

    Thursday, June 02, 2011 12:25 AM

Answers

  • Local files have more security.  IE pops that up on lots of things if you preview locally.  It has nothing to do with what your visitors will see on your site when you publish.

    Easiest way to see what they will see: Set all pages to preview through the development server.  See if the warning goes away.

     

    • Marked as answer by John 09 Monday, June 06, 2011 1:32 AM
    Thursday, June 02, 2011 12:32 AM

All replies

  • Local files have more security.  IE pops that up on lots of things if you preview locally.  It has nothing to do with what your visitors will see on your site when you publish.

    Easiest way to see what they will see: Set all pages to preview through the development server.  See if the warning goes away.

     

    • Marked as answer by John 09 Monday, June 06, 2011 1:32 AM
    Thursday, June 02, 2011 12:32 AM
  • Thanks Kathy

    I temporarily uploaded the HTML file to the web host and it worked Okay.

    Monday, June 06, 2011 1:34 AM
  • This will fix the problem:  Go to Tools->Internet Options->Advanced Tab, scroll to the Security section and check 'Allow active content to run in files on My Computer'.

    Wednesday, March 07, 2012 12:40 AM
  • Brenda, it will fix the problem, but open your computer to security risks from other files.  My answer fixes the problem within EW, without opening your computer to risks.
    Wednesday, March 07, 2012 1:41 AM
  • Brenda,

    The method Kathy posted of going to Site > Site Settings > Preview tab and changing it to use the local web server for all pages so the site is viewed in the internet zone is a much better approach than allowing all internet sites to access your file system. That's a good way to end up with a trojan compromising your computer.


    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com

    Wednesday, March 07, 2012 1:52 AM