locked
error al conectarme a sql server 2008

    Pregunta

  • tengo el siguiente problema...

    error relacionado con la red o especifico de la instancia mientras se establecia una conexion con el servidor sql server. no se encontro el servidor o este no estaba accesible. compruebe que el nombre de la instancia es correcta y que sql server esta configurado para admitir conexiones remotas.(provider: proveedor de canalizaciones con nombre, error 40 - no se pudo abrir una conexion con sql server) (microsoft sql server error 53)

     

    la verdad antes el sql me funcionaba perfectamente no se si tenga algo q ver pero hace un tiempo conecte mi laptop q tiene sql server a mi desktop x router para compartir archivos y luego cuando intente conectarme a sql me empezo a mandar este error... noc si tengo algo q veer... bueno el problema es qno puedo conectarme :S

    domingo, 23 de octubre de 2011 16:16

Respuestas

Todas las respuestas

  • Verificaste el Firewall del sistema operativo?


    Abraham Forchue Frias MCITP:Database Administrator 2008 -- Santo Domingo, Republica Dominicana
    domingo, 23 de octubre de 2011 22:43
  • los errores: Could not open a connection to SQL Server [53], indican que el servidor SQL no puede ser accedido o no existe. Intente usar: PING nombreservidor ó PING ipservidor. Si los pings tienen un timeout u otra falla, es posible que el nombre del servidor no está siendo bien resuelto por el DNS o hay algún problema de red o de ruteo a resolver. Obviamente, hay un problema de red si el ping falla cuando se especifica simplemente la dirección IP del servidor.


     Si fuese por motivos de firewall, como indica Abraham, cuando la conexión es bloqueada por algún firewall. Para resolver el problema puedes hacer lo siguiente:

    1. Habilitar el servicio SqlBrowser. Además agregar a sqlbrowser.exe como excepción en el firewall.

    2. Agregar el puerto tcp (normalmente es el 1433) como excepción en el firewall. Por ejemplo: Name-1433:TCP, Value-1433:TCP:*:Enabled:Tcp 1433.
     Norman M. Pardell 

    ||Microsoft Certified IT Professional|| Database Administrator. Database Developer. SQL Server 2008

    lunes, 24 de octubre de 2011 14:24
  • Adicionalmente a lo que dice Normannp, le recuerdo que las instancias por nombre utilizan números de puerto dinámicos, y el puerto 1433 es únicamente utilizado por la instancia por defecto (la que no tiene nombre).  Para resolver problemas de firewall, cambie la configuración de puertos dinámicos a un puerto estático y agregue el puerto estático de su preferencia al firewall como Normannp le aconseja.

    También le recuerdo que SqlBrowser es necesario para instancias con nombre porque es este servicio el que le informa al cliente del número de puerto a utilizar en el caso de instancias con nombre.


    Jose R. MCP
    lunes, 24 de octubre de 2011 14:28
  •  Las instancias por nombre, puedes configurarlas por puerto estático, por el 1433 o el que quieras.

     Norman M. Pardell 

    ||Microsoft Certified IT Professional|| Database Administrator. Database Developer. SQL Server 2008

    lunes, 24 de octubre de 2011 14:41
  • En algunos servidores (principalmente windows 2008R2) me ha pasado que tambien fue requerido configurar como regla del firewall el INBOUND del sql browser, el cual comunmente no configuraba. El efecto era que los servidores se podia acceder por ip pero no por nombre. Te lo dejo como otra cosa para corroborar :)
    Lic. Andrés M. Aiello | DBA MS SQL - Oracle | http://aiellodba.blogspot.com | @AndresAiello
    lunes, 24 de octubre de 2011 16:03
  • Hola.

    ¿Resolviste el problema? ¿Lograste establecer las conexión?


    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/ Sígueme en twitter en http://twitter.com/qwalgrande

    sábado, 29 de octubre de 2011 15:54
  • Al parecer el OP perdió interés por el tema o lo resolvió por él mismo. Doy el hilo por cerrado.

    Alberto López Grande
    SQL Server MVP
    Visita mi blog en http://qwalgrande.blogspot.es/ Sígueme en twitter en http://twitter.com/qwalgrande

    sábado, 05 de noviembre de 2011 8:17