none
Error en tiempo de ejecución de Microsoft JScript: 'WebForm_DoPostBackWithOptions' no está definido

    Pregunta

  • buenos dias,

     

    Hace dias vengo experimentando este problema con la aplicacion que estamos desarrollando.

    El mensaje es el siguiente:

    Error en tiempo de ejecución de Microsoft JScript: 'WebForm_DoPostBackWithOptions' no está definido

    Esto ocurre cuando presiono el botón de Login, antes de ejecutar el code behind asociado a ese evento, simplemente salta el mensaje.

    Al darle Ignore al mensaje, ejecuta el code behind, luego ante cualquier evento comienzan a saltar este tipo de mensajes:

    Error en tiempo de ejecución de Microsoft JScript: No se puede obtener valor de la propiedad 'UI': el objeto es nulo o está sin definir

    Error en tiempo de ejecución de Microsoft JScript: 'WebForm_FireDefaultButton' no está definido

     


    Podrían ayudarme por favor? aún no estamos pudiendo resolver el problema,

     

    muchas gracias 

    sábado, 07 de enero de 2012 11:18

Respuestas

  • hola

    analiza esta otra pregunta en dodne trato el tema

    http://social.msdn.microsoft.com/Forums/es/netfxwebes/thread/3541ba18-76b2-4ed8-82d2-2129cf189f84

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    sábado, 07 de enero de 2012 13:18
  • Hola a todos!

    Creo que he descubierto el problema, sin embargo desconozco el motivo.

    Por alguna razón el ajaxcontroltoolkit no agrega las siguientes líneas:

        <script src="http://ajax.microsoft.com/ajax/4.0/2/WebForms.js" type="text/javascript"></script>
        <script src="http://ajax.microsoft.com/ajax/4.0/2/WebUIValidation.js" type="text/javascript"></script>
    

    Lo que hice fue agregarlas manualmente y los problemas se eliminaron.

    Pero... ¿Porqué el ToolScriptManager no los agregó de forma automática?

     

    Un cordial saludo,

     

     

     


    Saludos cordiales, Gustavo Arriola
    martes, 10 de enero de 2012 3:36

Todas las respuestas

  • hola

    analiza esta otra pregunta en dodne trato el tema

    http://social.msdn.microsoft.com/Forums/es/netfxwebes/thread/3541ba18-76b2-4ed8-82d2-2129cf189f84

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    sábado, 07 de enero de 2012 13:18
  • Muchas gracias por la respuesta, lo analizaré y comentare al respecto.

     

    saludos

    sábado, 07 de enero de 2012 13:44
  • Hola a todos!

    Creo que he descubierto el problema, sin embargo desconozco el motivo.

    Por alguna razón el ajaxcontroltoolkit no agrega las siguientes líneas:

        <script src="http://ajax.microsoft.com/ajax/4.0/2/WebForms.js" type="text/javascript"></script>
        <script src="http://ajax.microsoft.com/ajax/4.0/2/WebUIValidation.js" type="text/javascript"></script>
    

    Lo que hice fue agregarlas manualmente y los problemas se eliminaron.

    Pero... ¿Porqué el ToolScriptManager no los agregó de forma automática?

     

    Un cordial saludo,

     

     

     


    Saludos cordiales, Gustavo Arriola
    martes, 10 de enero de 2012 3:36
  • Hola, Tengo el mismo problema y al colocar tu solución, me persiste el error, en que parte de  la pagina se deberia colocar el codigo?

    Muchas gracias.


    Desarrollo Web, Adm BD

    lunes, 16 de septiembre de 2013 4:46