none
Configurar servidor SQL

    Pregunta

  • Buenos días, me estoy viendo con problemas para acceder al servidor que estoy configurando y no se ya por donde puede estar el problema.

    Les explico un poco el asunto por si me pueden ayudar con su experiencia ya que el otro día estuve en el lugar donde donde se instala la aplicación y no hubo forma de configurar el servidor, seguramente que por falta de experiencia.

    Para asegurarme y practicar en la configuración del mismo, he montado una pequeña red en mi casa entre dos ordenadores que he configurado en red y en el mismo grupo de trabajo.

    Le comento lo que he hecho hasta ahora:

    1º En ambos he instalado SQL 2005 EXPRESS, y he configurado para aceptar conexiones remotas tal y como lo explica en los tutoriales de Microsoft siguiendo todos los pasos que se indican en el siguiente enlace: http://support.microsoft.com/kb/914277

    2º También he habilitado el servicio de SQL Server Browser en ambos ordenadores.

    3º Incluso he añadido en el Firewall de Windows la aplicación SQL Browser (en ambos ordenadores)

    Uno de los ordenadores tiene Windows 7 (el servidor se llama W7\SQLEXPRESS) y el otro Windows XP (XP\SQLEXPRESS), y desde Windows 7 quiero acceder a WindowsXP.

    4º He instalado SQL Management 2005 en ambos ordenadores.

    Como lo que quiero es acceder desde Windows7 a XP (que sería el servidor donde se ubicaría la base de datos), desde el cliente (W7) he abierto SQL Management y veo el servidor (XP\SQLEXPRESS), pero no me permite iniciarlo.

    En la consola de Windows he probado realizar una llamada del siguiente modo: sqlcmd -E -S XP\SQLEXPRESS

    y me arroja el siguiente mensaje:

     sqlcmd: error:Microsoft SQL Navite Client: No se puede compeltar el proceso de inicio de sesión debido a un retraso en la apertura de la conexión del servidor.

    ¿Que puedo hacer para que me conecte y probar la conexión con la aplicación?

     

    Gracias.

     

     

     

    viernes, 10 de diciembre de 2010 13:25

Respuestas

  • Hola, 1. revisa los puertos q usa sql

    2. el xp dale permisos al usuario invitado

    3. esas dos mauqinas forman dominio¡?


    Julio Avellaneda
    Blog !!

    • Marcado como respuesta Tavernero sábado, 11 de diciembre de 2010 20:11
    viernes, 10 de diciembre de 2010 13:32
  • Hola Leandro, si, el enlace lo había visto y como comenté en el mensaje mío anterior los puertos los tengo (creo) que bien configurados, con el puerto 1433 en el último apartado IPAII, y es como solucionó el otro usuario su problema, pero tengo que tener algo más mal configurado.

    En cuanto al hecho de ver con SQL Management Studio la base de datos remota, si que puedo verla, e incluso he añadido su instancia a SQL Management, pero no la puedo iniciar, lo que no se es si es porque hay otra (la local) que está iniciada y no pueden haber más de una), ahora caigo que me ha faltado comprobar si se inicia la remota desconectando la local.

    Esta tarde voy a intentarlo de nuevo haber si avanzo algo y si no obtengo resultados positivos y en este foro no puedo obtener respuesta, pondré la pregunta en el que me aconsejas.

    Muchas gracias tu vuestra ayuda.

    • Marcado como respuesta Tavernero sábado, 11 de diciembre de 2010 20:11
    sábado, 11 de diciembre de 2010 11:12

Todas las respuestas

  • Hola, 1. revisa los puertos q usa sql

    2. el xp dale permisos al usuario invitado

    3. esas dos mauqinas forman dominio¡?


    Julio Avellaneda
    Blog !!

    • Marcado como respuesta Tavernero sábado, 11 de diciembre de 2010 20:11
    viernes, 10 de diciembre de 2010 13:32
  • Hola Julitogtu, perdona por la tardanza en responderte, mira, he revisado los puertos, en concreto le he asignado el 1433 en ambos ordenadores que creo que es el puerto que por defecto usa, pero sigue igual.

    Las dos máquinas no forman dominio, simplemente están conectados en red doméstica, y creo que los de la empresa tampoco, simplemente son varios ordenadores conectados entre ellos.

    Lo que no tengo muy claro es como darle permisos al usuario invitado, ¿Lo tengo que hacer desde SQL Management?

     

    Gracias.

    viernes, 10 de diciembre de 2010 22:29
  • hola

    has visto esta otra consulta

    http://social.msdn.microsoft.com/Forums/es-ES/sqlserveres/thread/d986aa19-333f-4db5-9302-4fac806206c6

    sino aconsejaria que realices esta misma pregunta en el foro de Sql Server, seguro con mas experiencia le sucedio algo parecido

    algo que no has mencionado es si con el Sql Server Management Studio puede ingresar a la db de la pc remota?

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    sábado, 11 de diciembre de 2010 4:41
  • Hola Leandro, si, el enlace lo había visto y como comenté en el mensaje mío anterior los puertos los tengo (creo) que bien configurados, con el puerto 1433 en el último apartado IPAII, y es como solucionó el otro usuario su problema, pero tengo que tener algo más mal configurado.

    En cuanto al hecho de ver con SQL Management Studio la base de datos remota, si que puedo verla, e incluso he añadido su instancia a SQL Management, pero no la puedo iniciar, lo que no se es si es porque hay otra (la local) que está iniciada y no pueden haber más de una), ahora caigo que me ha faltado comprobar si se inicia la remota desconectando la local.

    Esta tarde voy a intentarlo de nuevo haber si avanzo algo y si no obtengo resultados positivos y en este foro no puedo obtener respuesta, pondré la pregunta en el que me aconsejas.

    Muchas gracias tu vuestra ayuda.

    • Marcado como respuesta Tavernero sábado, 11 de diciembre de 2010 20:11
    sábado, 11 de diciembre de 2010 11:12
  • Ok, he conseguido que funcione...

    Aunque después de mucho "trastear"  parece que el asunto se ha resuelto... 

     

    Gracias por vuestra ayuda.

    sábado, 11 de diciembre de 2010 20:11
  • Que fue lo que hiciste, yo eh tenido un problema parecido, tengo una base de datos en SQL 2005 EXPRESS en un PC con Windows 7 y un programa que hace consultas e ingresa informacion en un pc con XP, esto dentro de un dominio y quisiera saber como lo solucionaste, es posible que me sirva hacerlo... porfavor espero pronta respuesta.
    jueves, 09 de junio de 2011 2:40