none
Publicar en reporting services AYUDA NOVATO

    Pregunta

  • Hola,
    Soy nuevo en este mundo en el cual me estoy introduciendo depués de hacer un curso.
    El caso es que he instalado en mi PC SQL SERVER y que he estoy haciendo unos informes con SQL Server Business Intelligence Development Studio.
    Una vez hechos, los implemento, acedo a internet explorer y los veo. Hasta aquí todo estupendo.
    El caso es que me gustaría que mis compañeros de trabajo pudieran acceder a esos informes y no sé cómo hacerlo.
    A través del administrador de configuraciones he añadido la dirección IP de un compañero (para hacer la prueba) y he vuelto a implementar los informes pero no consigo que se vean.
    Tengo que instalar algo en el PC del compañero?
    Cómo puedo hacerlo?

    Puede alguien echarme una mano?

    Gracias y un saludo,
    viernes, 22 de enero de 2010 12:06

Respuestas

  • No hay que instalar nada. Para ver los informes desde otro puesto solo se necesita un navegardor. Basta con navegar a la dirección http://MINONMBRE:80/Reports y con eso tienen que salir los informes en el navegador, sin instalar nada en ese puesto.

    Cuando dices "Ninguno. Intento acceder a http://MINONMBRE:80/Reports y no sale nada", esto no puede ser exacto, algo tiene que ocurrir. O bien el navegador se queda mostrando la barra de progreso, o muestra una página en blanco. Si la llega a mostrar en blanco, significa que el cortafuegos de tu equipo está correctamente abierto y que está respondiendo al puerto 80. Así que "mostrar una página completamente en blanco" no es lo mismo que "no sale nada". Y "mostrar una indicación de progreso de la descarga, la cual nunca termina" tampoco es lo mismo que "no sale nada". Para poder tratar de deducir qué te está pasando, sería necesario que dieras una descripción mucho más exacta y detallada de qué es lo que se observa desde el puesto cliente al realizar la navegación.

    jueves, 03 de junio de 2010 13:10
    Moderador

Todas las respuestas

  • lo que tienes que hacer para que se vea el informe en otras maquinas es primero implementar el reporte despues en la maquina donde quieras ver el reporte abrir internet explorer y poner la siguiente direccion http://ip.servidor.reportes/reports donde reports es el nombre que le diste al report manager virtual directory que es el servicio para mostrar y administrar los reportes, revisa que este arriba este servicio en menu inicio→todos los programas→microsoft sql server 2005→configuration tools→reporting services configuration, esto deberia mostrarte el administrador de informes que es ahi donde tus usuarios podran ver y obtener reportes, la primera ves que entres debera preguntarte nombre de usuario y contraseña que pueden ser con los que inicias sesion en windows
    jueves, 04 de marzo de 2010 0:41
  • Hola, debes hacer eldeploy a SSRS y ademas darle seguridad de acceso.
    Para ello puedes entrar al servidor via URL por ejemplo : http://servidor/Reports
    Maxi Accotto Consultoria en SQL Server Buenos Aires - Argentina http://blog.maxiaccotto.com
    jueves, 04 de marzo de 2010 20:46
    Moderador
  • ¿Lo has conseguido?
    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    jueves, 15 de abril de 2010 10:42
    Moderador
  • NO, todavía no.

     

    Gracias

    lunes, 31 de mayo de 2010 13:25
  • Hola.

    ¿Puedes dar alguna información adicional? ¿En qué punto te quedaste? ¿Obtuviste algún error?


    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)
    martes, 01 de junio de 2010 23:39
    Moderador
  • Pues que sigo sin obtenerlo y sin saber cómo hacerlo.

    Paso a detallar cómo está el Administrador de Configuración de Reporting Services:

    1.- Cuenta de Servicio: Usar cuenta integrada, sistema local

    2.- Dirección URL del servicio web: Directorio Virtual: ReportServer

    Dirección IP: Todas asignadas

    Puerto: 80

    Certificado SSL: No seleccionado

    3.- Dirección URL del administrador de informes:

    Directorio virtual: Reports

    Direcciones URL: http://MINOMBRE:80/Reports

     

    Si queréis más información os la doy encantado.

     

    Muchas gracias y un saludo,

    miércoles, 02 de junio de 2010 14:27
  • Hola.

    ¿Y qué error reciben los otros usuarios que desean ver los reports?


    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)
    miércoles, 02 de junio de 2010 16:46
    Moderador
  • Hola.

    ¿Y qué error reciben los otros usuarios que desean ver los reports?


    Alberto López Grande (Visita mi blog en http://qwalgrande.blogspot.es/)

    Ninguno. Intento acceder a http://MINONMBRE:80/Reports y no sale nada.

    Vuelvo a preguntar si en los demás puestos hay que instalar algo o iniciar algún servicio...

    Muchas gracias

    jueves, 03 de junio de 2010 12:24
  • No hay que instalar nada. Para ver los informes desde otro puesto solo se necesita un navegardor. Basta con navegar a la dirección http://MINONMBRE:80/Reports y con eso tienen que salir los informes en el navegador, sin instalar nada en ese puesto.

    Cuando dices "Ninguno. Intento acceder a http://MINONMBRE:80/Reports y no sale nada", esto no puede ser exacto, algo tiene que ocurrir. O bien el navegador se queda mostrando la barra de progreso, o muestra una página en blanco. Si la llega a mostrar en blanco, significa que el cortafuegos de tu equipo está correctamente abierto y que está respondiendo al puerto 80. Así que "mostrar una página completamente en blanco" no es lo mismo que "no sale nada". Y "mostrar una indicación de progreso de la descarga, la cual nunca termina" tampoco es lo mismo que "no sale nada". Para poder tratar de deducir qué te está pasando, sería necesario que dieras una descripción mucho más exacta y detallada de qué es lo que se observa desde el puesto cliente al realizar la navegación.

    jueves, 03 de junio de 2010 13:10
    Moderador
  • hola ,

     YA  resolviste  tu problema  con la informacione que los compañaro te facilitaron "te fue util"

     

    enmanuel grullard

    republica dominicana

    viernes, 11 de junio de 2010 15:41
  • Perdonen la tardanza pero otras obligaciones me tienen alejado de este tema.

    Cuando coja tiempo retomaré el tema; 

     

    Muchas gracias a todos

    sábado, 12 de junio de 2010 8:24
  • Hola,

    Para que tus usuarios accedan desde fuera debes darle permisos dentro del servidor de informes.

    1. Abres la url: http://MINONMBRE:80/Reports
    2. Entras en una carpeta o un report
    3. Verás una pestañita propiedades, pincha
    4. Security o Seguridad según el idioma ;)
    5. Ahí añades un nuevo rol, que no es más que añadir un usuario de directorio activo o cuenta de usuario con la que accederán (mejor la primera opción).
    6. Ya tan sólo te queda decirle si quieres que vea, edite, etc, según las opciones que te salen más abajo para marcar ;)

    Ya nos contarás,

    Un Saludo! 


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    miércoles, 07 de julio de 2010 22:09
    Moderador
  • Hola,

    Para que tus usuarios accedan desde fuera debes darle permisos dentro del servidor de informes.

    1. Abres la url: http://MINONMBRE:80/Reports
    2. Entras en una carpeta o un report
    3. Verás una pestañita propiedades, pincha
    4. Security o Seguridad según el idioma ;)
    5. Ahí añades un nuevo rol, que no es más que añadir un usuario de directorio activo o cuenta de usuario con la que accederán (mejor la primera opción).
    6. Ya tan sólo te queda decirle si quieres que vea, edite, etc, según las opciones que te salen más abajo para marcar ;)

    Ya nos contarás,

    Un Saludo! 


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}

    Hola,

    Desde el PC de al lado esto es lo que me dice internet explorer:

    Oops! This page appears broken. DNS Error - Server cannot be found.

     

    Gracias de todas formas, seguiremos buscando

    martes, 13 de julio de 2010 7:31
  • Prueba a cambiar: MiNombre:80 por la dirección IP real de esa máquina ;)

    Un Saludo!


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    martes, 13 de julio de 2010 7:42
    Moderador
  • Prueba a cambiar: MiNombre:80 por la dirección IP real de esa máquina ;)

    Un Saludo!


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}

    Ya lo he hecho, y tampoco funciona.

    Hablaré con el administrador de la red.

     

    Gracias

    martes, 13 de julio de 2010 7:44
  • HORROR!!

    Ahora resulta que no puedo ver los informes ni yo!

    He conseguido averiguar que el servicio ReportServer está detenido y no hay forma de ponerlo en marcha.

    El viernes funcionaba y el lunes no, y juro y rejuro que no he tocado nada.

    He probado todas las cuentas posibles para iniciarlo y no hay forma.

     

    Puede alguien ayudarme?

    Estoy perdido sin informes!

    martes, 20 de julio de 2010 9:26
  • Me imagino que tu entras a tu http:localhost//reports  y ves tu reporte, pero cuando los demás se conectan no les manda nada.

    Te explico paso a paso como hacer que los usuarios puedan ver tu reporte.

    1.- Entras a SQL Server Management Studio-- En la ventana en la parte Server Type, selecciona Reporting Services, clic en el botón Connect.

    2.-Busca la carpeta que dice HOME, clic derecho sobre la carpeta--Properties--Te muestra una ventana, es para que le des de alta a los usuarios, le das clic en Add Group or User--capturas tu dominio por ejemplo GPOS\victor.uribe--OK. Le seleccionas el cuadrito de Content Manager--Ok, para guardar los cambios.

    3.-En esa misma ventana te debe de aparecer la carpeta donde se alojan tus reportes, les das clic derecho, por ejemplo Total--clic derecho sobre la carpeta--Properties-- clic en la pestaña de Permissions-- Add Group or User-- le seleccionas el cuadrito de Content Manager--Ok, para guardar los cambios.

    4.- Entras a donde se aloja tu reporte http:localhost//reports y te vas a la pestaña Propiedades, ahi ya debes de poder ver al usuario que agregastes para accesar a tu reporte.

    Al usuario el link que le vas a dar es donde se aloja tus reportes, en mi caso http://Nombredelamaquina/reports y con esto ya ellos se pueden conectar a los reportes. Si los reportes se alojan en tu máquina le pones http://jose/reports y ya con esto queda solucionado, espero tu problema, acabamos de terminar lo de reporting y asi nos salio, igual después de tantas vueltas.

    Suerte y espero que quede solucionado tu problema, si no te funciona contactame en Linney_Sistemas@hotmail.com

    lunes, 09 de agosto de 2010 22:13
  • No encontre como adjuntar  las imágenes de cada paso que te explico, ni modo, pero creo que soy clara con lo que te explico, entiendo tu desesperación ese es el pan de cada dia en nuestra área, lo primero no te desanimes ni te desesperes, asi es mientras uno le agarra.

    Saludos.

     

    lunes, 09 de agosto de 2010 22:17
  • Buenas,

    ¿Reiniciaste la máquina?

    Un Saludo!


    Fran Díaz | {geeks.ms/blogs/fdiaz/} | {onobanet.com} | {secondnug.com}
    jueves, 12 de agosto de 2010 20:26
    Moderador