none
windows vista error de aplicación: "configuración en paralelo no es correcta"(¿?)

    Pregunta


  • Hola!

     Soy un programador aficionado desarrollando un juego 3D. Llevo unos años metido en este proyecto y actualmente lo estoy volviendo a reprogramar desde cero sobre un windows XP Home edition y usando VC++Express y la última versión del Plattform SDK compatible con Windows 2000 y Windows XP ademas de la versión de Directx de diciembre2004 (la ultima compatible con W2k). Casualmente tambien tengo un windows vista home edition premium a mano así puedo probar la compatibilidad de mi aplicación con los tres SO.

    Mi problema es el siguiente:

     He configurado la aplicación en modo consola y yo me encargo de la gestión de la ventana de la aplicación. Despues de generar el .exe en modo release y probarlo en mi WXP, funciona correctamente así como en el W2k... Pero en el Vista me da el siguiente error:

     "Error al iniciar la aplicación; la configuración en paralelo no es correcta. Consulte el registro de eventos de la aplicación para obtener mas detalles (sic.)".

     Nota 1: El W2k que utilizo es un pentium dual, el WXP es un pentium 4 y El Vista es un centrino duo.

     Nota 2: Ejecutando un release que compilé hace tiempo usando visual studio 6 si que me funciona en los tres ordenadores W2k(~50FPS), WXP(~30FPS), Vista(~60FPS)...

    Nota 3: El contador de FPS me da mas velocidad en el pentium del WXP (360fps) que en el W2k dual (60fps) , no se si esto se debe a las velocidades del procesador o a algún problema de incompatibilidad con el plattform SDK...

    Agradezco cualquier ayuda...

    @B^)>

     


     
    viernes, 09 de marzo de 2007 10:20

Respuestas

  • cuando instale el nero 9 en windows 7 ultimate 64 bits no iniciaba, pues me daba el siguiente error:

     

    "no se pudo iniciar la aplicacion la configuracion en paralelo no es correcta..... "

     

    mirando en el visor de eventos

     

    Error al generar el contexto de activación para "C:\Program Files (x86)\Nero\Nero 9\Nero StartSmart\NeroStartSmart.exe.Manifest". No se encontró el ensamblado dependiente Microsoft.VC80.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4053". Use sxstrace.exe para obtener un diagnóstico detallado.

     

    esto lo solucione instalando

    Microsoft Visual C++ 2005 Redistributable Package (x86)

     

    que lo pueden encontrar en la siguiente pagina

    http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=es

     

     como en mi caso no funciono tuve que instalar los siguientes hotfix:
    uno te puede decir que no es para tu sistema operativo

    http://www.microsoft.com/downloads/details.aspx?displaylang=es&FamilyID=766a6af7-ec73-40ff-b072-9112bab119c2

     

    otros se van a instalar

    si en uno te dice que no puede encontrar un temporario poner omitir y se termina instalando
    ojala les sirva, estube 3 dias para encontrar la solucion

    jueves, 14 de enero de 2010 5:22

Todas las respuestas

  • Tiene toda la pinta de que el problema esta en que el driver de la tarjeta de video en Vista no soporta el modo de visualización que has establecido. Pero es dificil saber cual puede ser el problema, quiza nos puedas dar algún dato más.
    jueves, 15 de marzo de 2007 15:57
  • Dale un vistaso a esta pagina: http://www.solarsockets.solar-opensource.com/zerugiran/index.php/blog/show/MSVCP80Ddll-error-en-Visual-c-2005.html , es un problema de los programas compilados con Visual C++ 2005c-2005.html
    miércoles, 25 de julio de 2007 14:13
  • he tenido el mismo error al tratar de instalar la aplicación wildpackets omnipeek para gestión inalámbrica, es una versión demo y especifica que soporta windows vista, por otra parte no he visto a nadie más con este error buscando en la red :/
    miércoles, 07 de noviembre de 2007 18:57
  • Yo tampoco lo he visto nunca, pero me da que se debe a algún problema con el tema de los multinúcleo, esas aplicaciones tienen algún problema de sincronización entre hilos que sólo salta cuando se ejecutan en un procesador con más de un núcleo.

     

    Para probar si es eso, ejecutad el "msconfig"  y en la sección de "boot", "advanced options", seleccionad 1 solo procesador y reiniciad.

     

    Si ahora no salta el error el tema está claro: hay un bug en la aplicación o en las bibliotecas del C++.

    miércoles, 07 de noviembre de 2007 21:46
    Moderador
  • Hola,creo haber leido todo lo q encuentro en la red con respecto a este error,estoy al borde d la lokura,he probado ejecutar el "msnconfig" dice q windows no encuentra el archivo,he consultado el visor de eventos,he reinstalado la aplicación..el error persiste,he seguido un montón de consejos y lo uinico q consigo es desastibilar el sist...si es cómo tu dices un bug en la aplicación o en la bibliotecas del C++...pues agradecería me hecharas un cable...xq ahí me pierdo..por otro lado el spyware terminator encuentra "invalid startup items"...el S.O. es windows vista home premium,procesador intel(R) corel(tm)2duo cpu  t5670"1.80 GHz,32 bits..tb han deaparecido el ejecurtar y el cdm de la barra,d herra..pero estan en system 32 uno y en el acceso del teclado otro,yo juraria q antes staban...me desbordan los errores y las dudas...bueno gracias d antemano espero puedas ayudarme..ciao!
    domingo, 10 de enero de 2010 15:26
  • Lo que tu has puesto aquí creo que no tiene nada que ver con el hilo, y tiene toda la pinta de que tu sistema está roto... posiblemente porque has estado instalando programas chungos de limpieza y optimización de windows... y es mejor que preguntes en un foro de windows.
    Visita mi blog sobre desarrollo: http://geeks.ms/blogs/rfog/
    lunes, 11 de enero de 2010 11:50
    Moderador
  • cuando instale el nero 9 en windows 7 ultimate 64 bits no iniciaba, pues me daba el siguiente error:

     

    "no se pudo iniciar la aplicacion la configuracion en paralelo no es correcta..... "

     

    mirando en el visor de eventos

     

    Error al generar el contexto de activación para "C:\Program Files (x86)\Nero\Nero 9\Nero StartSmart\NeroStartSmart.exe.Manifest". No se encontró el ensamblado dependiente Microsoft.VC80.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4053". Use sxstrace.exe para obtener un diagnóstico detallado.

     

    esto lo solucione instalando

    Microsoft Visual C++ 2005 Redistributable Package (x86)

     

    que lo pueden encontrar en la siguiente pagina

    http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=es

     

     como en mi caso no funciono tuve que instalar los siguientes hotfix:
    uno te puede decir que no es para tu sistema operativo

    http://www.microsoft.com/downloads/details.aspx?displaylang=es&FamilyID=766a6af7-ec73-40ff-b072-9112bab119c2

     

    otros se van a instalar

    si en uno te dice que no puede encontrar un temporario poner omitir y se termina instalando
    ojala les sirva, estube 3 dias para encontrar la solucion

    jueves, 14 de enero de 2010 5:22
  • Gracias walter... tenia el problema de la aplicacion en paralelo y no habia notado qe desinstalando programas qe crei innecesarios.. habia desinstalado el qe ahi mencionas... acabo de instalarlo y.. PROBLEMA SOLUCIONADO.

    asi qe gracias esta todo muy completo (Y).

    miércoles, 24 de marzo de 2010 1:20
  • "msnconfig"  NOOOOOOOO eso no existe (tienes una N de mas)

    msconfig

     

     

    Micro

    Soft

    Configuration

    martes, 04 de enero de 2011 15:27
  • Gracias Walter ya me había pasado antes y no pude recordar que era lo que me hacía falta, eso soluciona lo del Nero, me ahorraste mas búsqueda.

    viernes, 28 de enero de 2011 0:22
  • Me sale ese mismo error pero cuando trato de iniciar mi msn?? me sirve el mismo programa que dice  Walter??
    sábado, 10 de septiembre de 2011 18:38
  • Tengo un problema igual con un programa, y analizando el registro de eventos, cuando la configuración del paralelo no es correcta, se debe a que dos archivos entran en conflicto de ext. .manifest. 

    Según una definición de microsoft la ext. manifest es "Un manifiesto de aplicación es un archivo XML que describe e identifica las privadas y compartidas de lado a los ensamblados que una aplicación debe se unen en tiempo de ejecución. Estas deben ser las versiones de montaje mismos que se utilizaron para probar la aplicación. Manifiestos de aplicación también puede describir metadatos de los archivos que son privados de la aplicación."

     Una opción (NO PROBADA) sería eliminar alguno de los archivos que esta en conflicto, que solo quede 1  de ellos.


    Eddison G.

    domingo, 08 de abril de 2012 1:14
  • muchas gracias estaba desesperado y tu me diste la solucion te lo agradesco

    miércoles, 11 de abril de 2012 0:52