locked
Configuration Manager not visible in IDE

    Question

  • Guys,

    I do not see Configuration Manager in IDE of VS 2005 Team Suite, and basically cannot switch between Release and Debug mode for the code. I have checked all possible placed and I do not see how I could make it to appear. Am I missing something?

    Saturday, August 12, 2006 2:03 AM

Answers

  • Tools | Customize from the menu.

    In the Build section, drag the "Solution  Configuration" item from the list on the right to the build toolbar.  You might also want to drag the "Platform  Configuration"  item as well.  The Configuration Manager itself is available from the drop-down list of either of those controls.  Also check Tools|Customize|Toolbars to make sure that the Build toolbar is visible.

    You might also try the infamous devenv /resetsettings from the command line - that'll completely reset VS to the out of box configuration, so anything that's gone missing should come back.

    If none of that pans out, I would guess that your VS installation is damaged somehow and a reinstall is probably in your future.
     

    Sunday, August 13, 2006 5:41 AM

All replies

  • Tools | Customize from the menu.

    In the Build section, drag the "Solution  Configuration" item from the list on the right to the build toolbar.  You might also want to drag the "Platform  Configuration"  item as well.  The Configuration Manager itself is available from the drop-down list of either of those controls.  Also check Tools|Customize|Toolbars to make sure that the Build toolbar is visible.

    You might also try the infamous devenv /resetsettings from the command line - that'll completely reset VS to the out of box configuration, so anything that's gone missing should come back.

    If none of that pans out, I would guess that your VS installation is damaged somehow and a reinstall is probably in your future.
     

    Sunday, August 13, 2006 5:41 AM
  • Thanks. I had to reset it. Otherwise it did not work
    Tuesday, August 15, 2006 10:14 AM
  • I had the exact same problem.  The configuration manager drop-down and platform dropdown were in my toolbar, but were not enabled(greyed out in VS2005 Team Edition).  I could only speculate that the SP1 Beta I installed may have caused this, but I can't be sure...  In addition, in the build tab of the project properties page, the configuration manager (usually with the default Debug and Release) and the Platform drop-down were completely missing from the top of the page.  It's as if the Configuration manager was completely disable across all of Visual Studio 2005. 

    So, I tried the "devenv /resetsettings" command, but that didn't help.  Then I removed all VisualStudio products and reinstalled VS2005... that didn't help.  Then, I removed VS2005 again AND I removed two sections from my registry (which I feel should have been removed with VS2005): 

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio

    Then, I reinstalled VS2005 and voila!  The configuration manager is back.  So, I can only conclude that a setting in my Registry was causing this. 

    -Valkyrie-MT

     

    Thursday, February 15, 2007 9:35 PM
  • I am also not able to see the 'release' option for my Web Service project....

    External users will get 'debug.assert' messages....  Not Good. 

    PLEASE GIVE FIX TO THIS!    

    Regards Bjørn Sigurd Johansen

    Monday, February 26, 2007 8:33 PM
  • Hello everyone,

        Today i had the same issue, after a long time i decided to do some release builds and it was gone and also disabled when i tried adding it to the toolbar. I did the reset, didn't change anything. I uninstalled and also removed the registry sections like Valkyrie-MT2 said, reinstalled, and still the same...

        I solved it by simply noticing this:

              Tools - options ->Projects and Solutions ->General
    the Show advanced build configurations was unchecked! i checked it, closed the window, and magically it got enabled, and added to the Build menu ;)

        Hope this helps someone who wasn't able to solve this :)

    vangelis
    • Proposed as answer by Stefan 000000 Monday, November 09, 2009 3:00 PM
    Tuesday, February 27, 2007 12:22 PM
  • vangelis wrote:

    ------------------------------------------------ 

       I solved it by simply noticing this:

              Tools - options ->Projects and Solutions ->General
    the Show advanced build configurations was unchecked!

    -------------------------------------------------

    That's it!  I suspect there is a package that we all installed that changed this setting for us...  Do any of these tools sound like something you installed recently? 

    - Team System Solution Explorer

    - Dundas Chart 5.5

    - Exceed Components

    - Oracle Developer Tools 10.2.0.2.20

    - Visual Studio 2005 Service Pack 1 Beta

    -Valkyrie-MT

    P.S. Vangelis- Sorry the uninstall/reinstall thing didn't work for you.  I know that's a painful process...

     

     

    Tuesday, February 27, 2007 2:40 PM
  • I suffered a very similar experience and did not find this post until afterward. I have been lead to beleive that it happened because I picked VB Style Settings upon install of studio.

    --
    Rory
    Saturday, March 31, 2007 10:03 PM
  • There is really nothing special about the "Release" configuration.  You can create your own configurations at any time...  In the menu go to Build -> Configuration Manager...  In the "Active solution configuration" dropdown, click on <New...> and name it Release.  Close that dialog.  Then, select your new Release configuration from the toolbar.  Now in the properties of ALL the projects in your solution, open the "Build" tab and uncheck "Define DEBUG constant" and check "Optimize code".  Once you have done this for all projects, you're done...

     

    -Valkyrie-MT

    Monday, April 02, 2007 1:49 PM
  • Thanks a million!!!
    Tuesday, April 03, 2007 6:06 PM
  •  

    This link will solve your problem - step by step..

    http://blogs.vertigo.com/personal/KeithC/Blog/Lists/Posts/Post.aspx?ID=16


    Basically if you are missing menu options in Visual Studio, you are working with a profile configured for a simplified environment. The Tools -> Import and Export Settings menu option lets you load a more advanced profile which will show you the options you need.

    Thursday, September 06, 2007 8:24 AM
  • Exactly what happened to me - thanks for the tip!
    Thursday, April 03, 2008 1:22 PM
  • vangelis,

    Thank you very much for your post, it worked!  You saved me a ton of time.

    Sincerely,

    --Harry

    Monday, January 25, 2010 2:36 PM
  • Thanks very much vangelis, this worked for me.

    I also think this may be due to choosing VB rather then general dev settings as Rory suggests.  Just because I code in VB doesn't mean... ah what's the point...

    P.S. I am enormously impressed by the way Valkyrie-MT didn't moan or complain about the hassle he had to go though to get his IDE working.  Well done Valkyrie-MT, and as they say in France, Bon Courage...

    ChrisE
    Thursday, February 18, 2010 11:30 PM
  • excellent - that did the trick for me ("Show Advanced Build Config)

    thanks

    Wednesday, June 02, 2010 2:47 PM
  • Vagos, youre my man, Thanks a lot!
    Wednesday, November 10, 2010 9:09 AM
  • VS.2010, this same thing happened to me for one of my project/solutions.  Setting the checkbox as described made it magically re-appear.  Nice work, vagos21, and Thanks!
    mp
    Thursday, July 28, 2011 4:05 PM
  • You're the man! Thank you a lot.
    Monday, February 20, 2012 9:47 AM
  • I tried the same piece of guidline in 2010 VS but it didn't help me.
    Wednesday, May 09, 2012 9:00 AM
  • For the same issue in VS 2008 Team system, devenv /resetsettings (on Run prompt) worked well. Now I can able to see the Debug & Find dropdown.
    Thursday, July 26, 2012 9:09 AM
  • From Visual Studio select the following:

    From the customize menu, select “Toolbar” check box and chose the “Build” option

    If your Solution Configuration is missing, click the “Add Command…” button

    On the right, select the “Build” option and then scroll until you see “Solution Configuration”  Select it and click OK

    It should now appear in your group shown below.  Click Close

    Wednesday, September 12, 2012 4:03 PM