none
WES8 CTP installs, WES8 Final doesn't

    General discussion

  • We were able to use the WES8 CTP IBW to successfully load a device designed for Win8.  However, the final release of WES8 fails to install properly.  We allow the IBW to completely reformat and partition the drive during install. After the installation is complete, the device reboots, and we see the Windows error screen with code 0xC0000001.  The device is a tablet with UEFI support (no legacy BIOS support).  Secure boot has been disabled.    We have run the install with and without the vendor-supplied drivers (written for Win8/Win8 Pro).  The device runs off of an SSD drive.

    Are there any major differences between WES8 CTP and WES8 final (e.g. hardware compatibility, UEFI requirements, driver signing enforcement, etc) that might be causing our issue?

    As a side note, Windows Embedded Industry 8.1 (Preview) also boots properly.  However, we're hesitant to do too much testing for fear that the final release will exhibit the same symptoms.

    Thursday, June 27, 2013 2:47 PM

All replies

  • Hi,

    This may be related to an issue that on newer hardware it is necessary to recreate the IBW media from ICE for IBW to be successful on the final release.
    To recreate the IBW media in ICE select Tools->CreateMedia->Create IBW Image with full Catalog  

    Windows Embedded Industry 8.1 should not be effected by this.

    Please let us know if this addresses the issue or not.

    Thanks


    Dave Massy, Program Manager

    Thursday, June 27, 2013 3:34 PM
    Owner
  • Hi Dave:

    We followed your directions but still are seeing the same problem.  After install we are getting the Recovery Blue Screen with the error code: 0xc0000001.  The WES8 preview worked fine.

    Ed

    Thursday, June 27, 2013 5:22 PM
  • Thanks.

    Can you give us full specifications of the hardware so we can investigate further?


    Dave Massy, Program Manager

    Thursday, June 27, 2013 5:43 PM
    Owner
  • Dell Latitude 10 Tablet

    Atam Dual Core Z2760 CPU

    2 GB DDR-800MHz SDRAM

    64GB SSD

    10.1" display 1366x 768

    Capacitive 10 finger touch

    Front / Rear cameras


    Thursday, June 27, 2013 6:12 PM
  • I thought Windows 8 still required legacy BIOS.

    www.annabooks.com / www.seanliming.com / Book Author - Pro Guide to WE8S, Pro Guide to WES 7, Pro Guide to POS for .NET

    Thursday, June 27, 2013 11:00 PM
  • Windows 8 does not require a legacy bios.

    See http://windows.microsoft.com/en-US/windows-8/what-uefi

    Thanks


    Dave Massy, Program Manager

    Friday, June 28, 2013 3:04 AM
    Owner
  • Thanks. We're reproducing the issue and continuing our investigation.

    Dave Massy, Program Manager

    Friday, June 28, 2013 6:13 PM
    Owner
  • Dave:

    Any updates?

    Monday, July 01, 2013 8:15 PM
  • Dave:

    Do you have a list of WES8 certified tablets?

    Is there a way I can setup a conference call with you to discuss our issue with WES8.

    ed

    Friday, July 05, 2013 2:56 PM
  • Hi Ed111s,

    Sorry I don't have any updates yet. I'm out of the office for the next week but the investigation continues while I am away.

    This is an exception and WES8 will work on nearly all Windows x86/x64 hardware out of the box. For very new hardware it is possible that the necessary drivers are not part of the WES8 media and need to be added separately.

    Thanks


    Dave Massy, Program Manager

    Friday, July 05, 2013 4:58 PM
    Owner
  • Thanks for getting back to me today.

    What is the difference between WES8 Preview and WES8 Final version.  The reason for my question is, WES8 Preview installed and booted fine, whereas WES8 Final won't boot. 

    Friday, July 05, 2013 5:18 PM
  • Dave:

    Checking the setuperr.log file I am seeing this entry

    Error 0x060755 IBS Callback_Embedded_ComRegistration: Failed to register EmbeddedMmi.dll

    Hope this helps to narrow down it down

    Friday, July 05, 2013 7:51 PM
  • Dave:

    Any updates on the investigation?

    ed

    Wednesday, July 17, 2013 3:20 PM
  • When you updated ICE did you remove the existing windows catalog?
    (Usually C:\Windows Embedded Catalog)
    If not try uninstalling ICE and remove this catalog.
    And the reinstall ICE and recreate the IBW.

    That is how I got rid of my WES8 final release issues.

    /JD

    Thursday, July 18, 2013 4:26 PM
  • Is Windows 8 embedded standard UEFI in the x32 version? Or only the x64 version.
    Wednesday, July 24, 2013 6:54 PM