none
Microsoft SQL Server 2008 R2 Express SP2 Adv (x64) installation fails on Install_msreportviewer90sp1_Cpu32_Action action

    Question

  • I am having problems installing Microsoft SQL Server 2008 R2 Express SP2 Adv (x64) on our windows embedded Standard SP1 services.  During the installation it pops up a dialog stating the Managed SQL Server Installer has stopped working”, Exception Code: c0000374.  This happens when SQL is trying to install the Install_msreportviewer90sp1_Cpu32_Action action.

    This install has worked before but for some unknown reason it consistently fails.

    Here is the summary_XX.txt log. *******************************************

    Overall summary:
      Final result:                  Pending
      Exit code (Decimal):           0
      Exit message:                  Pending
      Start time:                    2013-09-05 11:38:49
      End time:                      2013-09-05 11:39:10
      Requested action:              Install

    Machine Properties:
      Machine name:                  IPA-013
      Machine processor count:       4
      OS version:                    Windows 7
      OS service pack:               Service Pack 1
      OS region:                     United States
      OS language:                   English (United States)
      OS architecture:               x64
      Process architecture:          64 Bit
      OS clustered:                  No

    Product features discovered:
      Product              Instance             Instance ID                    Feature                                  Language             Edition              Version         Clustered

    Package properties:
      Description:                   SQL Server Database Services 2008 R2
      ProductName:                   SQL Server 2008 R2
      Type:                          RTM
      Version:                       10
      Installation location:         c:\bc550639d7777b59802f7a6add\x64\setup\
      Installation edition:          EXPRESS_ADVANCED

      Slipstream:                    True
      SP Level                       2

    User Input Settings:
      ACTION:                        Install
      ADDCURRENTUSERASSQLADMIN:      False
      AGTSVCACCOUNT:                 NT AUTHORITY\NETWORK SERVICE
      AGTSVCPASSWORD:                *****
      AGTSVCSTARTUPTYPE:             Disabled
      ASBACKUPDIR:                   Backup
      ASCOLLATION:                   Latin1_General_CI_AS
      ASCONFIGDIR:                   Config
      ASDATADIR:                     Data
      ASDOMAINGROUP:                 <empty>
      ASLOGDIR:                      Log
      ASPROVIDERMSOLAP:              1
      ASSVCACCOUNT:                  <empty>
      ASSVCPASSWORD:                 *****
      ASSVCSTARTUPTYPE:              Automatic
      ASSYSADMINACCOUNTS:            <empty>
      ASTEMPDIR:                     Temp
      BROWSERSVCSTARTUPTYPE:         Disabled
      CONFIGURATIONFILE:            
      CUSOURCE:                     
      ENABLERANU:                    False
      ENU:                           True
      ERRORREPORTING:                False
      FARMACCOUNT:                   <empty>
      FARMADMINPORT:                 0
      FARMPASSWORD:                  *****
      FEATURES:                      SQLENGINE,FULLTEXT,SSMS
      FILESTREAMLEVEL:               0
      FILESTREAMSHARENAME:           <empty>
      FTSVCACCOUNT:                  NT AUTHORITY\LOCAL SERVICE
      FTSVCPASSWORD:                 *****
      HELP:                          False
      INDICATEPROGRESS:              False
      INSTALLSHAREDDIR:              c:\Program Files\Microsoft SQL Server\
      INSTALLSHAREDWOWDIR:           c:\Program Files (x86)\Microsoft SQL Server\
      INSTALLSQLDATADIR:             <empty>
      INSTANCEDIR:                   c:\Program Files\Microsoft SQL Server\
      INSTANCEID:                    MSSQLSERVER
      INSTANCENAME:                  MSSQLSERVER
      ISSVCACCOUNT:                  NT AUTHORITY\NetworkService
      ISSVCPASSWORD:                 *****
      ISSVCSTARTUPTYPE:              Automatic
      NPENABLED:                     0
      PASSPHRASE:                    *****
      PCUSOURCE:                     c:\bc550639d7777b59802f7a6add\PCUSOURCE
      PID:                           *****
      QUIET:                         False
      QUIETSIMPLE:                   True
      ROLE:                          AllFeatures_WithDefaults
      RSINSTALLMODE:                 FilesOnlyMode
      RSSVCACCOUNT:                  NT AUTHORITY\NETWORK SERVICE
      RSSVCPASSWORD:                 *****
      RSSVCSTARTUPTYPE:              Automatic
      SAPWD:                         *****
      SECURITYMODE:                  SQL
      SQLBACKUPDIR:                  <empty>
      SQLCOLLATION:                  SQL_Latin1_General_CP1_CI_AS
      SQLSVCACCOUNT:                 NT AUTHORITY\NETWORK SERVICE
      SQLSVCPASSWORD:                *****
      SQLSVCSTARTUPTYPE:             Automatic
      SQLSYSADMINACCOUNTS:           GVAdmin,Administrator
      SQLTEMPDBDIR:                  <empty>
      SQLTEMPDBLOGDIR:               <empty>
      SQLUSERDBDIR:                  <empty>
      SQLUSERDBLOGDIR:               <empty>
      SQMREPORTING:                  False
      TCPENABLED:                    0
      UIMODE:                        AutoAdvance
      X86:                           False

      Configuration file:            c:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20130905_113807\ConfigurationFile.ini

    Detailed results:
      Feature:                       Database Engine Services
      Status:                        Failed: see logs for details
      MSI status:                    Passed
      Configuration status:          Passed

      Feature:                       Full-Text Search
      Status:                        Failed: see logs for details
      MSI status:                    Passed
      Configuration status:          Passed

      Feature:                       Management Tools - Basic
      Status:                        Failed: see logs for details
      MSI status:                    Passed
      Configuration status:          Passed

    Rules with failures:

    Global rules:

    Scenario specific rules:

    Rules report file:               c:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20130905_113807\SystemConfigurationCheck_Report.htm

     Here is the tail end of the Details.txt log ******************************************

    2013-09-05 11:40:14 Slp: Checkpoint: INSTALL_TRIN_AIDE_CPU32_ACTION
    2013-09-05 11:40:14 Slp: Completed Action: Install_trin_aide_Cpu32_Action, returned True
    2013-09-05 11:40:14 Slp: ----------------------------------------------------------------------
    2013-09-05 11:40:14 Slp: Running Action: Install_msreportviewer90sp1_Cpu32_Action
    2013-09-05 11:40:14 Slp: Sco: Attempting to create base registry key HKEY_LOCAL_MACHINE, machine
    2013-09-05 11:40:14 Slp: Sco: Attempting to open registry subkey
    2013-09-05 11:40:14 Slp: Sco: Attempting to open registry subkey SOFTWARE\Microsoft\VisualStudio\9.0
    2013-09-05 11:40:14 Slp: Sco: Attempting to get registry value InstallDir
    2013-09-05 11:40:14 Slp: Sco: Waiting for service 'msiserver' to accept the stop request.
    2013-09-05 11:40:14 Slp: Sco: Returning service status Running
    2013-09-05 11:40:14 Slp: Target package: "c:\bc550639d7777b59802f7a6add\x64\setup\msreportviewer90sp1\vb_ros.msi"

    Thursday, September 05, 2013 8:58 PM

Answers

  • Hi,

    Teh exception code c0000374 indicates a heap corruption. Usually third party dlls/drivers may cause this with a running sql instance. I wonder why it occurs during installation..

    The next step would be to look into the dumps generated by this exception. You should have some appcrash dumps under C:\ProgramData\Microsoft\Windows\WER\ReportQueue which Microsoft may want to look into.

    In the meantime, you may try to repair the .net framework and see if it helps?


    This posting is provided “AS IS” with no warranties, and confers no rights.

    If this reply answers your question, please mark it as Answered for others to find it easily.
    If this reply help you resolving the problem, please vote the post as Helpful.

    Monday, September 09, 2013 3:41 AM
  • McAfee solidifier was still blocking this install even though it was in update mode.  It needed to be disabled so that the installer would work.

    • Marked as answer by Memmott2 Thursday, September 26, 2013 11:59 AM
    Thursday, September 26, 2013 11:58 AM

All replies

  • Hi,

    Can you please provide the complete log file (Summary and Detail)

    You may upload the file somewhere and post the link here.


    This posting is provided “AS IS” with no warranties, and confers no rights.

    If this reply answers your question, please mark it as Answered for others to find it easily.
    If this reply help you resolving the problem, please vote the post as Helpful.

    Friday, September 06, 2013 3:02 AM
  • Hi,

    Teh exception code c0000374 indicates a heap corruption. Usually third party dlls/drivers may cause this with a running sql instance. I wonder why it occurs during installation..

    The next step would be to look into the dumps generated by this exception. You should have some appcrash dumps under C:\ProgramData\Microsoft\Windows\WER\ReportQueue which Microsoft may want to look into.

    In the meantime, you may try to repair the .net framework and see if it helps?


    This posting is provided “AS IS” with no warranties, and confers no rights.

    If this reply answers your question, please mark it as Answered for others to find it easily.
    If this reply help you resolving the problem, please vote the post as Helpful.

    Monday, September 09, 2013 3:41 AM
  • Hi Memmott,

    I’m writing to follow up with you on this post. If you are satisfied with our solution, I’d like to mark this issue as "Answered". Please also feel free to unmark the issue, with any new findings or concerns you may have.

    Thanks,
    Sofiya Li


    Sofiya Li
    TechNet Community Support

    Tuesday, September 17, 2013 1:20 AM
    Moderator
  • McAfee solidifier was still blocking this install even though it was in update mode.  It needed to be disabled so that the installer would work.

    • Marked as answer by Memmott2 Thursday, September 26, 2013 11:59 AM
    Thursday, September 26, 2013 11:58 AM