locked
Installation Failure on Windows 7 Pro 64bit

    Question

  • When the installation stated it's installing .NET Framework 4, the failure was occured.
    and here are the content of the log file:

    [03/05/10,01:48:18] Microsoft .NET Framework 4: [2] Error code 9 for this component means "The storage control block address is invalid.
    "
    [03/05/10,01:48:18] Microsoft .NET Framework 4: [2] Component Microsoft .NET Framework 4 returned an unexpected value.
    [03/05/10,01:48:18] Microsoft .NET Framework 4: [2] Return from system messaging: The storage control block address is invalid.

    ...skipped the following that is about was not attempted to install something else....
    • Moved by YiChun Chen Monday, March 08, 2010 7:04 AM .NET 4.0 issue (From:Visual Studio Setup and Installation)
    Thursday, March 04, 2010 5:53 PM

Answers

  • Good evening,

    I eventually managed to fix the issue.

    Actually it was a simple security access problem.
    I just gave the correct rights to the installer's directory ("system" is at least necessary i think) and it ran well !

    VS2010 is really nice. ^_^

    Regards

    • Marked as answer by YiChun Chen Wednesday, March 10, 2010 3:47 AM
    Monday, March 08, 2010 11:09 PM

All replies

  • Hi David,

    I am moving this thread from Base "Visual Studio Setup and Installation" forum to the ".NET Framework 4 setup & deployment (Pre-Release versions)" forum, since the issue is related to .NET 4.0. There are more experts in the ".NET Framework 4 setup & deployment (Pre-Release versions)" forum.

    Thanks


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, March 08, 2010 7:04 AM
  • Hi,

    I'm just facing with the same issue.

    I previously managed to setup VS_PRO_2010_RC on Windows 7 Pro 32bit (which had VS_PRO_2008 installed).
    The problem seems to be linked to 64bits systems.

    I also tried to install the framework 4 separately without any success.

    Thanks in advance for your help.
    Math
    Monday, March 08, 2010 11:57 AM
  • oops, actually, the problem is occurred when i am installing VS2010 RC.
    Monday, March 08, 2010 1:49 PM
  • Sure, but have you tried a separate installation of the framework 4 ?
    Monday, March 08, 2010 2:29 PM
  • Hi,

    I'm sorry that you are having troubles installing the RC.  I will need to take a look at the complete install logs to narrow down the issue.  Could you collect your .Netfx4 setup logs following the instructions at http://blogs.msdn.com/heaths/pages/collect.aspx and post them somewhere we can access? (you can use skydrive.live.com to post the logs).  I'd be happy to take a look to see what has happened.

    Thanks,

    ~Merrie - MSFT
    --------------
    VS/ .NET Deployment Team
    Monday, March 08, 2010 6:12 PM
  • Good evening,

    I eventually managed to fix the issue.

    Actually it was a simple security access problem.
    I just gave the correct rights to the installer's directory ("system" is at least necessary i think) and it ran well !

    VS2010 is really nice. ^_^

    Regards

    • Marked as answer by YiChun Chen Wednesday, March 10, 2010 3:47 AM
    Monday, March 08, 2010 11:09 PM
  • I'm glad you were able to install successfully!  I agree, VS2010 is very nice :-)

    ~Merrie - MSFT
    Tuesday, March 09, 2010 7:49 PM
  • What exactly did you mean by giving the correct rights to th installer's directory.  I'm having the same problem but am having difficultly understanding how you are going to assign security access to a directory to doesn't exist until you run the installer.
    Monday, June 07, 2010 6:52 PM