none
Cannot Edit Table Data with SQL Server Management Studio?

    Question

  • HI all,

    I'm just posting this to make sure I didn't mess anything.

    Is the only way to enter/edit table data (in grid view) is through the VS (Express) IDE?

    The reason why I ask is because I installed the Sql Server 2008 developer trial to get the Management Studio and pretty much the only things I can do are create/edit/delete databases, tables and the like.

    It would be nice for the Management Studio (and Express at that) to have those capabilites.  It would be nice to not have to create connections in the VS IDE to diffferent databases to edit them.  Opening up the Management Studio and selecting the database seems like the proper (if not accustomed) way to do it.

    Thanks,
    JB
    Tuesday, April 15, 2008 10:21 PM

Answers

  • You are right, you cannot "open table" from SSMS. It would be nice if one could, though!

     

    Wednesday, April 16, 2008 6:18 PM
    Moderator

All replies

  • You are right, you cannot "open table" from SSMS. It would be nice if one could, though!

     

    Wednesday, April 16, 2008 6:18 PM
    Moderator
  • Hi Erik,

    Thanks very much for the confirmation.  Yeah, I wish it had those features.  That's a big bummer, I think.

    Oh well, nothing is perfect. 

    Thanks!
    JB
    Wednesday, April 16, 2008 10:17 PM
  • Not so.

    Check out http://stackoverflow.com/questions/358382/where-did-open-table-go-in-sql-server-2008

    In the Tools Menu -> Options... under SQL server Object Explorer\Table and view options\Value Edit Top Rows Command. Change the default value 200 too "0". You should now have the option "Edit All Rows" instead of "Edit Top 200 Rows" as a default and if you know it is a laaarge table use the "Select Top 1000 Rows" as a rewiew of the table.


    Edward R. Joell MCSD MCDBA

    Tuesday, April 24, 2012 3:42 PM
  • there are more issues regarding entering data in SSMS. When I add a uniqueidentifier column to my table and try to enter a valid guid value I just copied from a rowguid column, the data is rejected telling me to enter it as a 16-byte value. What fucking idiot ever tested this? He should be shot on sight since he doesn't do his job properly and the manager should also be shot since he should have noticed this during final testing of the package.

    thanks to this millionth fuckup of MS, I can start to create a stored procedure just to enter my initial data.

    Friday, September 28, 2012 3:51 PM
  • Awesome, thank you SO much for posting this. I was getting so frustrated!
    Friday, November 09, 2012 4:58 PM