locked
Is this a bug, or is there a way to enable JavaScript in IE10?

    Question

  • When I go to this URL: http://time.manpowerdirect.com I get an error "This site requires a javascript enabled browser, please change your browswer and try again."

    I get that error in IE10 under both Metro and Desktop.

    I reset my browser's advanced settings, but there is no change.  Any suggestions?

    Tuesday, October 11, 2011 2:16 AM

Answers

All replies

  • Tom

     

    You say you have restored the ‘Advanced settings’, but have you checked if Javascript is enabled?

     

    If not:

     

    1. Go to Internet Options > Security Tab > Internet > Custom Level, scroll down to the Scripting section (near the bottom) and in Active Scripting, put a check mark against Enable.

     

    2. If it’s still not working, reregister it by opening a Command Prompt as the Administrator, type regsvr32 jscript.dll (note the space) and press Enter. A box will come up saying it has been successful, click OK to close the box.

     


    • Edited by BurrWalnut Tuesday, October 11, 2011 1:38 PM
    Tuesday, October 11, 2011 1:33 PM
  • Tom.allen,

    That website checks to see what browser you use and it doesn't know about Internet Explorer 10.  There is option to tell the website that you using Internet Explorer 9 instead.

    1. Using Desktop Internet Explorer 10
    2. Go to http://time.manpowerdirect.com
    3. Press F12 key. 
    4. Click on Browser Mode: IE 10 and select Internet Explorer 9
    5. Re enter http://time.manpowerdirect.com address again and it will display website correctly.

     

     





    Tuesday, October 11, 2011 1:45 PM
  • BurrWalnut,

     Thanks for your help.  Scripting was already enabled. And after I reregistered the dll (elevated command prompt needed) there was no change in the symptoms.  A solution that worked was proposed by Eric. at MSFT.


    +tom Cupertino, CA
    Tuesday, October 11, 2011 3:01 PM
  • Eric, Thanks for your help; it worked.  (BTW, it is F12, not F9.)  I let the website know they have an issue with IE10.

     

    +tom


    +tom Cupertino, CA
    Tuesday, October 11, 2011 3:02 PM