none
Dúvida com Formula no Excel ou VBA ?

    Question

  • Prezados,

    tenho a seguinte formula no excel:
    =ESQUERDA(B2;PROCURAR(" ";B2)-1)

    Na minha celula B2 eu tenho um texto to tipo:
    BUCHA ROLAMENTO CONICO

    Essa formula que mencionei acima, ela me retorna a primeira palavra da frase, que no caso é BUCHA. Preciso que me retorne não apenas a primeira palavra e sim a primeira e a segunda, no caso o resultado da formula ficaria BUCHA ROLAMENTO.

    Alguem pode me ajudar ?


    Att, Estanislau Frade msn: lauedele@hotmail.com email: estanislaufrade@yahoo.com.br estanislau.frade@vale.com

    Monday, July 09, 2012 4:05 PM

Answers

  • Você testou a fórmula? Ela faz exatamente isso que disse.

    No entanto, se a sua expressão possuir exatamente duas palavras (ou melhor, um espaço), a fórmula retornará um erro. Use essa versão que adaptei do David:

    =SEERRO(ESQUERDA(B2;LOCALIZAR("#";SUBSTITUIR(B2;" ";"#";2);1)-1);B2)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    Tuesday, July 10, 2012 8:42 PM
  • Boa tarde amigo.

    Experimente substituir a segunda ocorrencia do espaço em branco por um caracter e usar sua expressão para localiza-lo:

    +/- assim =ESQUERDA(B2;LOCALIZAR("#";SUBSTITUIR(B2;" ";"#";2);1)-1).


    David Brigido

    Monday, July 09, 2012 4:48 PM

All replies

  • Boa tarde amigo.

    Experimente substituir a segunda ocorrencia do espaço em branco por um caracter e usar sua expressão para localiza-lo:

    +/- assim =ESQUERDA(B2;LOCALIZAR("#";SUBSTITUIR(B2;" ";"#";2);1)-1).


    David Brigido

    Monday, July 09, 2012 4:48 PM
  • Na verdade preciso dela para me retornar a primeira e segunda palavras de um texto, sem eu ter que informar quais são essas palavras.

    Preciso que o resultado seje BUCHA ROLAMENTO


    Att, Estanislau Frade msn: lauedele@hotmail.com email: estanislaufrade@yahoo.com.br estanislau.frade@vale.com

    Tuesday, July 10, 2012 1:49 PM
  • Você testou a fórmula? Ela faz exatamente isso que disse.

    No entanto, se a sua expressão possuir exatamente duas palavras (ou melhor, um espaço), a fórmula retornará um erro. Use essa versão que adaptei do David:

    =SEERRO(ESQUERDA(B2;LOCALIZAR("#";SUBSTITUIR(B2;" ";"#";2);1)-1);B2)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    Tuesday, July 10, 2012 8:42 PM