none
SQL Cluster failures

    Question

  • Hello,

    On a SQL Cluster I have two nodes and one seems to be weak... Anytime I am on B Node with all instances it works for 48 hours at least but on Node A after 1 hour it fails...

    1. cannot access the instances anymore: instance1\instance1 is not available error 26 but I am able to access instance1 the netbios name which will display the databases through SSMS.

    2. email result of SQL jobs are not more flowing... not sent error 

    [264] An attempt was made to send an email when no email session has been established

    If I failed over to the other node it will work again...

    Is it possible to have instance1 and instance1\instance1 both sets available for the email configuration? and for the access to the databases through application?

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    • Moved by Kalman Toth Saturday, April 12, 2014 4:24 AM Better fit
    Tuesday, March 25, 2014 7:37 PM

Answers

  • The only confusing aspect is that it works without issues for an hour and then it starts to fail.

    If you feel it is the NIC then check the setting for Auto negotiate on the NIC's, it should be set to FULL not AUTO.

    • Marked as answer by Felyjos Wednesday, April 23, 2014 5:54 PM
    Saturday, April 12, 2014 4:04 AM

All replies

  • Take a look at this post might give you a hand in troubleshooting this.

    If this is helpful please mark it so. Also if this solved your problem mark as answer.

    Wednesday, March 26, 2014 8:57 AM
  • let me try...

    Thanks,
    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    Wednesday, March 26, 2014 2:27 PM
  • Did you get a chance to look at the Windows Application event log and Cluster logs.

    In most cases, one of these logs point out the issue.

    I would start with setting a max server memory for all the instances in such a way that the sum total memory for all instances does not exceed (.75 times the memory) on any node in the cluster. If the SQL instances grab all the memory you have, then the OS goes into a perpetual swap situation.

     

    Saturday, March 29, 2014 6:32 PM
  • Hello Dom,

    Is this still a issue


    Please mark this reply as the answer or vote as helpful, as appropriate, to make it useful for other readers

    Sunday, April 06, 2014 9:56 PM
  • The memory size is using only 85 Gb from the 135 Gb available. and both nodes have the same configuration...

    seems to have a NIC issue at once at least as one of them was responding to 100 Mb instead of 1 Gb it is stable at 1 Gb since friday

    in progress


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    Tuesday, April 08, 2014 2:27 AM
  • The only confusing aspect is that it works without issues for an hour and then it starts to fail.

    If you feel it is the NIC then check the setting for Auto negotiate on the NIC's, it should be set to FULL not AUTO.

    • Marked as answer by Felyjos Wednesday, April 23, 2014 5:54 PM
    Saturday, April 12, 2014 4:04 AM
  • Hello,

    All our clusters (about 15 now) have been set to Auto per request from the Network team.

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    Monday, April 14, 2014 7:26 PM
  • I am not a networking expert but would suggest you give it a shot by setting the NIC's to 1000/Full instead of Auto/Auto.

    You can always set it back.

    Thursday, April 17, 2014 2:49 AM