none
problem with the online xml/xsd validator

    Question

  • Hello,

    for a job I am required to validate my xml files against a schema using the online validator at

    http://apps.gotdotnet.com/xmltools/xsdvalidator/

    and even though my files validate without any problems using either offline validators or other online
    ones I can't get a single file validated using the above mentioned one.

    For every single element in my xml document I get an error message saying:

    Warning at (4,2): Could not find schema information for the element 'xyz'.

    It seems like the validator fails completetly to connect the instance to the schema.
    I did various tests and am pretty sure it's not a nemspace problem.
    In fact I can't find a single example of an xml/xsd pair that validates, even if I use
    examples from msdn or the w3c website.

    I would be very grateful if anyone had ideas what the problem could be or could supply me with a xml/xsd
    pair that passes validation

    thanks, daniel

    Monday, June 05, 2006 10:26 PM

Answers

  • Hi Daniel,

    The reason you are getting errors is that gotdotnet owners stopped supporting xml/xsd validator application in January and removed the backend code.  However, they haven't removed the front end from their site yet. 

    Stan Kitsis

    Monday, June 05, 2006 10:45 PM

All replies

  • Hi Daniel,

    The reason you are getting errors is that gotdotnet owners stopped supporting xml/xsd validator application in January and removed the backend code.  However, they haven't removed the front end from their site yet. 

    Stan Kitsis

    Monday, June 05, 2006 10:45 PM
  • thank you very much for your information, that helps a lot! I heared that the whole xml section is been taking down on gotdotnet.com and moved to http://www.msdn.com,

    is there going to be a new online validator soon?

    cheers, daniel
    Tuesday, June 06, 2006 9:04 AM