none
'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine error

    Question

  • Hi<o:p></o:p>

    Host Win 2008 R2 Server (64 bit).<o:p></o:p>

    My app configuration is set to 'Any CPU' in VS2010. I have installed Microsoft Access Database 2010 64 bit. I am using Microsoft.ACE.OLEDB.12.0 as provider. When I run the app I get a The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine error. <o:p></o:p>

    What am I doing wrong and how can I access the MS Access db on 64bit Windows 2008 Server?<o:p></o:p>

    Thanks<o:p></o:p>

    Regards<o:p></o:p>


    Sunday, June 17, 2012 1:29 AM

Answers

All replies

  • Hi<o:p></o:p>

    installed Microsoft Access Database 2010 64 bit. I am using Microsoft.ACE.OLEDB.12.0 a

    ACE.oledb.12.0 dosen't work in the 64-bit os

    download patch from

    http://www.microsoft.com/en-us/download/details.aspx?id=13255


    $Kracker

    • Proposed as answer by s3xs1 Friday, October 04, 2013 4:03 PM
    Sunday, June 17, 2012 11:25 AM
  • Hi

    I have already installed the 64-bit version (AccessDatabaseEngine_x64.exe) of the Microsoft Access Database Engine 2010 from the link you posted. What am I missing? Do I need to install the 32-bit version (AccessDatabaseEngine.exe)? What provider do I need to use?

    Thanks

    Regards

    Sunday, June 17, 2012 12:04 PM
  • Hi Yahya,

    Welcome to MSDN Forum.

    Here's a discussion about this error, please refer to it and let me know whether it is worked for you.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine"

    Best Regards


    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    Monday, June 18, 2012 7:36 AM
    Moderator
  • The setup you described appears to be correct. I would verify the install by checking the below path to insure that the data provider exists:

    "C:\Program Files\Common Files\Microsoft Shared\OFFICE14\ACEOLEDB.DLL"


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, June 18, 2012 1:40 PM
  • Hi Yahya,

    Any update about this issue? If you need further help, please feel free to let me know.

    Best Regards


    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, June 21, 2012 2:26 AM
    Moderator
  • Hi

    Check your MS Application if installed as x64 or 32 bit environment. On Web App Server (IIS Manager) try to change your application pool on advance settings >> Enable 32 bit Application - set True/false then restart the application. On windows app try to publish in x86/64 bit.

    Hope it helps

    Best regards


    To better the Man



    • Edited by Frequent J Friday, September 21, 2012 6:10 AM
    Friday, September 21, 2012 6:10 AM
  • This worked fine for me.

    DBA in Pinellas County Schools

    • Proposed as answer by JohnK.NET Saturday, February 02, 2013 3:10 AM
    Thursday, October 11, 2012 1:50 PM
  • Good link!  Perfect fix.  Thanks, Allen.
    Tuesday, November 13, 2012 2:30 AM
  • worked here as well..BUT, had to install both x64 and x86
    Friday, December 21, 2012 5:15 PM
  • The second link worked for me 100%

    Win 7 x64 and Office 2010 x64.

    Wednesday, February 27, 2013 3:03 AM
  • Thanks issue resolved after downolading
    Friday, March 08, 2013 7:48 AM
  • I am still have issues trying to get rid of this error.  The 32 bit does not recognize the .accdb file type.  All my databases are local on my laptop and I am trying to create a connection from my Access database to VBA 2010 express.  Did I miss something in this thread?  I am using Windows 7 home, 64x, VBA express 2010
    Saturday, March 16, 2013 6:28 PM
  • Worked for me Windows Server 2008 R2, SQL Server 2012 (error using import export wizard and Excel files)
    Thursday, April 04, 2013 12:51 PM
  • Sweet, perfect!  This has been driving me bat-crazy, but your solution worked on SQL 2008 R2 64-bit w/ Office 2013 64-bit installed on the same machine.

    Thanks so much!


    Bryce



    • Edited by Bryce White Wednesday, May 01, 2013 2:48 PM edit
    Wednesday, May 01, 2013 2:47 PM
  • Dude u Rock, thanks
    Wednesday, June 05, 2013 5:42 PM
  • This issue is caused by a missing 64-bit installation of the required driver.
    To fix this issue, perform the following steps...

    1.) Install ONLY the 64-bit driver from the following location
    http://www.microsoft.com/en-us/download/details.aspx?id=13255

    2.) Go to the website's application pool in IIS, choose advanced settings, and set Enable 32-bit applications to FALSE

    3.) Restart the website

    www.meltdown.co.za

    • Proposed as answer by oggynr1 Monday, June 30, 2014 12:04 PM
    Wednesday, June 12, 2013 11:01 AM
  • I am using:

    • Win 7 x64
    • Office 2010(32 bit).
    • MSFT Access Database 2010(32 bit)
    • MSFT Office Access Database engine 2007.

    My project is ANY CPU but still getting this error. Here is my connection string

    "Provider=Microsoft.ACE.OLEDB.12.0;Data Source=" + fileLocation + ";
     
    Extended Properties=\"Excel 12.0;HDR=Yes;IMEX=1\";"

    And also set the app pool to false for 32 bit. but it is still giving some problem.

    ANy clue?

    Monday, June 17, 2013 9:34 PM
  • If you are working with 32-bit Office then you need to set the Platform option to x86 for Windows apps. If it's a web app then the Enable 32-Bit Applications option should be set to True for the app's application pool.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    • Proposed as answer by Mina Nagy Tuesday, October 29, 2013 1:07 PM
    Monday, June 17, 2013 10:07 PM
  • I am trying to access an Excel (Office-2010 32 Bit) on a WIN-7 machine (64 Bit) using Powershell and receiving this error 'The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.'.

    Any help to fix this..

    Wednesday, August 14, 2013 2:30 PM
  • Any solution for the Excel (32-bit) on a Win-7 (64-bit) machine using powershell? Having the exact same problem
    Friday, August 16, 2013 3:57 PM
  • This error usually occurs when there is a mismatch between the bits allocation of the system on which the application  is built and that of the server system it is hosted into.

    If the base system is 32-bits and server is say, 64 bits....This error will erupt.

    To resolve,

    1.) Go to IIS on the server

    2.) Check for the application pool on which the website is hosted.

    3.) Right Click on that application pool and go to properties.

    4.) Set "Enable32-bitsApplication" to true.


    Thursday, August 29, 2013 9:21 AM
  • If you are using a compiled application compile to 32 bit so it matches Office/Access Redistributable.

    Thursday, September 05, 2013 8:21 PM
  • Had the same problem with connecting to MS Access 2013 database from SSDT on x64 and installing the x32 access database engine 2007 solved the problem!
    Thursday, November 21, 2013 2:49 PM
  • I am getting this error, when i adding a reference in the project

    Wednesday, November 27, 2013 3:30 PM
  • Thanks. It works for me~
    Thursday, December 12, 2013 2:31 AM
  • This worked for me.

    I have recently upgraded to office 2013 (64bit) and was trying to import data from Excel to SQL Server 2008 R2. Using the import wizard generated the error you described above. Installing the fix Allen Li posted above worked flawlessly. It even fixed the excel preview issue in Outlook 2013 that I had for excel files.

    Thanks again,

    Ralph Schwehr

    Database Administrator

    State Center Community College District


    RS

    Friday, December 20, 2013 5:31 PM
  • I tried running this on a Windows Server 2008 R2 and got the following error:

    Error 1935.  An error occurred during the installation of assembly component {98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}.  HRESULT: 0x80070BC9.

    Friday, February 07, 2014 6:51 PM
  • That is the download address, not a patch.

    Dave

    Tuesday, February 11, 2014 3:53 AM
  • THank You man
    Saturday, February 22, 2014 9:34 AM
  • Hi guys

    I have a similar one but a little more complicated.

    Two servers, one is a virtual directory of the first one. Both need to access OLEDB12. The driver is installed on the 1st machine, 64bit. How to make it available on the 2nd machine?

    Tuesday, July 01, 2014 12:04 PM
  • Install it...

    Dave

    Tuesday, July 01, 2014 1:34 PM
  • Yes.. It works!!

    I have SQL Server 2012 64 bit, MS Office 64 bit and Win 7 64 Bit.  When I tried to import an Excel File created in 32 bit I got this error.

    Solution:  

    Download and install this 32 bit Access Database Engine

    http://www.microsoft.com/en-us/download/confirmation.aspx?id=23734

    I tried to install first the 64bit Access engine did nor work, from 

    http://www.microsoft.com/en-us/download/details.aspx?id=13255

    The solution is 32 bit engine from the:

    http://www.microsoft.com/en-us/download/confirmation.aspx?id=23734

    -niladri 

    Wednesday, July 09, 2014 4:46 PM
  • I ve installed it but no such dll in this file path what should I do now?
    Friday, July 11, 2014 11:31 AM
  • Try to add new build configration in to your project: Like this
    Thursday, July 24, 2014 3:25 PM
  • Allen Li wrote:

    Hi Yahya,

    Welcome to MSDN Forum.

    Here's a discussion about this error, please refer to it and let me know whether it is worked for you.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine

    Hi Allen,

    I reviewed that link but it states that it works only for 64 bit Office installations.

    I am running 32-bit Office (on 64 bit Windows 7), and I am attempting to connect to Access 2010 through VBScript (vs a web-app).  Do you know of a solution that will work for me?  Thanks!

    [EDIT]:  I found an alternate method which is working for me, which is to run my VBScript via 32-bit cscript.exe  ref: stackoverflow.com/questions/2806584/how-do-i-run-a-vbscript-in-32-bit-mode-on-a-64-bit-machine

    However, I would still be interested in knowing if there is a solution that is more closely related to the 64-bit Office method that Allen provided.  Thanks again!




    • Edited by SkiReturn14 Friday, August 15, 2014 7:42 PM
    Friday, August 15, 2014 6:13 PM
  • Or you could do like we did and uninstall 32 bit and install 64 bit Office. Less problems overall esp. when build .NET CPU=ANY apps which doesn't really work well with the ACE provider.

    Dave

    Friday, August 15, 2014 8:49 PM
  • it helps me a lot....
    Monday, August 18, 2014 8:04 AM
  • Have tried all the above but still get

    The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine

    running windows 8.1 with sp1 x64

    can someone please advise how you register it.

    Monday, September 08, 2014 3:02 AM
  • Even when using the Server Explorer in Visual Studio to connect to an Access Database you get the message

    The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine

    Monday, September 08, 2014 3:09 AM
  • Visual Studio (Server Explorer) runs 32-bit so you would need to have the 32-bit version of the ACE OLEDB Provider installed.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, September 08, 2014 3:34 AM