none
Problemas con access no me hace la consulta actualizada

    Question

  • ayuda por favor: lo que pasa ya tengo un mes con una bd y una tabla datos agrego datos y asi y todo bn hago conusltas por ejemplo status disponibles, por cruzar y salen bien, pero hoy me tope con el PROBLEMA QUE EJECUTO MI CONSULTA y solo me da los disponibles que tengo desde ayer los que voy agregando hoy no los ejecuta por que razón?
    Friday, September 27, 2013 5:32 PM

All replies

  • osea los que agrego desce mi bd a mi tabla si hace la consulta bien , pero los que se agregan desde vb.net no los ace la consulta ayudaaaaaaaaaaaaaaaaaaa
    Friday, September 27, 2013 5:33 PM
  • Calma,calma ejejej. Primero puedes indicarnos el código de tu consulta? vamos a ver ok?


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    Friday, September 27, 2013 5:51 PM
  • consulta en Access SELECT *
    FROM datos
    WHERE status="en patio";

    osea esta bien me arregoja bien todo pero si x ejemplo te describiré lo que hago paso a paso:

    1.agrego registros a mi tabla desde aquí de Access y hago la consulta y sale perfectamente, luego me voy a ...

    2. me voy a vb.net ejecuto mi programa y en mi datagrid se ve la tabla bien y actualizada y todo cuando agrego registro me actualiza la tabla y de echo la agrega tmb en Access, pero de nuevo me voy a ccess..

    3. y vuelvo a ejecutar mi consulta y no me agrega los registro que di de alta en vb.net mas sin embargo si se aagregan a la tabla, pero no als ejecuta en la consulta..

    Friday, September 27, 2013 6:05 PM
  • Ok...

    Una pregunta...desde donde estas ejecutando tu programa? Desee el propio visual studio o desde el programa compilado? Cada vez que dices que pasas de vb a Access paras la ejecución del programa? Es importante ya que sospecho algo kejeje


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    Friday, September 27, 2013 6:21 PM
  • desde el visual que tengo en mi compu de projets tengo todo el programa completo, pero nose que abra pasado si ayer todavía ejecutaba vb y agregaba se iban a mi tabla de Access hacia consulta y funcionaba y ahora nose que abra pasado.

    si te lo agradeceria

    Friday, September 27, 2013 6:24 PM
  • Vale y seguramente tienes tu bbdd en los datasource de visual verdad? Te comento, que Visual Studio acada vez que ejecutas para depuración,por defecto te mueve una copia de la bbdd al directorio bin\debug. Por lo que podemos darnos cuenta que

    1.- desde Access moddificas e insertas registros.OK.

    2.- Ejecutas la depuración y agregas registros te funciona pero es sobre la copia

    3.- Vas a tu Access y los registros no están

    Eso es lo que ocurre. Ve al datasource de tu bbdd en el administardor de servidores o fuentes de datos. Marca tu bbdd y botón derecho propiedades. Vas a las propiedades y hay una que se llama Copia local o algo así, no puedo verificarlo ya que no tengo el ordenador delante, y ponlo a false


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    Friday, September 27, 2013 6:33 PM
  • Revisa a fondo este articulo de Leandro

    http://ltuttini.blogspot.com.es/2012/11/visual-studio-base-de-datos-integradas.html


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    Friday, September 27, 2013 6:35 PM
  • voy a Access y si están si lo agrega desde vb, pero al momento de hacer la consulta solo agrega los que doy manual de alta en la tabla, los que agregue desde vb, no los refleja la consulta pero si están en la tabla... como vez?
    Friday, September 27, 2013 6:38 PM
  • crie otra bd otra tabla y otro vb.net con también agregar y me ace lo mismo los que agrego desde vb se ven en la tabla pero no en consulta
    Friday, September 27, 2013 6:40 PM
  • Has revisado el enlace que te puse?? Verific las propiedades de tu bbdd integrada en el explorador de servidores. ...


    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    Friday, September 27, 2013 6:41 PM
  • no amigo creo que no me estas entendiendo mucho, lo que pasa es que agrego datos desde mi vb.net y luego voy a Access y se ve esos datos en mi tabla, pero haho de nuevo la consulta de where status y es ahí donde me me arroja lo que agregue en vb. net mas sin embargo si esta en la tabla pero en consulta no lo muestra¨????
    Friday, September 27, 2013 6:56 PM
  • perdón digo que solo la consulta que hago agrega los que pongo manual de mi tabla, pero los que agreguedesde vb no los arroja la consulta...si me expliko
    Friday, September 27, 2013 6:59 PM
  • el problema es como en Access no? que osea si se ve en la tabla lo que agrego en vb pero hago la consulta y como que no pone lo que agrege en vb
    Friday, September 27, 2013 7:01 PM
  • Puedes verificar en tu depuración, donde apunta tu objeto conexion?

    Si se solucionó tu consulta no olvides marcar la respuesta. Si te ayudó vótala como útil. Saludos

    Friday, September 27, 2013 7:24 PM
  • pues es que todo es bien raro porque ayer desde otro formulario veia lo que iba agregando por fecha asi como lo daba de alta y ahora no me arroja nada
    Friday, September 27, 2013 8:28 PM
  • ya lo solucione, es que tenia un espacio en el datagrid al momento de guardar :)
    Friday, October 04, 2013 2:07 PM