none
Unable to Start Report Builder

    Question

  • Hi,

    I am new to report server. After installing it I am able to start Report Manager, however when I click on Report Builder button in Report manager, I get the following dialog:

    Cannot download the aplication. The application is missing required files. Contact application vendor for assistance.

    When I press the 'Details' button, I get this (pasting here):

    --------------------------------------------------------------------------------------------------------

    PLATFORM VERSION INFO
     Windows    : 6.1.7601.65536 (Win32NT)
     Common Language Runtime  : 4.0.30319.18052
     System.Deployment.dll   : 4.0.30319.17929 built by: FX45RTMREL
     clr.dll    : 4.0.30319.18052 built by: FX45RTMGDR
     dfdll.dll    : 4.0.30319.17929 built by: FX45RTMREL
     dfshim.dll    : 4.0.41209.0 (Main.041209-0000)

    SOURCES
     Deployment url   : file:///C:/Users/Peter%20Battelino/Downloads/ReportBuilder_3_0_0_0%20(4).application

    IDENTITIES
     Deployment Identity  : ReportBuilder_3_0_0_0.application, Version=11.0.2100.60, Culture=neutral, PublicKeyToken=c3bce3770c238a49, processorArchitecture=x86

    APPLICATION SUMMARY
     * Online only application.
     * Trust url parameter is set.
    ERROR SUMMARY
     Below is a summary of the errors, details of these errors are listed later in the log.
     * Activation of C:\Users\Peter Battelino\Downloads\ReportBuilder_3_0_0_0 (4).application resulted in exception. Following failure messages were detected:
      + Downloading file:///C:/Users/Peter Battelino/Downloads/RptBuilder_3/MSReportBuilder.exe.manifest did not succeed.
      + Could not find a part of the path 'C:\Users\Peter Battelino\Downloads\RptBuilder_3\MSReportBuilder.exe.manifest'.
      + Could not find a part of the path 'C:\Users\Peter Battelino\Downloads\RptBuilder_3\MSReportBuilder.exe.manifest'.
      + Could not find a part of the path 'C:\Users\Peter Battelino\Downloads\RptBuilder_3\MSReportBuilder.exe.manifest'.

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
     No transaction error was detected.

    WARNINGS
     There were no warnings during this operation.

    OPERATION PROGRESS STATUS
     * [7/25/2013 9:31:36 AM] : Activation of C:\Users\Peter Battelino\Downloads\ReportBuilder_3_0_0_0 (4).application has started.
     * [7/25/2013 9:31:36 AM] : Processing of deployment manifest has successfully completed.
     * [7/25/2013 9:31:36 AM] : Installation of the application has started.

    ERROR DETAILS
     Following errors were detected during this operation.
     * [7/25/2013 9:31:36 AM] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
      - Downloading file:///C:/Users/Peter Battelino/Downloads/RptBuilder_3/MSReportBuilder.exe.manifest did not succeed.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
       at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
       at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
       at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)
       at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, Uri& appSourceUri, String& appManifestPath)
       at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
       at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
       at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
       at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
      --- Inner Exception ---
      System.Net.WebException
      - Could not find a part of the path 'C:\Users\Peter Battelino\Downloads\RptBuilder_3\MSReportBuilder.exe.manifest'.
      - Source: System
      - Stack trace:
       at System.Net.FileWebRequest.EndGetResponse(IAsyncResult asyncResult)
       at System.Net.FileWebRequest.GetResponse()
       at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
      --- Inner Exception ---
      System.Net.WebException
      - Could not find a part of the path 'C:\Users\Peter Battelino\Downloads\RptBuilder_3\MSReportBuilder.exe.manifest'.
      - Source: System
      - Stack trace:
       at System.Net.FileWebResponse..ctor(FileWebRequest request, Uri uri, FileAccess access, Boolean asyncHint)
       at System.Net.FileWebRequest.GetResponseCallback(Object state)
      --- Inner Exception ---
      System.IO.DirectoryNotFoundException
      - Could not find a part of the path 'C:\Users\Peter Battelino\Downloads\RptBuilder_3\MSReportBuilder.exe.manifest'.
      - Source: mscorlib
      - Stack trace:
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean useAsync)
       at System.Net.FileWebStream..ctor(FileWebRequest request, String path, FileMode mode, FileAccess access, FileShare sharing, Int32 length, Boolean async)
       at System.Net.FileWebResponse..ctor(FileWebRequest request, Uri uri, FileAccess access, Boolean asyncHint)

    COMPONENT STORE TRANSACTION DETAILS
     No transaction information is available.

    --------------------------------------------------------------------------

    Does anybody know what the rpoble is?

    Thank you in advance.

    Peter Battelino

    BTE Corporation 


    PMBT

    Thursday, July 25, 2013 1:49 PM

Answers

  • Hi Meagan,

    Thank you for your response, much apreciated.

    First, a couple of comments: Before submitting my query, I have read all simmilar threads. Also, the detailed error message you ask for is in my original submission.

    Now for my findings: it seems the Report Builder does not launch from Report Manager when the latter is running in Google Chrome - my default browser. It turns out Report Builder does launch if one uses IE. Not sure if this is a feature or a bug?

    Thanks again for your reply.


    PMBT

    • Marked as answer by PMBT Tuesday, July 30, 2013 1:55 PM
    Sunday, July 28, 2013 1:17 PM

All replies

  • Here is a similar thread with the same answer.

    It lists some things you can try:

    "So, please try the following steps to fix the issue:

    1. Update the Reporting Services to date. Suppose the Report Builder is corrupted, this step will repair it.
    2. Check that the Report Builder application is existing
          Open the Report Server folder. By default, the folder is located in: C:\Program Files\Microsoft SQL Server\MSSQL.<X>\Reporting Services\ReportServer\ReportBuilder
          Make sure the file "ReportBuilder.application" is existing in the folder mentioned above.
    3. If it is existing, please use the following URL to access the Report Builder directly:
      http://<server>/ReportServer/ReportBuilder/ReportBuilder.application

    If we are still not able to open it, could you please help to copy the detailed error message from the error dialog and paster it in this thread. This will help us to solve the issue."

    Saturday, July 27, 2013 11:38 PM
  • Hi Meagan,

    Thank you for your response, much apreciated.

    First, a couple of comments: Before submitting my query, I have read all simmilar threads. Also, the detailed error message you ask for is in my original submission.

    Now for my findings: it seems the Report Builder does not launch from Report Manager when the latter is running in Google Chrome - my default browser. It turns out Report Builder does launch if one uses IE. Not sure if this is a feature or a bug?

    Thanks again for your reply.


    PMBT

    • Marked as answer by PMBT Tuesday, July 30, 2013 1:55 PM
    Sunday, July 28, 2013 1:17 PM
  • The request for the error log was from the thread to which I linked (sorry, I copied a couple of lines too many).  The fact that Report Builder doesn't open from Report Manager in Chrome does not surprise me.  I have found several things from SSRS that do not work well in Chrome.  I just have my users stick with IE or Firefox when accessing SSRS reports.
    Sunday, July 28, 2013 3:58 PM
  • Hi,

    Can you please check the .Net framework version installed is compatible with SQL Server version which you have installed.

    Monday, July 29, 2013 4:02 AM
  • Hi Pmbt,

    From your description, you cannot start Report Builder using Google Chrome, right? In Reporting Services, you use a Web browser to view reports and run Report Manager. Not all report functionality is supported by all browsers. Google Chrome is not a supported browser for SSRS. So we recommend you to start Report Builder using IE. For the detail information about it, please see:
    http://msdn.microsoft.com/en-us/library/ms156511(v=sql.105).aspx
    http://social.technet.microsoft.com/Forums/sqlserver/en-US/f50eb196-3f15-408d-acb7-7f90e3348e3e/why-does-the-ssrs-calendar-control-not-work-in-google-chrome-but-plenty-of-other-websites-with

    If you have any questions, please feel free to ask.

    Regards,


    Charlie Liao
    TechNet Community Support

    Tuesday, July 30, 2013 4:37 AM
    Moderator
  • Hi Kiran,

    Yes it is. In the meantime I have resolved the issue. Thank you for your response any way.


    PMBT

    Tuesday, July 30, 2013 1:57 PM
  • Hi Charlie,

    The issue is resolved, please see rest of the thread. Thank you for your response any way.


    PMBT

    Tuesday, July 30, 2013 1:58 PM