locked
Invalid URI: The format of the URI could not be determined

    Question

  • Hello,

    I'm receiving the errors "Invalid URI: The format of the URI could not be determined." when viewing the build summary within Visual Studio 2010 Team Web Access. However when viewing the same build summary within Team Explorer 2010, I do not see these errors. I'm not sure what the problem is. Can anyone help?

     

     

    Background:

    I performed an upgrade from TFS 2008 to TFS 2010 onto new physical servers. I followed the steps outlined by Microsoft and the upgrade went successful. I'm able to login to the new TFS 2010 server, create team projects, access the Sharepoint sites, download source code, and login to Team Web Access. My new TFS 2010 environment is setup as a dual-server.

     

    App Tier:

    * Windows Server 2008 SP2

    * Reporting Services

    * IIS 7.0

    * SharePoint Service 3.0 SP1

    * Team Foundation Server 2010 SP1

     

    Data Tier:

    * Windows Server 2008 R2

    * SQL Server 2008 Enterprise SP1

    Tuesday, June 28, 2011 7:26 PM

All replies

  • Hello briang01,

    Thanks for your post.

    I am sorry I can’t view the image you post in your post, could you please repost it? In addition, what about other build summary? If you are trying to open other build summary via web access, will you get the same error?

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, June 30, 2011 7:56 AM
  • Hello,

     

    Since I can't seem to find a way to attach a screenshot, I've pasted the source of the web page. You will see the error "Invalid URI". Basically I can see the header which shows the build number, build quality, and the various buttons like "View Summary", "View Log", "Open Drop Folder", etc. However within the Summary section, the errors appear at the spot where the page is trying to show the path to the solution file.

     

    NOTE: These "Invalid URI" errors only occur on builds that were performed before my migration/upgrade to TFS 2010. If I run a new build (same build type), I do not see these "Invalid URI" errors. Thank you for your help.

     

    <div class="tswa-buildview-mainsection">
                            <div class="tswa-buildview-mainsectiontitle">
                                Latest Activity
                            </div><div id="ctl00_c_br1_ctl17" class="tswa-buildview-item">
                                Build last modified by TFSSERVICE 8 days ago.
                            </div>
                        </div><div class="tswa-buildview-mainsection">
                            <div class="tswa-buildview-mainsectiontitle">
                                Summary
                            </div><div>
                                <div id="ctl00_c_br1_cfg3476611" class="tswa-buildview-configheader">
                                    Win32 | Release
                                </div><div id="ctl00_c_br1_ew3476611" class="tswa-buildview-indentitem">
                                    0 error(s), 12 warning(s)
                                </div><div id="ctl00_c_br1_cfgp3476611" class="tswa-buildview-indentitem">
                                    2 projects/solutions compiled<div class="tswa-buildview-indentitem">
                                        <div class="err" title="Invalid URI: The format of the URI could not be determined."><img align="absMiddle" src="/tfs/web/Resources/Images/error-sm.gif" width="16" height="16" border="0"   >Invalid URI: The format of the URI could not be determined.</div>
                                    </div><div class="tswa-buildview-indentitem">
                                        <div class="err" title="Invalid URI: The format of the URI could not be determined."><img align="absMiddle" src="/tfs/web/Resources/Images/error-sm.gif" width="16" height="16" border="0"   >Invalid URI: The format of the URI could not be determined.</div>
                                    </div>
                                </div><div id="ctl00_c_br1_tr3476611" class="tswa-buildview-indentitem">
                                    No Test Results
                                </div><div id="ctl00_c_br1_cc3476611" class="tswa-buildview-indentitem">
                                    No Code Coverage Results
                                </div>
                            </div><div>
                                <div id="ctl00_c_br1_cfg3476615" class="tswa-buildview-configheader">
                                    x64 | Release
                                </div><div id="ctl00_c_br1_ew3476615" class="tswa-buildview-indentitem">
                                    0 error(s), 5 warning(s)
                                </div><div id="ctl00_c_br1_cfgp3476615" class="tswa-buildview-indentitem">
                                    2 projects/solutions compiled<div class="tswa-buildview-indentitem">
                                        <div class="err" title="Invalid URI: The format of the URI could not be determined."><img align="absMiddle" src="/tfs/web/Resources/Images/error-sm.gif" width="16" height="16" border="0"   >Invalid URI: The format of the URI could not be determined.</div>
                                    </div><div class="tswa-buildview-indentitem">
                                        <div class="err" title="Invalid URI: The format of the URI could not be determined."><img align="absMiddle" src="/tfs/web/Resources/Images/error-sm.gif" width="16" height="16" border="0"   >Invalid URI: The format of the URI could not be determined.</div>
                                    </div>
                                </div><div id="ctl00_c_br1_tr3476615" class="tswa-buildview-indentitem">
                                    No Test Results
                                </div><div id="ctl00_c_br1_cc3476615" class="tswa-buildview-indentitem">
                                    No Code Coverage Results
                                </div>
                            </div>
                        </div>
       
                    </div>

    Thursday, July 07, 2011 10:57 PM