none
Other Shared Memory Provider, error: 0 - No process is on the other end of the pipe.

    Question

  • <!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1; mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-1610611985 1073750139 0 0 159 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin-top:0cm; margin-right:0cm; margin-bottom:10.0pt; margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;} .MsoPapDefault {mso-style-type:export-only; margin-bottom:10.0pt; line-height:115%;} @page Section1 {size:595.3pt 841.9pt; margin:70.85pt 70.85pt 2.0cm 70.85pt; mso-header-margin:35.4pt; mso-footer-margin:35.4pt; mso-paper-source:0;} div.Section1 {page:Section1;} -->

    Hallo,

    I have a c# .DLL that is used to provide security to a SSAS cube. This dll is suposed to connect to a MSSQL server data base, execute a Stored Procedure and retreve the result.
    Due to security question I was asqed to cange the way this dll acces the SQL server from windows authentification to named pipe authentification. Since the dll uses a external text file to configure the connection string a changed this :
    Server=Server;DataBase=HERZ; Integrated Security=TRUE;
    to this
    Server=Server;DataBase=HERZ;User ID=DOMAIN\USER;Password=XXX!; Integrated Security=no;

    since then I can’t run the dll anymore .
     

     

    ERROR message:

    occurred during the login process. (provider: Shared Memory Provider, error:
    0 - No process is on the other end of the pipe.)

     
    Details:

    SQL server 2005 with SP3 running on Windows server 2003
    Mixed Authentification Mode
    Remote Connection allowed
    Using Named Pipes and TCP/IP
    SQL Browser and SQL Agent services are started.
    A windows Firewall exception for sqlsvr.exe exists.

    A test with
    sqlcmd -S lpc:server
    returned:

    HResult 0x57, Level 16, State 1
    SQL Network Interfaces: Cannot open a Shared Memory connection to a remote SQL s
    erver [87].
    Sqlcmd: Error: Microsoft SQL Native Client : An error has occurred while establi
    shing a connection to the server. When connecting to SQL Server 2005, this failu
    re may be caused by the fact that under the default settings SQL Server does not
     allow remote connections..
    Sqlcmd: Error: Microsoft SQL Native Client : Login timeout expired.

    A test with:
    sqlcmd -S tcp:server

    returned >1

    Any help will be appreciated .

    Clara



     



    Tuesday, June 09, 2009 2:50 PM

Answers

  • Btw, the user exists in SQL Security. I tried with SQL login and windows authentification. The user is also mapped to the right Database with owner role.



    Hi Clara,

    Is the user you mentioned  a domain account(domain\user) or a SQL Server Loin account ?

    If you want to specify the user to connect to SQL Server, SQL Server Authentication is required by setting Integrated Security as false in the connecting string or ignore the Integrated Security option. The default value of Integrated Security is false.  Also, the User ID in the connecting string must be a SQL Login account for SQL Server authentication rather than a domain account. Therefore, you need to add a new login in SQL Server by the steps I mentioned above.

    In addition, you could specify the password without any special format when establishing a connection, such as “ …User ID=sa; Password=12345;…”.


    If you have any more questions, please let me know.

    Thanks.
    ***Xiao Min Tan***Microsoft Online Community***
    Monday, June 15, 2009 3:42 AM
    Moderator

All replies

  • Hi,

    The error might be caused by a variety of reasons. Try the following troubleshooting steps:

    1. Enable Named Pipes and TCP/IP Protocols in SQL Server Configuration Manager->SQL Server Network Configuration -> Protocols for <instancename>.
    2. Running the “Ping server” command.
    3. It the error still occurs, consider the SQL Server security. If you don’t want use Windows Integrated Authentication, I suggest you use SQL Server Authentication. If you don’t have a SQL Server login for your application, create a SQL Server login and grant permissions to access your database:
       a. Expand the Security folder in the SQL Server Enterprise Manager, right-click Logins, and click New Login.
       b. Select the SQL Server Authentication option for Authentication.
       c. Enter a login name and strong password.
       d. Grant permissions to access your database for the login account.
    4. Configure the connect string, such as  "Server=server; Database=HERZ; User Id=MyUser; password= xxxxxx".


    If you have any more questions, please let me know.

    Thanks.


    ***Xiao Min Tan***Microsoft Online Community***
    Thursday, June 11, 2009 10:32 AM
    Moderator
  • <!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:0; mso-generic-font-family:roman; mso-font-pitch:variable; mso-font-signature:-1610611985 1107304683 0 0 159 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-1610611985 1073750139 0 0 159 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin-top:0cm; margin-right:0cm; margin-bottom:10.0pt; margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;} a:link, span.MsoHyperlink {mso-style-noshow:yes; mso-style-priority:99; color:blue; text-decoration:underline; text-underline:single;} a:visited, span.MsoHyperlinkFollowed {mso-style-noshow:yes; mso-style-priority:99; color:purple; mso-themecolor:followedhyperlink; text-decoration:underline; text-underline:single;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;} .MsoPapDefault {mso-style-type:export-only; margin-bottom:10.0pt; line-height:115%;} @page Section1 {size:595.3pt 841.9pt; margin:70.85pt 70.85pt 2.0cm 70.85pt; mso-header-margin:35.4pt; mso-footer-margin:35.4pt; mso-paper-source:0;} div.Section1 {page:Section1;} -->

    Hi Xiao,

    Thank you for your replay.

    The TCP/IP protocols are enabled. That is the strange thing, that in the Surface Configuration the remote connections and TCP/IP and Named pipes are enabled but when I try to access the server I receive this

    occurred during the login process. (provider: Shared Memory Provider, error:
    0 - No process is on the other end of the pipe.)

    When running sqlcmd -S lpc:server I receive :

    "When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not
     allow remote connections.."



    Btw, the user exists in SQL Security. I tried with SQL login and windows authentification. The user is also mapped to the right Database with owner role.


     Are you suggesting that the password format may be fault?

    "4. Configure the connect string, such as  "Server=server; Database=HERZ; User Id=MyUser; password=
    xxxxxx ".
    "


    Tanks.
    Clara

    Thursday, June 11, 2009 1:04 PM
  • Btw, the user exists in SQL Security. I tried with SQL login and windows authentification. The user is also mapped to the right Database with owner role.



    Hi Clara,

    Is the user you mentioned  a domain account(domain\user) or a SQL Server Loin account ?

    If you want to specify the user to connect to SQL Server, SQL Server Authentication is required by setting Integrated Security as false in the connecting string or ignore the Integrated Security option. The default value of Integrated Security is false.  Also, the User ID in the connecting string must be a SQL Login account for SQL Server authentication rather than a domain account. Therefore, you need to add a new login in SQL Server by the steps I mentioned above.

    In addition, you could specify the password without any special format when establishing a connection, such as “ …User ID=sa; Password=12345;…”.


    If you have any more questions, please let me know.

    Thanks.
    ***Xiao Min Tan***Microsoft Online Community***
    Monday, June 15, 2009 3:42 AM
    Moderator