locked
Enabling Guidance Automation with Visual Studio 2005

    Question

  • I have Visual Studio 2005 Team Edition installed on my PC and I just installed the Guidance Automation Extensions.

     

    The documentation talks about going to Tools -> Guidance Package Manager to enable Guidance Automation.

     

    I do not have that option and if I go to create a new project I do not have a Guidance Automation project group either.

     

    What have I done wrong?  Please help.

     

    Thx.

    Tuesday, February 05, 2008 7:42 PM

Answers

  • Have you installed GAT (besides GAX)? GAX -what you say you have installed- it's only the runtime and it doesn't include any guidance packages. So it's okay to not have the entries you're describing after just having installed GAX as you will need to install at least one guidance package (eg. GAT)  to make them appear.

     

    HTH,

    -Victor.

     

    Wednesday, February 06, 2008 4:13 AM

All replies

  • This sounds an awful lot like the problem I’m having, except I’m using Visual Studio Team System 2008 Development Edition.

    Tuesday, February 05, 2008 8:32 PM
  • Okay, I think I figured this out. This is what I did and I got it to work.

     

    To Enable Guidance Packages

    1)      Launch Visual Studio and open a project, any project, it doesn’t matter.

    2)      Choose View | Other Windows | Guidance Navigator Window

    3)      Once this window is displayed, select “Guidance Package Manager…” from it’s dropdown combobox.

    4)      The Guidance Package Manager dialog box will appear.

    5)      Click on the “Enable / Disable Packages” button.

    6)      The Enable and Disable Packages dialog box will appear.

    7)      Check the box next to the “Guidance Package Development.” entry and click OK.

    8)      You may get the following big nasty error in the following section. If you don’t, you’re good to go.

    9)      After this works you should now see the “Guidance Packages” entry in the New Project dialog Box.

     

    Big Nasty Error

    System.IO.FileLoadException: Could not load file or assembly 'Microsoft.VisualStudio.TemplateWizardInterface, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

     

    Fix for Big Nasty Error

    1)      Unload the “Guidance Package Development” by unchecking the checkbox in Enable and Disable Packages dialog box.

    2)      Close down Visual Studio

    3)      Follow the instructions in the following link: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2370411&SiteID=1

    4)      Follow the previous instructions outlined under To Enable Guidance Packages. It should work this time with no big nasty error.

     

    Have fun.

    Tuesday, February 05, 2008 10:15 PM
  • Have you installed GAT (besides GAX)? GAX -what you say you have installed- it's only the runtime and it doesn't include any guidance packages. So it's okay to not have the entries you're describing after just having installed GAX as you will need to install at least one guidance package (eg. GAT)  to make them appear.

     

    HTH,

    -Victor.

     

    Wednesday, February 06, 2008 4:13 AM