locked
TF270003, Binary Folder doesn't exist

    Question

  • Hello,

    I just setup the TFS2010 in a Basic Setup and added Build-Services.
    So far everything runs fine, the only problem is, that when i want Gated-CheckIns to Build i just receive the following Warning:

    TF270003: Failed to copy. Ensure the source directory C:\Builds\1\Personal Framework\Secured Build\Binaries exists and that you have the appropriate permissions.

    and since the Folder doesn't exist there are also no Binaries, which i could use.

    Can anyone tell me, which configuration i have to change so the Folder is build correctly?

    Thursday, April 29, 2010 5:14 PM

Answers

  • Hi,

    What is the account running TFSBuildServiceHost?

    I guess that the account is "Network Service". By default,"Network Service" does not have the account to create a folder under C:\, you have to create a folder "C:\Builds" manually, and give "Network Service" the full control on this folder.


    Best regards,
    Ruiz
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com
    Thursday, May 06, 2010 6:37 AM
    Moderator

All replies

  • Hi,

    What is the account running TFSBuildServiceHost?

    I guess that the account is "Network Service". By default,"Network Service" does not have the account to create a folder under C:\, you have to create a folder "C:\Builds" manually, and give "Network Service" the full control on this folder.


    Best regards,
    Ruiz
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com
    Thursday, May 06, 2010 6:37 AM
    Moderator
  • Hi,

    Is this issue fixed?


    Best regards,
    Ruiz
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com
    Friday, May 07, 2010 10:17 AM
    Moderator
  • I am having the same issue:

    TF270003: Failed to copy. Ensure the source directory D:\WorkingDirectory\MTPS\MAIN\Binaries exists and that you have the appropriate permissions.

    THe buildservice is running as user who is an admin of TFS and an admin of the machine.

    Thursday, May 20, 2010 10:35 PM
  • Hi,

       Do we have any resolution for the same?

       I am also facing this issue although i was running my host with the account which has admin permissions on the box. 

      any help is appreciated.

    Thanks

    sudheer

    Thursday, June 03, 2010 6:53 AM
  • Having the same problem.  The account running the service, even as Administrator has the same problem.  I gave proper permissions on the folder.  

    I was also getting this error which corresponded in the Event Log...

     

    The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID 

    {3EEF301F-B596-4C0B-BD92-013BEAFCE793}

     and APPID 

    {3EEF301F-B596-4C0B-BD92-013BEAFCE793}

     to the user TFS1\TFSBuild SID (S-1-5-21-231815098-3627199624-1658995800-1004) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

     

    On windows 2008 I had to go into the registry and give permissions to this APPID so I could edit it in the Components screen.  I finally got rid of the event log, but not the warning in the development builder.  I can't build a non-application Website.


    Mastro
    Friday, June 04, 2010 9:35 PM
  • Hi,

     

    I am having the same issue. My Build Service is in the administrator group. Another project is building correctly.

     

    Any resolution?

    Cheers,

    Michael

    Thursday, August 05, 2010 4:34 AM
  • Build error is "TF270003: Failed to copy. Ensure the source directory C:\Builds\1\Personal Framework\Secured Build\Binaries" When you face an error like above,it may be caused by you want to build two or more solution but workspace can find only one solution in directory of your build defination .You can revise your build defination’s directory from “workspace” tab,the directory must enclose all of the solutions.

    For Example :

    Build Solutions :

    Solution 1 : $/ProjectA/Batch/x.sln,

    Solution 2 : $/ProjectA/Web/y.sln

    False Workspace : $/ProjectA/Batch or  $ProjectA/Web

    True Workspace : $/ProjectA

    Serdar.

    Monday, November 29, 2010 10:08 AM
  • I'm having the same issue. I have installed TFS 2010 on Windows Server 2008 R2, and Visual Studio installed on а Virtual Machine runing on the same Windows Server 2008 R2.

    When i create "Queue New Build", Visual Studio tells me that the build was successful, but warns: "TF270003: Failed to copy. Ensure the source directory H:\Builds\Assembly\WMI_Prog\MyWmi\Binaries exists and that you have the appropriate permissions.". In this folder should be located where the build is empty .

     

    I have only one solution and for folder H:\Builds (allocated on server) everyone has full control.

     

    Thank you for your attention!

    Saturday, December 18, 2010 11:07 AM
  • I had the same issue... and finally could fix it after two days searching:

    For configuring an output folder, you must edit the .csproj file and create a new PropertyGroup-element (well known, I guess..).

    But the element must be the last PropertyGroup element (meaning no other PropertyGroup-element may follow in the *.csproj-file)!

    Tuesday, June 28, 2011 3:24 PM
  • ...one more thing, I just remember:

    Make sure, the configuration and platform(e.g. "release / x86", "debug / Any CPU") which you have defined in your build definition exists for all projects. Check out the configuration manager, if all projects are checked for build...

    In my case, a platform was missing. I added them using the configuration manager and that way, the TeamBuildOutDir-property Group element wasn't the last property Group element anymore..

    Tuesday, June 28, 2011 3:51 PM
  • I had a similar issue but the service account had all the required admin permissions and it was working fine for all the other projects.  

    The issue was when I tried to add a new configuration "Test" then that test configuration was added at some level below in the .vbproj file.  I re-arranged that config to be just below the "release" config and now everything works just fine.

    Thanks,

    Mitul

    Thursday, November 08, 2012 2:59 PM