locked
PORCV TABELA DE PREÇOS

    Question

  • PESSOAL ALGUEM PODE ME AJUDAR, TENHO UMA PLANILHA1 COM 3 COLUNAS:
    CÓDIGO FABRICANTE; CODIGO INTERNO; DESCRIÇÃO PRODUTO
    GOSTARIA DE PEGAR A INFORMAÇÃO DE UMA PLANILHA2 ANEXADA QUE CONTEM 5 COLUNAS: CODIGO FABRICANTE; PREÇO BRUTO; ICMS; IPI; EMBALAGEM
    GOSTARIA DE UTILIZAR O CODIGO FABRICANTE PARA BUSCAR O PREÇO E JOGAR NA COLUNA 4 DA PLANILHA 1

    OBRIGADO,

    Wednesday, September 30, 2009 11:23 AM

Answers

  • Olá Alencikas,
      Pelo que entendi, voce esta querendo buscar pelo código do fabricante o preço e jogar numa outra planilha.

    Tenho um questionamento: voce tem mais de um produto por fabricante? Se sim, nem sempre quando digitar o codigo do fabricante virá o preço do produto correto, pois a lógica do PROCV é retornar a primeira ocorrência encontrada na tabela de pesquisa.
    Uma das soluções possíveis seria concatenar o codigo do fabricante e o codigo do produto, na primeira coluna da tabela de pesquisa, garantindo o valor correto retornado.

    Bom, caso seja apenas um produto por fabricante apenas, abaixo vc tem a resposta:
    PLAN1
    Codigo Fabricante (coluna A) | Codigo interno(coluna B) | Descrição Produto (coluna C)| Preço (coluna D - nova coluna)

    PLAN2
    Codigo Fabricante (coluna A)| Preço Bruto(coluna B) | ICMS (coluna C)| IPI (coluna D)| Embalagem(coluna E)

    Na coluna D (Preço)  da PLAN1 coloque a seguinte fórmula:
    =PROCV(a2;PLAN2!A1:E10;2;0)

    - Onde:
    a2 = PLAN1!A2 - codigo do fabricante que quer buscar.
    PLAN2!A1:E10 = onde localizam os dados que quer buscar a informação
    2 = segunda coluna ou coluna B, de onde localizam os dados que quer buscar, coluna de retorno.
    0 = buscar a informação A2 Exata.

    Dará certo.

    Ultima observação: Não vi na PLAN2 sua a informação do produto, esta certo isto?

    Espero ter ajudado.

    []'s

     


    Dan - BH/MG - Brasil - mbarrosdaniel@hotmail.com
    • Marked as answer by ALENCIKAS Thursday, October 01, 2009 9:28 PM
    Thursday, October 01, 2009 2:43 PM

All replies

  • Olá Alencikas,
      Pelo que entendi, voce esta querendo buscar pelo código do fabricante o preço e jogar numa outra planilha.

    Tenho um questionamento: voce tem mais de um produto por fabricante? Se sim, nem sempre quando digitar o codigo do fabricante virá o preço do produto correto, pois a lógica do PROCV é retornar a primeira ocorrência encontrada na tabela de pesquisa.
    Uma das soluções possíveis seria concatenar o codigo do fabricante e o codigo do produto, na primeira coluna da tabela de pesquisa, garantindo o valor correto retornado.

    Bom, caso seja apenas um produto por fabricante apenas, abaixo vc tem a resposta:
    PLAN1
    Codigo Fabricante (coluna A) | Codigo interno(coluna B) | Descrição Produto (coluna C)| Preço (coluna D - nova coluna)

    PLAN2
    Codigo Fabricante (coluna A)| Preço Bruto(coluna B) | ICMS (coluna C)| IPI (coluna D)| Embalagem(coluna E)

    Na coluna D (Preço)  da PLAN1 coloque a seguinte fórmula:
    =PROCV(a2;PLAN2!A1:E10;2;0)

    - Onde:
    a2 = PLAN1!A2 - codigo do fabricante que quer buscar.
    PLAN2!A1:E10 = onde localizam os dados que quer buscar a informação
    2 = segunda coluna ou coluna B, de onde localizam os dados que quer buscar, coluna de retorno.
    0 = buscar a informação A2 Exata.

    Dará certo.

    Ultima observação: Não vi na PLAN2 sua a informação do produto, esta certo isto?

    Espero ter ajudado.

    []'s

     


    Dan - BH/MG - Brasil - mbarrosdaniel@hotmail.com
    • Marked as answer by ALENCIKAS Thursday, October 01, 2009 9:28 PM
    Thursday, October 01, 2009 2:43 PM
  • OBRIGADO IRMÃO.

    DEU CERTO SIM, ESTAVA FAZENDO CONFUSÃO ENTRE A PLAN1 E 2. FECHOU, UM ABRAÇO E OBRIGADO.

    Thursday, October 01, 2009 9:29 PM