none
Upgraded to Live SDK 5.4 no SSO is not working on win 8.0

    Question

  • Hello all,

    I recently upgraded my references to Live SDK 5.4 and found the auto sign-in functionality is no longer working.

    I'm still running on Windows 8 Enterprise.  Is win 8.0 single sign-on supported with this version or should I use an older SDK for now?

                    // Initialize access to the Live Connect SDK.
                    LiveAuthClient LCAuth = new LiveAuthClient();
                    LiveLoginResult LCLoginResult = await LCAuth.InitializeAsync();

    Basically the InializeAsync() throws a server error.

    The code I'm using was pulled from the Live Connect site:

    http://msdn.microsoft.com/en-us/library/windows/apps/hh968445.aspx#settings

    Thanks in advance.

    Wednesday, October 30, 2013 5:50 AM

All replies

  • I pulled down the latest version SDK 5.5 and I'm still getting the generic server error when I call .InitializeAsync()

    My app is associated with a store app and this section of cod has not changed in a while.

    I'm thinking it has something to do with the SDK because I recently put security in an unrelated WP8 phone app and installed Live SDK 5.4 as mentioned above.

    The inner exception is:

    No credentials are available in the security package (Exception from HRESULT: 0x8009030E)

    Wednesday, October 30, 2013 6:03 AM
  • Which version of Live SDK did you use before?

    If you switch back, will it work again?

    Just make sure that you can see your app on this site: https://account.live.com/developers/applications


    Lin Wang

    Wednesday, October 30, 2013 6:40 PM