none
Somar um range de células de uma planilha em excel usando C#

    Question

  •  

    Olá amigos.

     

    Estou desenvolvendo uma aplicação windowsform, onde nela eu exporto uma tabela de um dataset para excel.

    Mas eu também preciso fazer soma de campos, exemplo: =soma(A1:A10)

    Acho que isso pode ajudar a vcs entenderem o que eu preciso:

     

    excel.Cells[24, 1] = excel.get_Range("A2", "A22").Font.Bold = true;

     

    Acho que esse é o caminho, mas ao invês de Font.Bold gostaria de saber se tem algum método que some da célula A2 até a A22.

     

    Desde já estou agradecido

     

    Jabson

    Thursday, November 22, 2007 4:56 PM

Answers

  • Bem, ja faz tempo que consegui resolver esse problema, mas vim me lembrar agora de postar a resposta caso alguem precise.

    A resolução é muito simples:

     

    excel.Cells[1, "E"] = "=SOMA(E2:E" + (rowIndex).ToString() + ")";

     

    É praticamente igual a fazer uma soma no excel, mas com algumas adaptações.

    Você apenas seleciona a celula onde você que inserir o valor da soma, que no caso foi a celula "E1" e atribui a função em string igual faz no excel. rowIndex é um int que eu usei para pegar onde termina de ser preenchida a tabela e passei ele para somar até a ultima celula independente da quantidade de linhas que tenha um planilha.

    Bem é isso ai, qualquer dúvida e só perguntar se eu puder ajudar estarei aqui.

    Friday, February 08, 2008 7:19 PM

All replies

  • Bem, ja faz tempo que consegui resolver esse problema, mas vim me lembrar agora de postar a resposta caso alguem precise.

    A resolução é muito simples:

     

    excel.Cells[1, "E"] = "=SOMA(E2:E" + (rowIndex).ToString() + ")";

     

    É praticamente igual a fazer uma soma no excel, mas com algumas adaptações.

    Você apenas seleciona a celula onde você que inserir o valor da soma, que no caso foi a celula "E1" e atribui a função em string igual faz no excel. rowIndex é um int que eu usei para pegar onde termina de ser preenchida a tabela e passei ele para somar até a ultima celula independente da quantidade de linhas que tenha um planilha.

    Bem é isso ai, qualquer dúvida e só perguntar se eu puder ajudar estarei aqui.

    Friday, February 08, 2008 7:19 PM
  • Pessoal, Eu tentei utilizar o código abaixo e ele insere a fórmula correta na célula, porém ela vai como texto na célula e não mostra o resultado do cálculo exibindo #NOME?

    vb.NET:
    Excel.Cells(1, "L") = "=SOMA(E2:E" + (RowIndex).ToString() + ")"

    Alguém sabe o que pode ser?

    Abraços!


    Aislan Miranda

    Wednesday, October 10, 2012 2:46 AM