none
Sharepoint item metadata disappears

    Question

  • I have a lengthy lists of task for my marketing group. They are individual items with a mixture of the usual items: assignment, priority, due dates, % complete... As this is a repository for all the activities it's rather crowded and mixed up. 

    We've assigned tags to each item as needed and can simply filter using the metadata filter to reduce the entire list to something relevant for a subject of concern. This works fine... until you edit an item. 

    You must either select (again) the metadata tag you want associated before you save it or loose the tag value. WHY DOES THE METADATA VALUE DISAPPEAR?

    Another interesting point is that the Metadata column is always blank when either looking at all the items or if the filter is applied. It seems that the tag value is dropped when entering the edit, therefor the save records it as blank (unless you deliberately set the tag again before saving).

    Thursday, October 31, 2013 1:15 AM

All replies

  • are these tags are from MMS services? 

    which sharepoint version you are using.


    Thanks -WS SharePoint administrator, MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog *Please remember to mark your question as answered & Vote helpful,if this solves/helps your problem.*

    Thursday, October 31, 2013 2:56 AM
  • 2010 (sorry, hit submit and realized this could have been useful :) Don't know about MMS...

    I can now find a few errors indicating:

    "One or more field types are not installed properly. Go to the list settings page to delete these fields. "

    ...and...
    "List does not exist. The page you selected contains a list that does not exist. It may have been deleted by another user. (Web Part title: Modified By Me)"

    I used the Term Set Manager to create the Metadata entries, then went straight back to the list itself to start using them. Perhaps I missed a setting somewhere?


    • Edited by Kim Hartman Friday, November 01, 2013 4:15 PM
    Friday, November 01, 2013 4:13 PM
  • Could you please share the ULS in sequence, because for me both errors are for different issues.

    check this one: http://snahta.blogspot.com/2009/01/one-or-more-field-types-are-not.html

    or this one is good: http://microsoftechies.com/2013/06/12/one-or-more-field-types-are-not-installed-properly-go-to-list-settings-page-to-delete-these-fields-undefined/


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog

    Friday, November 01, 2013 7:18 PM
  • I've a work around for the immediate sorting / filtering of tasks, but it doesn't scale across the site as metadata could. The links were very informative. I need to study better how to enjoy success and roll this out for mor comprehensive usage. I may be back!
    Saturday, November 02, 2013 6:30 AM