locked
Error TF260078 - could not connect to SC VMM - SQL Server issue?

    Question

  • I'm trying to setup the lab management integration in the RC with SC VMM.  I already have the TFS Service account in the adminstrator role for VMM.  When I go to test the SCVMM server in the TFS Admin UI, after entering credentials (either domain admin or the tfs service), I get the following error:

    tf260078: Team Foundation Server could not connect to the SC VMM Server: zeus.housenet.novotny.org.  More information for administrator: The SQL Server service account does not have permission to access Active Directory Domain Services (AD DS). (Error ID: 2607)

    From the same computer, I can connect to zeus using the SCVMM Admin console and that works fine....  The SQL Server service account is a domain account and is a member of domain users, so it can definitely read the AD.  The SQL Server is on a different machine (happens to be the same one the SC VMM database is on too). The rest of TFS Seems to work fine with web access, work items, source control and reporting (no sharepoint).

    Help? :)
    Saturday, February 13, 2010 2:55 PM

Answers

  • Found the solution -- seems like within SQL Server, even Execute as User failed -- the issue was that the domain account that SQL Server ran in was not in the "Pre-Windows 2000 Compatible" auth group in the domain.  Adding the sql service account to that group and restarting the sql service solved it. 
    • Marked as answer by Oren Novotny Sunday, February 13, 2011 10:59 PM
    Sunday, February 13, 2011 10:59 PM

All replies

  • Hello Oren

    Can you try this workaround, and check if it resolves your issue?

    let me know if it dosent, and i can investigate further.

    Thanks for trying Lab Management
    -Vijay
    Saturday, February 13, 2010 3:32 PM
  • There's nothing for me to change -- in the VirtualManagerDB, both dbo and VMMServer are already db_owner.  the VMM R2 tools and MMC work correctly. It's the TFS Admin UI that's not working/connecting to the VMM stuff....

    Friday, February 19, 2010 10:17 PM
  • )Hello Oren

    Please open the SCVMM Admin Console as TFS Service account (This is the "service account" you see in Application Tier Summary)

    Run the command in the command prompt with administrative privileges
    If TFS Service account is "NT AUTHORITY\NETWORK SERVICE"
              psexec -u "NT Authority\Network Service" -i "%PROGRAMFILES%\Microsoft System Center Virtual Machine Manager 2008 R2\bin\VMMAdmin.exe" (psexec can be downloaded from here )  
    Else if service account is any domain account
              runas /user:<DOMAIN SERVICE ACCOUNT> "%PROGRAMFILES%\Microsoft System Center Virtual Machine Manager 2008 R2\bin\VMMAdmin.exe"  (Provide password on prompt)

    Do let us know whether the operation succeeded or not ?

    If the above operation succeeds, please provide us the following details :
    1. Any event viewer traces seen ?
    2. What is the SQL Server version ?
    3. What is the Service account with which SCVMM is running ?
    4. Are you sure the domain credentials provided on TFS Admin UI while Testing the SCVMM Server, added to machine "administrators" group on the SCVMM ?
    5. Did you try after reopening the Admin UI ?

    We're on top of your issue and working closely with the team. Will get back to you shortly.


    Thanks & Regards, Satish K Cheekala
    Thursday, February 25, 2010 2:57 PM
  • Hello,

    I have the same problem as Oren. 

    Connecting from the SCVMM Console works but in the TFS Admininstration Console, the lab management configuration prompts for credentials and this is where I'm stuck.

    In my evalutaion environment there's the TFS 2010 RTM in the corporate domain (let's call it CorpDom) and the SCVMM Server 2008 R2 in a not-trusted test domain (TestDom). The TFSService is running under an user account (CorpDom\TFSService). The same account with the same password also exists in the test domain which is member of the SCVMMs' Administrators role (TestDom\TFSService). The Firewall is disabled on both sides and anonymous DCOM access is also granted (I used John Howard's Hyper-V Remote Management util http://code.msdn.microsoft.com/HVRemote). On the TFS machine I'm logged on with the TFS service account CorpDom\TFSService which is member of the local administrators group and the test domain credentials (TestDom\TFSService) for the SCVMM Server are stored in the Credential Manager (Control Panel > User Accounts > Manage your credentials) - net use \\scvmmserver\ipc$ /user:TestDom password in an non-elevated command line didn't work for me. I added the server names in both servers' etc\hosts to be sure that name resolution works on both sides and that it's not a DNS related issue. The SCVMM service runs under Local System account and SQL Server Expr (set up with SCVMM) is on the same machine.

    So connecting from the TFS' SCVMM Admin Console to the SCVMM Server in the not-trusted domain works perfect but when I'm trying to configure the SCVMM server in the Lab Management settings of the TFS Admin console it prompts me for credentials that cannot be validated if I use TestDom\TFSService (Invalid User Account or Password was entered) or I get the Error TF260078 if I try CorpDom\TFSService.

    Thanks and Regards

    Frank

    Wednesday, October 06, 2010 3:49 PM
  • When I use RunAs to use open the SCVMM admin console, I get the same error.  Seems like the TFSService can't connect to the VMM server...
    Saturday, February 12, 2011 10:18 PM
  • Found the solution -- seems like within SQL Server, even Execute as User failed -- the issue was that the domain account that SQL Server ran in was not in the "Pre-Windows 2000 Compatible" auth group in the domain.  Adding the sql service account to that group and restarting the sql service solved it. 
    • Marked as answer by Oren Novotny Sunday, February 13, 2011 10:59 PM
    Sunday, February 13, 2011 10:59 PM
  • This is strange.  I had the error indicating that my SCVMM service account couldn't read from AD so the VMM consolde would not open. 

    First, I tried adding the account, vmmsvc, to the Windows Authorization Access Group and restarting the Virtual Machine Manager service; that didn't work. 

    Second, I tried adding the account, vmmsvc, to the Pre-Windows 2000 Compatibility group and restarting the VMM service; that didn't work either.

    Next, I saw in your post that I should restart the SQL service; that worked!

    I though, hmmm, I wonder which group fixed it.

    I removed the vmmsvc from the Windows Auhorization Acces Group and restarted the SQL service; it still worked.

    I removed the vmmsvc from the Pre-Windows 2000 Compatibility group and restarted SQL; it still worked.

    I restarted the VMM service and it still worked.

    Was the solution just to restart SQL?


    Mitchel Hudson, Hudson Computer Services, LLC

    Thursday, March 01, 2012 9:54 PM