none
Error when saving capacity

    Question

  • Hello,

    We are getting the following error when trying to save capacity for one team. We are able to set capacity just fine for other teams. What can be the issue?

    There is nothing in the event log - how can we troubleshoot/identify the real problem?

    Your changes could not be saved because the server did not respond. Wait a few moments, and then re-try saving your changes.

    Thank you,

    Alin

    Tuesday, August 27, 2013 7:43 PM

Answers

  • Found the underlying issue:

    One of the iteration was named 1.5 + 2.0. Some of the TFS URL requests do include Iteration Name: e.g. http://tfsserver:8080/tfs/Collection 1/Project 1/Team 1/_backlogs/Iteration/1.5 + 2.0/Sprint 0 

    The IIS 8.0 identifies the + sign as a threat. I changed the iteration name from "1.5 + 2.0"  to "1.5 and 2.0" and it started working.

    Here is the underlying error message ( this is not raised by TFS when trying to save capacity, but it should)

    The request filtering module is configured to deny a request that contains a double escape sequence.Most likely causes:
    The request contained a double escape sequence and request filtering is configured on the Web server to deny double escape 

    Looks like a TFS bug... It should probably escape the + sign

    Thursday, August 29, 2013 1:18 PM
  • Found it... same issue as solved above, except the "+" was in the name of the Release, not sprint iteration.  But still the URL includes that as well.  Yikes!

    Eric JohnsonAtProModel

    Thursday, February 27, 2014 1:50 PM

All replies

  • Hi Alin, 

    Thanks for your post.

    Open TFS Web Access on your TFS Server(AT), then try to configure Capacity for that team and save it, check the result.

    If you have any further research of this issue, please share your experience here.


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Wednesday, August 28, 2013 1:49 AM
    Moderator
  • The experience is the same on the AT server. The error message comes back right away, which tell me some other thing is going on.
    Wednesday, August 28, 2013 3:42 AM
  • Hi Alin, 

    Thanks for your reply.

    You received the same error message on AT machine? No other more information?

    Try to clean the Cache for TFS 2012 manually(delete the content of the folder only, not the cache folder itself):

    1. Clean the Cache folder on Server machine. The folder path is: C:\ProgramData\Microsoft\Team Foundation\Web Access\Cache_v11.0. (os: Windows Server 2008 R2)
    2. After cleaned, on Server machine, click Start and select Run… to open the dialog box, then input iisreset.exe and click OK, wait it run completely.

    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, August 28, 2013 6:00 AM
    Moderator
  • That folder is empty (we are on Server 2012) I did however clear the C:\Program Files\Microsoft Team Foundation Server 11.0\Application Tier\Web Services\_tfs_data folder, but that did not make any difference.
    Wednesday, August 28, 2013 1:40 PM
  • Hi Alin, 

    Thanks for your post.

    What’s the detailed version of your TFS? TFS 2012 Update 2 or TFS 2012 Update 3?

    How did you set capacity for that team? Please share your detailed steps here.


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, August 29, 2013 2:57 AM
    Moderator
  • We are on Update 2.

    Repro:

    Go to the Capacity tab - all members are displayed with 0 hours (the default view). Any change we make (e.g.  enter 1 for the first member) and save gives back the error right away.

    Note that this is only for one of the teams - for the rest of them, we have no issues setting capacity.

    Thursday, August 29, 2013 3:23 AM
  • Hi Alin, 

    Thanks for your reply.

    It seem that’s a strange issue, and there’s no default way to find other helpful information/log.

    Have tried another Admin user to set the capacity for members in this one team?  

    Except this issue, other things all working fine for that one team?

    If create a new team, and try to set the capacity for the members in this new team, what’s the result?


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, August 29, 2013 11:19 AM
    Moderator
  • Found the underlying issue:

    One of the iteration was named 1.5 + 2.0. Some of the TFS URL requests do include Iteration Name: e.g. http://tfsserver:8080/tfs/Collection 1/Project 1/Team 1/_backlogs/Iteration/1.5 + 2.0/Sprint 0 

    The IIS 8.0 identifies the + sign as a threat. I changed the iteration name from "1.5 + 2.0"  to "1.5 and 2.0" and it started working.

    Here is the underlying error message ( this is not raised by TFS when trying to save capacity, but it should)

    The request filtering module is configured to deny a request that contains a double escape sequence.Most likely causes:
    The request contained a double escape sequence and request filtering is configured on the Web server to deny double escape 

    Looks like a TFS bug... It should probably escape the + sign

    Thursday, August 29, 2013 1:18 PM
  • Hi Alin, 

    Thanks for your solution.

    For this scenario, please submit it to Microsoft Connect Feedback portal at: https://connect.microsoft.com/VisualStudio. Microsoft engineers will evaluate them seriously.


    John Qiao [MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, August 30, 2013 1:34 AM
    Moderator
  • We are experiencing the same problem here.  Some background:

    * 5 projects created more-or-less the same time

    * 1 project received the "source code migration" output of the TFS Migration Tool (tfs 2012 -> tsf 2012).  That project is the problem.  The other 4 are perfectly fine.

    * I looked around at a few tables in the SQL Server database... noticed that

    tbl_TeamConfigurationCapacity

    receives rows only after you successfully post capacity for a team member.

    It's like the team itself is not valid, or otherwise is unknown somehow.  I tried deleting all members of the team, then reassigning them (they Windows users)-- no improvement.  I then removed all team members, create another team, assigned members, made that the default team, then deleted the 'old default'.  Also no improvement.  Help!


    Eric JohnsonAtProModel

    Wednesday, February 26, 2014 7:43 PM
  • Found it... same issue as solved above, except the "+" was in the name of the Release, not sprint iteration.  But still the URL includes that as well.  Yikes!

    Eric JohnsonAtProModel

    Thursday, February 27, 2014 1:50 PM