none
Login failed for user 'WebsitePanel'

    Question

  • Hi,

    I've just reinstall websiteadmin, but I've this error when I launch websitepanel.

    I've this error:

     Login failed for user 'WebsitePanel'

    Why?

    Thansk for your help.


    -- Eric
    Wednesday, April 20, 2011 11:38 AM

All replies

  • Where are you getting this error? I assume it's an SQL server problem?  Try to update the password on the SQL server  to match the one in the web.config file of your portal.
    http://www.winblogs.net windows geek blog support, patches, fixes
    Wednesday, April 20, 2011 9:43 PM
  • Hi,

    We have tried reinstalling this on a brand new server, and it came up with the same message. i have checked the web.config file, and cannot find anywhere anything to do with a username and password. any help would be appreciated.

    thanks,

    Tim.


    EDIT: have found in the logs that the SQL user 'WebsitePanel' cannot log in due to an incorrect password. When was this password set? is it auto generated by the installer? as stated above, i cannot see this detail in the web.config file.
    Tuesday, May 17, 2011 2:19 AM
  • Check the web.config file located in the "Enterprise server" folder of your WebSitePanel installation. You should see something similar to this:

     

    <add name="EnterpriseServer" connectionString="server=(local);database=WebSitePanel;uid=WebSitePanel;pwd=YOURPASSWORD;" providerName="System.Data.SqlClient" />


    http://www.winblogs.net windows geek blog support, patches, fixes
    • Proposed as answer by Polderdijk Friday, April 13, 2012 7:03 PM
    Tuesday, May 17, 2011 6:39 AM
  • hi,

    we solved this by uninstalling, deleting the user account, then reinstalling. thankyou for you response though.

    thanks,

    Tim

    Tuesday, May 17, 2011 7:56 AM
  • I know this is a little old, but I just ran into this error installing WebSitePanel on a clean server. If you are rushing through an install of MS SQL Express and select Windows Authentication, WebSitePanel throws the error "Login failed for user 'WebsitePanel'" because it isn't using Windows Authentication. Search on how to change MS SQL Express from Windows Authentication to Mixed Mode, change it to Mixed Mode, and it will go right to work (or least it did for me).

    Yeah, if you read the docs, this is probably on the first page...but who reads the docs?

     


    • Proposed as answer by Jason of Oz Friday, December 30, 2011 11:06 PM
    Friday, July 29, 2011 8:51 PM
  • The reason why this occurs for some people is because of either from a re-install or uninstall of WSP.

    When you uninstall or re-install WSP enterprise component (without using the settings button to redo the settings), there is an issue with the crpto key that generates the password.

    For some reason when you uninstall the WSP enterprise, it is only able to uninstall the websitepanel database from SQL, but it does not delete the auto-generated websitepanel SQL login account which already holds the crpto key password.

    Therefore when you goto reinstall the WSP Enterprise, even through the installation seems to be smooth and even if you use the same password for websitepanel (which is the dialog box after the SQL stuff), it cannot update the SQL login password and even when you use the same password, the crpto key is always different for some reason. 

    So again, you must manually goto into your SQL Studio Management tool and login into your sql database, and expand the logins and you should still see websitepanel user still there after you uninstall the WSP enterprise.  Just right click the websitepanel user in SQL and delete it.  Also make sure your websitepanl database is deleted as well, and don't forget to refresh just to confirm.

    Then go back and re-install the WSP enterprise component, and for proper connection us your sql mixed mode login (sa) to connect to the database, do not use windows authentication (unless your entire environment is on ADS - then windows authentication is fine) - otherwise use mixed mode.

    and complete the rest of the information as you did before.  Be sure to click the link after the installation is done so that:

    a) you know the service is running

    b) the SQL connection is working so that you can connect to the next component

    it makes troubleshooting easier -- process of eliminination


    MattLok

    Friday, July 06, 2012 6:38 AM