none
Localhost setting error

    Question

  • Hi Any one can tell me where is setting for localhost.

    I am facing problem with localhost/uddi...
    "here was no endpoint listening at http://localhost/uddi/inquire.asmx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. "

    My IIS is set on Hostheader value.. I have assign proper domain .. and its working fine all my service are working fine by using my http://biztalk2009.com/uddi     like that every thing works fine.

    When I started creating Itinerary inside itinerary resolver I have use Resolver Implementation UDDI3   and from Resolver moniker I have opted UDDI3 then in server url it shows "http:\\localhost\UDDI".. and when I run my Resolver test then I am getting error end point is not listing... 
    I have search localhost every where in side biztalk ESB tool kit folder and replace with my domain biztalk2009.. I dont know from where and which configuration file its picking this :( I ahve change in ESB.config file also which is place in biztalk esb tool kit folder.

    any one can give me pointer ...



    Rit
    Friday, July 17, 2009 2:04 PM

Answers

  • As far as I know, if you're not using SSO, the only place it would be grabbing configuration data at runtime would be from this section of the esb.config file:

          <resolver name="UDDI3" type="Microsoft.Practices.ESB.Resolver.UDDI3.ResolveProvider, Microsoft.Practices.ESB.Resolver.UDDI3, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
            <resolverConfig>
              <add name="cacheTimeoutValue" value="120" />
              <add name="cacheName" value="UDDI Cache Manager" />
              <add name="publisherKey" value="esb" />
              <add name="baseUri" value="http://localhost/uddi" />
              <add name="publishUriSuffix" value="/publish.asmx" />
              <add name="inquireUriSuffix" value="/inquire.asmx" />
            </resolverConfig>
          </resolver>
    Could it be that the resolver service endpoint is the endpoint not listening after updating the configuration? If you click the design surface of the itinerary, there's a property named Resolver Service Url that allows you to specify where the Test Resolver Configuration option will go to test the resolver. Verify that setting first.
    BizTalk ESB Toolkit 2.0 Training: http://www.quicklearn.com/class.aspx?name=BizTalk_Expert_Series:_ESB
    Friday, July 17, 2009 6:14 PM

All replies

  • As far as I know, if you're not using SSO, the only place it would be grabbing configuration data at runtime would be from this section of the esb.config file:

          <resolver name="UDDI3" type="Microsoft.Practices.ESB.Resolver.UDDI3.ResolveProvider, Microsoft.Practices.ESB.Resolver.UDDI3, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
            <resolverConfig>
              <add name="cacheTimeoutValue" value="120" />
              <add name="cacheName" value="UDDI Cache Manager" />
              <add name="publisherKey" value="esb" />
              <add name="baseUri" value="http://localhost/uddi" />
              <add name="publishUriSuffix" value="/publish.asmx" />
              <add name="inquireUriSuffix" value="/inquire.asmx" />
            </resolverConfig>
          </resolver>
    Could it be that the resolver service endpoint is the endpoint not listening after updating the configuration? If you click the design surface of the itinerary, there's a property named Resolver Service Url that allows you to specify where the Test Resolver Configuration option will go to test the resolver. Verify that setting first.
    BizTalk ESB Toolkit 2.0 Training: http://www.quicklearn.com/class.aspx?name=BizTalk_Expert_Series:_ESB
    Friday, July 17, 2009 6:14 PM
  • Did you ever get this sorted out?
    BizTalk ESB Toolkit 2.0 Training: http://www.quicklearn.com/class.aspx?name=BizTalk_Expert_Series:_ESB
    Friday, July 24, 2009 9:55 PM