none
MVC 4 application is very slow, 30s before sending a webresponse when running in VS 2013 and Visual Studio 2012 update 4 RC

    Question

  • When debugging my MVC 4 application in Visual Studio 2012 update 4 RC most of the time it responds very slow. It takes 30-60 seconds before a response is sent, if any is sent at all. So I basically loose so much time waiting and refreshing a page, that it is not fun running the program in Visual Studio debugger.

    Clearing all the breakpoint and disabling 'Enable property evaluation and other implicit function calls' gave some temporary relieve, but the issues returned.

    The compiling is quick, so symbol loading is not the problem I've seen on other forums.

    When I deploy the app to Windows Azure, everything is fast. I'm using a HP Z820 workstation with 16GB memory and Intel SSD disk.

    EDIT:

    Reïnstalling the complete system gave some relieve, but issue keeps returning. I noticed in the Process Monitor that during the request there al dozens of event like this one:

    Class: File System

    Operation: CreateFile

    Result: NAME INVALID

    Path: C:\TFS\Imp\Main\packages\jQuery.UI.Combined.1.10.3\tools\"C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\msenvico.dll"

    Evidently this path cannot be correct, since there seem to be two path combined.

    (BTW c:\tfs is the root of all my projects, which are controller by Team Foundation Server.)

    Tuesday, October 29, 2013 7:51 AM

Answers

All replies

  • Hi Richard D,

    About the performance issue, actually it is hard to make sure that whether it is related to your VS Environment or others.

    But like Roahn’s suggestion in this thread: http://social.msdn.microsoft.com/Forums/en-US/5567a1db-8991-4b19-b2c1-d80e9d62bbd6/starting-vs2010-debugger-on-mvc-application-very-slow?forum=vsdebug, if possible, you could disable all add-ins, and run your VS in safe mode, check it again. To make sure that the third party tools impacts the performance in your windows, please also close them, like the firewall, the anti-virus software or other processes in your task manager. Check it again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, October 30, 2013 7:09 AM
  • Thanks for you reply Jack.

    The Azure project is not compatible with safemode, so that is not an option. The MVC app just won't run in safe mode.

    I've deleted all extentions and updates (Tools -> Extensions and Updates) except the Microsoft ones (MS Web developer tools, nuget package manager, tfs process template editor, tfs work item type designer and visual studio extensions fo Windows Library for Javascript).

    I've disabled Windows Firewall and Defender and closed all other applications.

    Unfortunately the issue stays.

    Wednesday, October 30, 2013 12:00 PM
  • Hi Richard D,

    If possible, please turn off the intellitrace under TOOLS->Options->IntelliTrace.

    http://connect.microsoft.com/VisualStudio/feedback/details/535799/debugging-mvc-is-very-very-slow

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, October 31, 2013 7:30 AM
  • I'm using Visual Studio Premium, that does not have Intellitrace included in the product.
    • Edited by Richard D Thursday, October 31, 2013 2:10 PM
    Thursday, October 31, 2013 2:07 PM
  • Hi Richard D,

    Sorry for no help to you.

    One idea I could get is that you could clear out the temporary files of your VS. Check it again.

    Reference:

    http://blogs.msdn.com/b/dougste/archive/2008/08/11/clearing-out-temporary-asp-net-files.aspx

    http://weblogs.asp.net/psheriff/archive/2011/11/08/clean-up-after-visual-studio.aspx

    Have a nice weekend,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, November 01, 2013 2:29 AM
  • Jack, I really do appreciate your effort. I've cleared all the ASP.NET temp directories (including %TEMP%) but the slowness persists
    Friday, November 01, 2013 9:42 AM
  • Hi Richard D,

    I did some research about this issue, I get some threads about the same issue, if possible, you could refer them, hope it could help.

    Disable JIT:

    http://forums.asp.net/p/1879106/5287075.aspx?file+new+mvc+4+project+loads+very+very+slow

    Some suggestions to improve MVC app performance:

    http://stackoverflow.com/questions/2246251/how-to-improve-asp-net-mvc-application-performance

    If still no help, I’m afraid that I have no idea, you can submit this feedback to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx, Microsoft engineers will evaluate them seriously. Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, November 04, 2013 2:20 AM
  • Thanks Jack for these options. Currently I'm travelling and as soon as I'm back (approx. 10-15 days) I'll try your suggestions.
    Monday, November 04, 2013 6:57 PM
  • Hi Richard D,

    Thanks for your response.

    Currently I'm travelling and as soon as I'm back (approx. 10-15 days) I'll try your suggestions.

    If so, we are changing the issue type to General Discussion since you are travelling. 

    If you come back and have more time to look at the issue and provide more information, please feel free to change the issue type back to Question by opening the Options list at the top of the post editor window, and changing the type. 

    If the issue is resolved, we will appreciate it if you mark the useful reply as the answer or you can share your solution so that the answer can be found and used by other community members having similar questions.

    Have a nice travelling,J


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, November 05, 2013 2:41 AM
  • I'm back again. Thank you for you reply. I've tried the suggestions, but issue remains.

    I've installed a new PC, with VS 2012 and my MVC app and that runs fine (so the code shouldn't be the issue).

    Uninstalled VS2012 and all related stuff (SQL server, IIS etc.) reinstalled again: issue remains :-(

    I've copied the Visual Studio settings from the working PC to my Z820 workstation -> issue remains.

    Upgraded to VS 2013 Ultimate. Seems OK at first sight, after few hours issue came back again.

    After many days of searching for a solution and hours and hours of waiting for a response to come back from my MVC app, I've lost faith. I can hardly call Visual Studio a productivity tool any more in my case. And I see that there are others experiencing the same issues.

    I'll file an issue at Microsoft Connect.

    Thanks for your effort Jack, I really appreciate it.



    • Edited by Richard D Wednesday, November 13, 2013 1:03 PM
    Wednesday, November 13, 2013 9:29 AM
  • Hi Richard D,

    You're welcome, but really sorry for that I didn’t provide the solution for this issue.

    I'll file an issue at Microsoft Connect.

    If you submit the connect report, you could share me the link here, so we could know the latest information about this issue from the product team expert.

    Sincerely,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, November 14, 2013 3:16 AM
  • I decided to re-install my complete workstation. Not a nice solution, but it works so far.

    I hope the issue does not come back . . . . . . .

    Saturday, November 16, 2013 4:39 PM
  • Hi Richard D,

    Since it worked well after you re-installed your machine, I will close this thread, but if it has this issue again, please feel free to let me knowJ

    Have a nice day,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, November 18, 2013 2:00 AM
  • Hi Richard D,

    As you already submit one feedback on the Microsoft Connect site, let's focus on the case on that channel, I think the senior members can provide more professional support.

    Have a nice day,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, November 19, 2013 1:49 AM
  • Richard,

    I've experienced the same thing and found a solution after "living with it" for a few months:

    One of the overlooked and never reported issues on increasing debug speed for visual studio 2013 ASP .NET apps (MVC and webforms) is to disable browser link.  This is a new feature in VS 2013 which causes a huge amount of overhead and causes pages to load extremely slowly (5-10 seconds in most of my cases).  Disabling it brings it back to Visual Studio 2012 speeds.

    See here for how to disable it:

    http://blogs.msdn.com/b/webdev/archive/2013/06/28/browser-link-feature-in-visual-studio-preview-2013.aspx

    Thursday, January 02, 2014 9:09 PM