locked
IntelliSense Font/Text Blank or Missing

    Question

  • Recently I have noticed that my IntelliSense has stopped working correctly. The suggestions displayed No longer have any visible text, only just an icon (showing what type of suggestion). The only Text that does infact appear are numbers and special Characters ( 1,2,#, (, )... etc.)

    I have already tried editing the font color, back/forground color and size for the intellisense. Although nothing seems to work. I have also tried completely uninstalling VB.Net 2010 and reinstalling also repairing and still the problem remains.

    If anyone has had this problem in the past or has the slightest clue what is going on I would highly appreciate your help.

    Windows XP Pro. Version 2002. Service Pack 3

    Visual Basic . NET 2010

    Thursday, July 14, 2011 12:44 PM

All replies

  • Hi PataRican,

    Can you show a picture here to help me to know this issue?

    According to your description, it seems that the VS just show you a icon without the class name or method name and so on.

    Here is a article about "how to uninstall VS2010 completely", please try it again: http://blogs.msdn.com/b/heaths/archive/2010/08/23/visual-studio-2010-uninstall-utility.aspx

    About how to insert picture:

    How to insert a PICTURE into a forum post.. Inserting code into a forum post

    Best regards,


    Mike Feng [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Mike FengModerator Wednesday, July 27, 2011 9:15 AM
    • Unmarked as answer by PataRican Thursday, July 28, 2011 2:27 PM
    Monday, July 18, 2011 3:58 AM
  • Photobucket

    I will try to completely uninstall once more. Although are there any other ideas you have that could cause this?

     

    Thursday, July 28, 2011 2:25 PM
  • Could you let us know if you observe this behavior in other projects, for example in C#, C++ projects in Visual Studio 2010 or is it specifically occurring in VB.NET project. You can try creating a VB.NET sample application and observe if you still face the same issue of intellisense.

    Also, could you also let us know if your application in Visual Studio 2010 is referring any third party add-ins?

     

    You could try closing the Visual Studio, renaming the .inc file from the solution directory and reopening Visual Studio again and observe if you face the same issue.


    --Trevor H.
    Send files to Hotmail.com: "MS_TREVORH"
    Friday, July 29, 2011 8:36 PM
  • Hi PataRican,

    1. Have you changed system settings recently? Like change language or add / remove fonts or anything maybe to optimize the system?

    2. Have a try to reset the IDE settings: Tools | Import and Export Settings | Reset all settings.

    3. Try run devenv / setup in Visual Studio Command Prompt to see if it works.

    Hope this helps.

     

    Tuesday, August 16, 2011 10:18 PM