none
Windows 7 keeps asking for permission

    Question

  • I've installed an application (VFP 9.0 - Setup created by Installsheild Express 5.0 for Visual FoxPro) on a client's machine that is running Windows 7 Home Edition with SP1.  The user is set up as the administrator.  I've been able to install the application with no problem, but what happens is that every time the program is launched from the shortcut on the desktop Windows asks if the program should be allowed to continue.  I click yes and it works as it should.  However, the next time I run the program it asks the same question.

    I've tried running the program as adminstrator, and even at that it still does the same thing. I've looked at the user's permissions and I can't see anything out of the ordinary.  The only thing I have noticed is that in the field asking for permission, it does say publisher unknown.

    I've installed the program on another machine running Windows 7 Home and one running Windows 7 Pro and I'm not encountering the same problem.

    Does anyone have any suggestions on how to fix this?

    Thank you


    Wednesday, August 03, 2011 8:20 PM

Answers

  • The program shortcut has probably checked "Run As Administrator" check box and it causes the dialog because UAC is switched on. If you uncheck "Run As Administrator" then everything should work without permission request.

     

    Thursday, August 04, 2011 12:06 AM
    Moderator

All replies

  • How's the name of the program? Windows knows several keywords, for which it does ask for elevated rights always, eg setup, update, install, even if that is only part of the exe name.

    Bye, Olaf.

    Wednesday, August 03, 2011 8:30 PM
  • Program name is 'grants.exe'
    Wednesday, August 03, 2011 8:59 PM
  • The program shortcut has probably checked "Run As Administrator" check box and it causes the dialog because UAC is switched on. If you uncheck "Run As Administrator" then everything should work without permission request.

     

    Thursday, August 04, 2011 12:06 AM
    Moderator
  • Thanks I'll have the customer try that tomorrow.
    Thursday, August 04, 2011 12:45 AM