none
Tracking No Longer Shows Messages

    Question

  • A couple days ago my messages no longer show up in Group Hub queries.  I have looked at the SQL jobs and they all look fine.  I have also rebooted the entire server.

    What else could I look at or run?

    -c

    Thursday, September 26, 2013 5:39 PM

Answers

  • Inside of the BizTalk.System/Pipelines application, the tracking was unchecked. Doh.
    • Marked as answer by fixitchris Monday, September 30, 2013 3:09 PM
    Monday, September 30, 2013 3:09 PM

All replies

  • Here are some some possible causes:

    1. The SQL Agent jobs are not functioning properly.  Be sure to review the History of each job, and verify there are no errors.

    2. A Host with the Tracking option set is not running.

    3. Global Tracking has been disabled.

    Are you seeing any Event Log entries?

    Thursday, September 26, 2013 6:11 PM
  • It looks like it is only one application that is no longer tracking.  But all the checkboxes are ON.
    Thursday, September 26, 2013 7:32 PM
  • Can you select Properties | Tracking on the Pipelines used and verify that both

    - Track Events | Port start and end events

    - Track Events | Message send and received events

    Are selected. 

    I have recently experienced that these have been de-selected on BizTalk Server 2010 without my customers having tampered with them.

    Morten la Cour 

    • Proposed as answer by Maheshkumar S Tiwari Friday, September 27, 2013 12:47 PM
    • Unproposed as answer by fixitchris Monday, September 30, 2013 3:08 PM
    Thursday, September 26, 2013 8:50 PM
  • Inside of the BizTalk.System/Pipelines application, the tracking was unchecked. Doh.
    • Marked as answer by fixitchris Monday, September 30, 2013 3:09 PM
    Monday, September 30, 2013 3:09 PM
  • Note that the BizTalk.System application has different tracking selections than the user deployed application.
    Monday, September 30, 2013 3:47 PM