none
auto adjust Page Viewer web part height

    Question

  • I am trying to display web page from different farm in page viewer webpart but I am getting height issue for page viewer webpart. Some content is hiding and I can see vertical scroll bar. I can seen hidden content when I scroll vertical scroll bar.

    Can anybody help me out to remove vertical scroll bar for page viewer webpart and show complete content?

    Any help would be appreciated.

    Thank you,


    AA.


    • Edited by AA2013 Monday, July 22, 2013 4:46 PM
    Monday, July 22, 2013 4:41 PM

Answers

  • I have fixed the issue. I got vertical scroll bar for "?IsDlg=1" but I didn't get any vertical scroll bar for "?IsDlg=0".

    It's strange but true.

    Thank you.


    AA.

    • Marked as answer by AA2013 Wednesday, July 24, 2013 6:48 PM
    Wednesday, July 24, 2013 6:48 PM

All replies

  • Hi AA,

    I have dealt with this several times especially on Home pages. You will have to adjust the Appearance manually until you get it just right.

    To remove the vertical scroll bar, you will have to adjust the Height in the Appearance and give it a Pixel size that removes the scroll.


    Daniel Christian (MCTS)

    • Marked as answer by AA2013 Wednesday, July 24, 2013 6:49 PM
    • Unmarked as answer by AA2013 Wednesday, July 24, 2013 6:50 PM
    Monday, July 22, 2013 7:23 PM
  • Thank you Daniel for your comments but i didn't get you exactly, do you mean edit page using sharepoint designer?

    Can you explain me in detail about the following line?

    "You will have to adjust the Appearance manually until you get it just right."

    Regards,


    AA.

    Monday, July 22, 2013 8:36 PM
  • You do not have to use SharePoint Designer to make this change.
    You will need Designer or Full Control access to that page to make the below changes.


    Below are the steps on the site/page where you have the web part.
    - Edit the WebPart. Now you should see the options to edit the page on the right.

    - Expand the Appearance. Choose the Yes radio button under Height and add pixel size. You might have to change the pixel size couple of times until you find the right number to remove the scroll bar.

    Does this help?


    Daniel Christian (MCTS)

    Monday, July 22, 2013 8:49 PM
  • Thank you for immediate reply!!

    I tried to increase height and width as you said but it didn't work for me.


    AA.

    Monday, July 22, 2013 8:54 PM
  • You are welcome.

    I just tested the Page Viewer webpart on my DEV environment and it worked. I was able to embed a page from a different site without the vertical scroll showing. Since I couldn't judge the exact height of the page, I added a ridiculous pixel size of 6000 for height. 

    Try that to confirm that the vertical scroll doesn't show up then you can tweak the pixel size.


    Daniel Christian (MCTS)

    Monday, July 22, 2013 9:07 PM
  • Nope, it's not working for me.

    Here I am attaching screen captures.

    Content in a web part page in another server:

    Content in page viewer webpart:


    AA.

    Tuesday, July 23, 2013 3:38 AM
  • I have used IsDlg=1 in url to unskin page view webpart.

    Without "?IsDlg=1" it's working fine, but it's not working if I use "?IsDlg=1 in url". I am trying to make it work with "?IsDlg=1 in url".

    Please advise me.



    AA.

    Tuesday, July 23, 2013 2:01 PM
  • I have fixed the issue. I got vertical scroll bar for "?IsDlg=1" but I didn't get any vertical scroll bar for "?IsDlg=0".

    It's strange but true.

    Thank you.


    AA.

    • Marked as answer by AA2013 Wednesday, July 24, 2013 6:48 PM
    Wednesday, July 24, 2013 6:48 PM