locked
No intellisence or color highlighting of xaml

    Question

  • HI, i have recently installed vwd 2008 express with sp1 and silverlight 3, but  i dont have any intellisence or color highlighting in any xaml documents. i have checked in the tools/options dialog box under text editor/xaml/formating and i get "an error occured loading this property page" i am also getting the same error message in the "choose toolbox items" dialogbox for the silverlight and wpf components. when i right click on the toolbox itself and choose show all items i can see the xaml components there but they seem to be disabled. I am not sure wether the xaml document should show a split screen with the layout at the top and the code below but that is also not there. i hope this is the right place to ask this question as i have searched google with no success and am hoping some one here will enlighten me with my problem... thanks in advance
    Wednesday, March 24, 2010 3:23 PM

Answers

  • Hi Willthisdoat42,

    Thank you for your post.

    Based on your description, it seems that the intellisence and highlighting were blocked due to some possible cause.

    Could you please help me to try some common workarounds mentioned below to eliminate these possible causes?

      1. Try running devenv /Resetsettings in Command Prompt to eliminate the cause of corrupted settings.
      2. Try running devenv /ResetSkipPkgs in Command Prompt.
      3. Try running devenv /Safemode in Command Prompt to see if you can apply it correctly.
      4. Try running devenv /Resetuserdata in Command Prompt to reset all of your VS environment and customization settings.

    If these suggestions don't work, I would suspect that your issue could be related corrupted Silverlight 3 Tools installation.
    You might try to repair or re-install Silverlight 3 Tools for Visual Studio 2008 SP1.

    If you want to re-install Silverlight 3 Tools for Visual Studio 2008 SP1, please remove the previous Silverlight 3 Tool installation >> repair VWD2008 SP1 >> install Silverlight 3 Tool again.
    You can download it from http://www.microsoft.com/downloads/details.aspx?familyid=9442b0f2-7465-417a-88f3-5e7b5409e9dd&displaylang=en.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, March 25, 2010 3:18 AM

All replies

  • Hi Willthisdoat42,

    Thank you for your post.

    Based on your description, it seems that the intellisence and highlighting were blocked due to some possible cause.

    Could you please help me to try some common workarounds mentioned below to eliminate these possible causes?

      1. Try running devenv /Resetsettings in Command Prompt to eliminate the cause of corrupted settings.
      2. Try running devenv /ResetSkipPkgs in Command Prompt.
      3. Try running devenv /Safemode in Command Prompt to see if you can apply it correctly.
      4. Try running devenv /Resetuserdata in Command Prompt to reset all of your VS environment and customization settings.

    If these suggestions don't work, I would suspect that your issue could be related corrupted Silverlight 3 Tools installation.
    You might try to repair or re-install Silverlight 3 Tools for Visual Studio 2008 SP1.

    If you want to re-install Silverlight 3 Tools for Visual Studio 2008 SP1, please remove the previous Silverlight 3 Tool installation >> repair VWD2008 SP1 >> install Silverlight 3 Tool again.
    You can download it from http://www.microsoft.com/downloads/details.aspx?familyid=9442b0f2-7465-417a-88f3-5e7b5409e9dd&displaylang=en.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, March 25, 2010 3:18 AM
  • Hi YiChun Chen

    Thank you very very much the first 4 suggestions you gave me have worked perfectly ... .. It took me a little while to figure out how to apply them in the command prompt but after a little search i discovered if i changed my directory in the command prompt to C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE and run "VWDExpress.exe /ResetSettings etc etc it worked its miricle

    Thank you so much again for sharing your knowledge with me

    Thursday, March 25, 2010 4:21 AM
  • Hi Willthisdoat42,

    It's my pleasure!

    I'm so glad to hear this good news. Cheer!

    Have a nice day.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, March 25, 2010 4:43 AM
  • Yipee! it worked for me ...

    I just ran the first 4 instrunctions 2twice and it seems to have doen the trick you are a Legend i have installed uninstalled installed uninstalled vs2008, sl2, sl3, SDK , toolkits, Blend 3 over and over and over again to no avail until your wonderful post!!!!!.thank you so much


    This Above all: to thy Self be True - William Shakespeare

    Tuesday, April 06, 2010 2:40 PM
  • That is a very nice article YiChun. Unfortunately the first 4 steps didn't do anything for me but then I uninstalled all my Silverlight components and installed them again and intellisense worked normally. Very unfortunately this happens once in a while, so I have had to go through this process a few times in last year or so. 

    If you have any connection to the MS team responsible, it would be great if you tell them that losing intellisense is most annoying thing to VS users. 

    Thursday, July 29, 2010 6:31 PM