locked
This form template is browser-compatible, but it cannot be browser-enabled on the selected site.

    Question

  • Hi,

    I get this error message every time I try to publish an InfoPath 2007 form to SharePoint. In fact, I get it only on one single SharePoint (one of many 100’s). Publishing browser-enabled forms is working fine one any other SP, except this one. And this is what I do not understand.

    To quote a former post from Shabab Khan:

    “1. Site Collection Features has "Enterprise Features enabled"
    2. Site Features also has "Enterprise Features" enabled
    3. Forms Library has "View as Web Page" enabled in advance settings
    4. Infopath Forms Service has Render and User Browser Compatible Forms enabled
    5. Tried creating a form with simple section and design checker does not flash any errors (And, yes, the form is made browser compatible)
    6. Tried enable and disable of Infopath Forms Service, Enterprise Features, etc and did an IISRESET each time, to no positive result.

    [...]
    Solution:
    As soon as we created a top level site using virtual path using the Sharepoint Administration Console, the thing worked.”

    Compared with Shabab Khan we use the Site Directory - Our structure is http://www.company.i/sites/sitename. I don’t know what to try anymore.

    Hopefully anyone in this forum can help me with this, I’m sure I don’t know what to do.

    Thanks in advance!

    Wednesday, August 22, 2007 9:11 AM

Answers

  •  

    Hi,

     

    Heres the steps which might work for you !!!

     

    Check if the default “Form Templates” option in appearing under “View all site contents” page. If it is not enabled by default, then you can follow this following steps.

     

     If "Office SharePoint Server Enterprise Site Features" is enabled but we don't see the default "Form Templates" on the "View all site contents" page, then you should use the following steps.

    • Make sure they have backup of everything.
    • Opened the site http://<your site url> in SharePoint Designer.
    • Select the root URL and click FILE >> NEW >> SharePoint Content
    • Choose Document Library >> Form Library
    • Under options type the name as “FormServerTemplates” and it will create the content.
    • Now right click on “FormServerTemplate” and open “Properties”
    • On settings Tab change the name to “Form Templates” and uncheck the option “Use a template for new documents”
    • Click OK
    • Now you should see “Form Templates” on the view all site content page.
    • You should be able to publish the InfoPath form with "Enable this form to be filled out by using a browser."

    Thanks and Regards,

    Amit Bajaj

    Thursday, October 25, 2007 9:18 AM

All replies

  • Hi Datoli,

     

    Please try

     

    http://<Your central admin site name with port>/_admin/ManageFormsServiceProxy.aspx

     

    a) Substitue you central admin site and port above

     

    b) On the above page Change the web application from drop down to the web application you are working with.

     

    c) Check on the both check boxes, click ok.

     

    d) Try publishing form again.

     

    Please let me know if this worked.

     

    Regards,

    Mo

     

    Saturday, August 25, 2007 12:21 AM
  • Hi MoOne1,

     

    I'm afraid that your tip didn't help me out.

     

    Isn't it strange that form publishing is working fine on every Company SharePoint except this special one? There must be a difference, but i cannot find it..

     

    What could it be?

     

    Despaired greetings Sad

    Monday, August 27, 2007 9:34 AM
  • Did you check the Browser version is it IE 6.0 or 7.0?

    Monday, August 27, 2007 1:58 PM
  • We are using IE 7.0, updates included.

     

    Do you really think it is a browser problem? Like I said, it is only one site where I cannot publish? Sad(

    Tuesday, August 28, 2007 8:35 AM
  • This can be caused by deploying a "blank site" template. if this is the case you have to turn on the Office SharePoint Enterprise Site feature or Standard Site feature). Basicly form services have to be enable per-site.

     

    I think all the other site templates have this feature enabled from the start but the blank site template does not.

     

    Friday, August 31, 2007 8:49 PM
  • Thanks for your advice.

    However, as described above, the „Office SharePoint Server Enterprise Site features” AND the “Office SharePoint Server Enterprise Site Collection features” are both activated and their status also is “ACTIVE” (as with all the other sites). I’ve already tried to deactivate and reactivate those features to no avail….

    I’m baffled.

    Monday, September 03, 2007 9:00 AM
  • Check this:

     

      1. The user that publish the form have permissions to collaborate in the site.

      2. Generate an alias in Administration. Publish in the site with ip: http://10.10.10.10/sites/sitename and with FQDN http://server/sites/sitename

      3. Check SQL Permissions. The user in publication need permissions for wssCONTENT database.

     

      Regards,

         Alvarez Arigos Roberto Miguel

                 System Analyst

     

     

    Monday, September 03, 2007 3:06 PM
  • I am sure you are publishing the form correctly. The form must be published to a local folder and then uploaded manually to the SharePoint. I have noticed that sometimes activating the uploaded form from central administration doesn't work and one has to activate the feature from the "Site collection features list" (available from site settings of the site that contains the forms library). This is strange but it works! Try this and let me know the outcome!

     

    Good luck

     

    http://sharepointblogs.com/ssa

     

    Saturday, September 08, 2007 7:07 AM
  • Hi,

     

    Thanks for your advice. I published the browser-enabled form to a local folder and uploaded the created xsn to the document library. However, the following error message occurs:

    This form template is not currently browser-enabled. It must either be republished as a browser-enabled form, or opened using Microsoft Office InfoPath 2007.

    But this is an xsn file… shouldn’t it be an xml-file? When I publish the form to SharePoint, InfoPath creates an xml file anyway.

    Site features and Site collection features are still active.

    Monday, September 10, 2007 11:15 AM
  • please, read the infopath and sharepoint documentation before post...

     

    this error says "This form template is browser-compatible, but it cannot be browser-enabled on the selected site. "... CANNOT BE BROWSER ENABLED ON SELECTED SITE....

     

    IS A PUBLISH PROBLEM...

     

    ON SELECTED SITE...

     

    1. Check browser compatibility in Tools, Form Options, Compatibility... using your  Sharepoint Server in URL

     

    sorry, and regards

     

       Alvarez Arigos Roberto Miguel

     

     

     

     

    Monday, September 10, 2007 3:09 PM
  • Hi,

    I know that this is a site problem. That’s the reason why I asked the question in this forum! I am the administrator (rights and permissions). It is the same form EVERY TIME (browser-enabled). It can be published to ALL our sites (forms services), EXCEPT on single site! All site- and site-collection features are identical (and active); the paths are the same; it’s the same server farm; everything I checked is identical. And I can’t publish the form anyway!

    I can’t find the difference and I don’t know where to search anymore.

    Nevertheless I’m happy about every hints and advices.

    Tuesday, September 11, 2007 6:11 AM
  • Ok. Try this:

     

    1. Click on Start -> Administrative Tools -> SharePoint 3.0 Central Administration and choose the Application Management tab on the top of the page. Click on Configure InfoPath Forms Services in the InfoPath Forms Services section and check both "Allow users to browser-enable form templates" and "Render form templates that are browser-enabled by users" checkboxes, then OK this page

     

    2. Open your SharePoint site, click on Site Actions -> Site Settings, select Site collection features under Site Collection Administration and activate InfoPath Forms Services support

     

    3. In InfoPath, click on Tools/Form Options, select the Compatibility category and check the "Design a form template that can be opened in a browser or InfoPath", then click OK. In the case if you miss this one and your form is browser-compatible, you get a warning message while publishing your form saying that "The server is running InfoPath Forms Services, but the compatibility settings for this form template is InfoPath only".

     

    4. Publish your form onto a SharePoint 2007 library. In the wizard, at step 3, check the "Enable this form to be filled out by using a browser" checkbox and finish publishing.

     

    5. At the end of the publishing wizard, select "Open this document library" and click on Close. This will open the document library in the browser. Click on Settings/Form Library Settings, then click on Advanced Settings and select the "Display as a Web page" option in the Browser-enabled Documents category.

     

    All this steps are OK????

     

    Regards,

       Alvarez Arigos Roberto Miguel

               Systems Analyst

     

     

     

     

    Tuesday, September 11, 2007 12:49 PM
  •  

    Step 1: Ok

    Step 2: OK

    Step 3: OK

    Step 4: FALSE!

     
    I cannot check the "Enable this form to be filled out by using a browser" checkbox! But all necessary features are ACTIVATED! It works fine on every other of our SharePoint’s, except this single one! And I can’t find the difference between all other SharePoint’s and the one I need to publish the form!

    Wednesday, September 12, 2007 8:34 AM
  •  

    Hi,

     

    Heres the steps which might work for you !!!

     

    Check if the default “Form Templates” option in appearing under “View all site contents” page. If it is not enabled by default, then you can follow this following steps.

     

     If "Office SharePoint Server Enterprise Site Features" is enabled but we don't see the default "Form Templates" on the "View all site contents" page, then you should use the following steps.

    • Make sure they have backup of everything.
    • Opened the site http://<your site url> in SharePoint Designer.
    • Select the root URL and click FILE >> NEW >> SharePoint Content
    • Choose Document Library >> Form Library
    • Under options type the name as “FormServerTemplates” and it will create the content.
    • Now right click on “FormServerTemplate” and open “Properties”
    • On settings Tab change the name to “Form Templates” and uncheck the option “Use a template for new documents”
    • Click OK
    • Now you should see “Form Templates” on the view all site content page.
    • You should be able to publish the InfoPath form with "Enable this form to be filled out by using a browser."

    Thanks and Regards,

    Amit Bajaj

    Thursday, October 25, 2007 9:18 AM
  • Greate Amit. This works!!!

    Thursday, October 25, 2007 9:31 AM
  •  

    Hi,

     

    thanks for your tip! It resolved this issue.

    Thursday, October 25, 2007 12:24 PM
  •  

    Hi All,

    Just another tip to solve this problem that I had hereat my server.

    I was trying to publish an Infopath Form in my Sharepoint with the hability to be edited in browser, and Infopath was saying "This form template is browser-compatible, but it cannot be browser-enabled on the selected site." When I tryed to publish it in my Sharepoint site.

     

    The problem in my case was that the Enterprise features were enabled for my site, but not for the SITE COLLECTION. There is a great difference between this two things. If enterprise features are not enabled on Site Collection, Sharepoint will not be able to render Infopath forms on browser for that site.

    Tuesday, November 06, 2007 6:00 PM
  • Hi,

     

    Follow the following steps, I think you can solve the issue.

     

    Before publishing the form

     

    1. Go to Tools--> Form options

    2. Then go to Compatibility

    3. Then you can see a text box (I couldn't remember it's name exactly)

    4. Put the Url of Form services web service

    e.g: http://<YourservernameStick out tongueortname/_formservice.asmx> (Please conform teh name of the formserver webservice)

     

    5. Then click on Ok button.

    6. Now publish the form.

     

     

     

    Tuesday, November 20, 2007 10:56 AM
  • Refer this link it is the best solution for this issue.

    http://littletalk.wordpress.com/

    typhoon
    Wednesday, August 13, 2008 6:48 AM
  • Thank you Amit, that solved my problem !!
    Someone has removed the "Form Templates " library in the site collection.
    Tuesday, September 15, 2009 4:21 PM
  • I am afraid non of these options worked. it works when you publish it to form templates in central administration. do you have an advice?
    thanks
    Tuesday, December 29, 2009 8:24 PM
  • I am afraid non of these options worked. it works when you publish it to form templates in central administration. do you have an advice?
    thanks

    What is your problem/question?  If you get this message when publishing directly to a form library but don't get it when publishing to admin-approve in Central Admin, then it's because your browser form has code in it, which requires admin-approval before it can be viewed in the browser.
    SharePoint Architect || My Blog
    Tuesday, December 29, 2009 8:33 PM

  • Refer this link it is the best solution for this issue.

    http://littletalk.wordpress.com/

    typhoon

    Run the following commands to force deactivating and activating the Forms Services feature:

    stsadm -o deactivatefeature -filename IPFSSiteFeatures\feature.xml -force -url %SITE_COLLECTION_URL%

    stsadm -o deactivatefeature -filename IPFSWebFeatures\feature.xml -force -url %SITE_COLLECTION_URL%

    STSADM.EXE -o activatefeature -filename IPFSSiteFeatures\feature.xml -url %Sitecollection_URL% -force

    STSADM.EXE -o activatefeature -filename IPFSWebFeatures\feature.xml -url %sitecollection_URL% -force

    ** NOTE: The “%Sitecollection_URL%” is a place holder that would be replaced with your site collection URL, such as: http://sharepoint/sites/YourSiteCollection


    Simon
    Tuesday, March 02, 2010 8:27 PM
  • You know what? Sometimes even if you followed all the steps the Microsoft experts suggested, things just won't work out.

    After struggling for a couple of hours, I finally figured out what is going on with my sharepoint site. All settings are correct, it's just you are missing some form library that they use to store the forms.

    OK. Simple solution.

    Create a Form Library named "FormServerTemplates" at the root of your site collection. Now you are good to roll.

    Tuesday, June 22, 2010 8:57 PM
  • Step 1 is OK but don't have InfoPath Forms Services support. i have started with the Blank site, Is this makes the difference?
    Monday, June 28, 2010 6:51 AM
  • Zoro, just as an FYI, that library is created by default.
    SharePoint Architect || Microsoft MVP || My Blog
    Monday, June 28, 2010 7:03 AM