locked
SOMARPRODUTO COM 3 CONDIÇÕES

    Question

  • Olá pessoal,

             Estou tentando fazer uma fórmula de somarproduto com 3 condições. Conforme tabela abaixo.

    Para obter os resultados dessa tabela eu utilizei a fórmula =SOMARPRODUTO(($E$2:$E$65536=$G$5)*(TEXTO($B$2:$B$65536;"mmm")=H4)) , porém eu queria acrescentar mais um critério para pegar na base tudo que contém a palavra "=*Faturamento*" na coluna C. Não consegui complementar a função. Será que os senhores poderiam me ajudar? Desde já agradeço!

     

      Jan Fev Mar Abr Mai Jun Jul Ago Set Out Nov Dez
    Dentro 8 4 2 0 0 0 5 0 0 0 0 0
    Fora                        

     

     

    Data Conclusão Solicitação S/ Hora Data Prevista Destinatário (Nome) Prazo
    06/01/2010 12/01/2010 Grupo Resgates Dentro
    06/01/2010 12/01/2010 Grupo Resgates Dentro
    07/01/2010 08/01/2010 Grupo Portabilidade Dentro
    07/01/2010 08/01/2010 Grupo Portabilidade Dentro
    08/01/2010 11/01/2010 Grupo Portabilidade Dentro
    08/01/2010 11/01/2010 Grupo Portabilidade Dentro
    13/01/2010 14/01/2010 Grupo Portabilidade Dentro
    13/01/2010 14/01/2010 Grupo Portabilidade Dentro
    18/01/2010 08/01/2010 Grupo Resgates Fora
    18/01/2010 08/01/2010 Grupo Resgates Fora
    19/02/2010 24/02/2010 Grupo Faturamento Ind. Prev Dentro
    19/02/2010 24/02/2010 Grupo Faturamento Ind. Prev Dentro
    19/02/2010 24/02/2010 Grupo Faturamento Ind. Prev Dentro
    19/02/2010 24/02/2010 Grupo Faturamento Ind. Prev Dentro
    04/03/2010 10/03/2010 Grupo Resgates Dentro
    04/03/2010 10/03/2010 Grupo Resgates Dentro
    26/04/2010 01/03/2010 Grupo Resgates Fora
    26/04/2010 01/03/2010 Grupo Resgates Fora
    19/07/2010 22/07/2010 Grupo Manutenção Previdência Dentro
    19/07/2010 22/07/2010 Grupo Manutenção Previdência Dentro
    19/07/2010 22/07/2010 Grupo Manutenção Previdência Dentro
    19/07/2010 19/07/2010 Grupo Resgates Dentro
    19/07/2010 19/07/2010 Grupo Resgates Dentro

    Thursday, September 02, 2010 7:06 PM

All replies

  • Olá Fantos segue a sua resposta

     

    =SUMPRODUCT(($E$8:$E$60=$A$2)*(TEXT($B$8:$B$60;"mmm")=C1)*(IF(ISERROR(SEARCH("Faturamento";$D$8:$D$60;1));0;1)))

    Só que você terá que ativar para virar fórmula matricial com o Ctrl+Shift+Enter

     

    Abraços,

     

    Baldini

     


    Baldini Fabio
    • Proposed as answer by Baldini Friday, September 03, 2010 12:11 AM
    Friday, September 03, 2010 12:10 AM
  • Funcionou Baldini. Muito Obrigado!
    Friday, September 03, 2010 11:33 AM
  • Se quiser uma explicação sobre SOMARPRODUTO, recomendo que visite http://www.ambienteoffice.com.br/excel/SOMARPRODUTO/
    http://www.ambienteoffice.com.br
    Saturday, September 04, 2010 11:32 AM