none
Auto Refresh doesn't happen.

    Question

  • Experts,

    I've created simple data-set query as:-

    SELECT CAST(GETDATE() AS DATETIME) AS DT

    This column(DT) I'm displaying into Tablix column and setting report property to Auto Refresh = 10 (10 sec).

    Report refresh every 10 secs but always with same value, the DT column value never changes as time pass.

    Can anybody help me out please?

    Thank You

    Regards,

    Kumar


    Please do let us know your feedback. Thank You - KG, MCTS

    Thursday, June 27, 2013 4:50 PM

All replies

  • Hi Kumar,

    This issue only occur on Business Integrated Development Studio (BIDS) for the reason that when the report first generate, it will create a .data file to cache the data. So the report will not reflect the data change immediately. When we deploy the report to report server, the default setting is "Do not cache temporary copies of this report", so the AutoRefresh property works fine.

    If you have any questions, please feel free to ask.

    Regards,


    Charlie Liao
    TechNet Community Support

    Friday, June 28, 2013 7:50 AM
  • Hey Charlie,

    No I also tried on Report Server. Same issue either on BIDS and also on report server too.

    What am I doing wrong?

    Please let me know.

    BTW: This msdn forums are behavioring very old/slow since last 1-2 week.

    Regards,

    Kumar


    Please do let us know your feedback. Thank You - KG, MCTS

    Monday, July 01, 2013 7:54 PM
  • Any thoughts Charlie?

    Please do let us know your feedback. Thank You - KG, MCTS

    Tuesday, July 09, 2013 3:11 PM
  • Hi Kumar,

    I have tested it on my local environment (SQL Server Reporting Services 2008 R2 on Window 7), we cannot reproduce this issue. The report works fine on the Report Server. You can recreate a report to see if this issue is persists or not.

    Regards,


    Charlie Liao
    TechNet Community Support

    Wednesday, July 10, 2013 1:42 AM