locked
Getting Report Server WMI Provider error: Invalid namespace -SharePoint integration

    Question

  • I get the following during sharepoint reporting services configuration. noticed in denali reporting services config tool the db is in native mode and i believe this is the cause that sharepoint is throwing the WMI errror

    but there is no option to create a new database in "Integrated" mode in reporting services config tool. when choose a excisting db with "Integrated mode" it pops a message to select a db in native mode and doesn't let sharepoint integrated mode.

    any idea what i am missing?


    shiv
    Monday, September 05, 2011 2:17 AM

All replies

  • Reporting Services in Denali is a SharePoint shared service. Do not use the old RS config tool for configuration, instead create a new SQL Reporting Services Application in SharePoint Central Administration –> Application Management –> Service Applications –> Manage Service Applications and create a new SQL Server Reporting Services Application.

    Please read this documentation page, specifically the section about "Create a Reporting Services Service Application" near the bottom:

    http://technet.microsoft.com/en-us/library/gg492276(SQL.110).aspx

    These blog posts may also be useful:

    * http://blogs.msdn.com/b/oneclickbi/archive/2011/07/21/getting-up-and-running-with-sql-server-denali-for-business-intelligence-crescent-and-powerpivot-in-ctp3.aspx

    * http://denglishbi.wordpress.com/2011/07/22/configuring-sql-server-denali-reporting-services-sharepoint-2010-integration/

     

    HTH,
    Robert


    Robert Bruckner   http://blogs.msdn.com/robertbruckner
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, September 05, 2011 5:02 AM
  • Robert,

    i am new to sharepoint reporting and not sure whether i am missing anything basic.

    yes, i had followed those articles during installation. by "do not use old RS config" tool. do you mean SQL 2008r2 config tool? no, i am not using it. i using the denali reporting config tool.

    also, on the sharepoint side. the central administration sql reporting integration is needed right?

    the SSRS service application that i created is showing a status of "stopped" and they is no way to start it?

     

    thanks

    s

     

     


    shiv
    Monday, September 05, 2011 6:45 PM
  • By the old tool he means the Reporting Services Configuration Manager that you find under Start Menu\Programs\Microsoft SQL Server Denali CTP3\Configuration tools, you can't use that tool to configure the Reporting Services Sharepoint Mode in Denali.

    To the second question , the Section SQL Server Reporting Services (2008 and 2008 R2) on Central Admin under General Application Settings (where I guess you mention the Reporting Services Integration link) is just for SQL 2008 and 2008R2 , RS Denali doesn't use that page or settings, those are just for back compatibility.

    As Robert mentions if you follow the steps http://technet.microsoft.com/en-us/library/gg492276(SQL.110).aspx you will see there is not mention to the RS Config Tool neither the Reporting Services Integration link in Central Admin.

     

    Regards

    -Jaime

    Thursday, September 22, 2011 9:00 PM