none
How to run visual studio 2005 beta 2 project EXE on a smartphone device

    Question

  • I am developing applications for a smartphone using visual studio 2005 beta 2.
    I am unable to run my dotnet exe on my smartphone device.Does it needs any framework to be installed? If So,how to install and where to install that frame work?

    Thank You,
    Amar.

    Tuesday, July 19, 2005 1:06 PM

Answers

  • That's expected should you try to run NETCF V2 application on SP 2003 which has only NETCF V1. Make sure you're using V1 project type unless you have WM 5.0 SP (not likely unless you got hold of some engineering sample). If your device is SP 2002, it's not supported.

    Monday, August 08, 2005 2:40 AM
    Moderator

All replies

  • I'm assuming you're using SmartPhone 2003.

    You don't have to install the framework manually - VS will take care of installing the .NET Compact Framework on the device for you (1.0 in the case of SP 2003).

    It would be helpful if you could tell us what error message you're seeing and/or send us a solution that repros the problem.

    Also, do try installing the DMA transport update and ActiveSync 4.0
    http://blogs.msdn.com/vsdteam/archive/2005/05/13/417224.aspx

    Thanks,
    Sriram Krishnan
    PM, Visual Studio for Devices
    Tuesday, July 19, 2005 4:15 PM
  • Who is the mobile operator that provided you your smartphone? Many mobile operators lock the phones down so only signed applications can be installed, and that will prevent your application from running after you press F5. What error do you get on the device when you say it is "unable to run"?

    Neil Enns
    Lead Program Manager
    Visual Studio for Devices

    Wednesday, July 20, 2005 10:06 PM
  • I am not getting any errors.But when i execute my exe on smartphone device it just gives no response.

    help me

    Amar
    Tuesday, July 26, 2005 2:54 PM
  • You might need to check that you are using Active Sync. version 4.0. If you don't use this you will not be able to deploy programs.

    Tuesday, July 26, 2005 4:04 PM
  • Yes, i already installed Active Sync 4.0.

    I am able to synchronize my desktop ps to my smartphone device but i could not run my .net exe.
    I have not installed any .net framework in my device.Does it needs to install  .net framework.

    Help me,
    Wednesday, July 27, 2005 4:49 AM
  • Hi Amarender,
      
       Can you please tell us the exact error message you get? To answer your question, Visual Studio will take care of installing .NET on the phone - you don't need to install it manually

    Thanks,
    Sriram Krishnan
    PM, Visual Studio for Devices
    Wednesday, August 03, 2005 4:47 PM
  • Hi,
    I am not getting any errors.It hardly responds when i click on my exe.

    I also want to know about how to package the smartphone application for installation.

    Can you please abstract the process for packaging.

    Thanks,

    Thursday, August 04, 2005 12:42 PM
  • That's expected should you try to run NETCF V2 application on SP 2003 which has only NETCF V1. Make sure you're using V1 project type unless you have WM 5.0 SP (not likely unless you got hold of some engineering sample). If your device is SP 2002, it's not supported.

    Monday, August 08, 2005 2:40 AM
    Moderator