none
Folders are creating automatically in Sql Server Report Manger

    Question

  • Dear All,

    I am using Sql Server Reporting Services. And i have created Diffrent Folders in Report Manager,

    And deployed various reports. Now the problem is one folder created automatically in Report Manager as 'User Folders'

    and in that folder, sub folders are created automatically whenenver users are extracting the reports.

    Iam getting the below error whenever iam going to delete that folders,

    The permissions granted to user 'sbkhetan' are insufficient for performing this operation. (rsAccessDenied)

    Pl help me on this issue. How can i delete that folders,

    Thanks

    Monday, July 22, 2013 4:57 AM

Answers

All replies

  • Ideally you should have content manager role permission to delete the folder from report server or you used be part of the system administrator or system user on the box where ssrs is installed.

    For details permission matrix please follow this link => http://c--shark.blogspot.in/2010/06/built-in-ssrs-2008-roles.html


    Regards Harsh

    Monday, July 22, 2013 5:05 AM
  • Dear Harsh,

    I have a full rights and im also a administrator for Report Server.

    Im unable to delete that Folders..

    Regards,

    Monday, July 22, 2013 5:15 AM
  • That folder is part of the My Reports functionality.  As long as you've got that activated you cannot delete the folder...

    "While the feature is activated, Users Folders and its subfolders cannot be deleted. Furthermore, the name "My Reports" becomes a reserved name for folders created under the root node (Home)."

    Ref. Enabling and Disabling My Reports


    MCITP SQL Server 2008 (BI & DEV); MCTS SQL Server 2008 (BI, DEV & DBA)
    Check out my articles at BI: Beer Intelligence?

    Monday, July 22, 2013 11:46 AM
  • Hi,

    Please open SQL Server Management studio, at connection window, select server type: Reporting service.

    Right click properties of Reporting Services in object explorer and select properties.

    in General tab: uncheck "Enable a My Reports folder for each user.

    this will solve the problem.

    please make sure you connect SSMS as administrator.

    please vote as Answered if this helps, any question please post.

    thanks

    Adnan

    Tuesday, May 06, 2014 4:25 PM