none
Upload Multiple Documents Option Grayed Out

Answers

All replies

  • Which build are you using?

    Multiple upload and Open with Explorer is working fine in my 4514.1009 build.

    Are you browsing as user or System Account? If user, does the user have permissions to upload?

    If you hover the grayed items, SharePoint should show a tool tip with some info why its disabled. Are you getting those?

    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Thursday, November 12, 2009 1:52 AM
  • Yes, I can upload single document. It shows tool tip "This control is currently disabled" Press F2 for help :) You do not have permission to...

    I have logged in as Site Collection Admin.

    Blog: Alpesh Nakar's Blog | Twitter: Follow Alpesh on Twitter |SharePoint Resources: Just SharePoint Resource Center | Follow Just SharePoint updates on Twitter
    Thursday, November 12, 2009 2:07 AM
  • Few possibilities:
    1.) You have not enable "Client Integration".
    Go to Central Admin, Manage Web Application, And click "Auth Providers" in the Ribbon.  Check the Client Integration check box.

    2.) You IE security setting has blocked the STSSYNC ActiveX add on
    Here's a good article for this problem: http://sharepoint4u.wordpress.com/2009/05/07/no-multiple-upload-no-connect-to-outlook/


    Regards,
    Wilson | SharePoint Egg's Blog
    Thursday, November 12, 2009 5:00 AM
  • In earlier versions Upload Multiple Documents didn't work if you didn't have (a particular version up of) Office installed on the client.

    There was no mention of Office in the original post (nor in any follow-up)

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    • Marked as answer by Alpesh NAKAR Monday, November 23, 2009 11:29 AM
    Thursday, November 12, 2009 7:27 AM
  • Great insight into ActiveX stuff mate! I am using FireFox to access the site at the moment externally :) I have had issues with some functionality using FireFox and this makes sense! Yes at work we don't have IE7/IE8. No prizes for guessing what browser we have :) I cannot even authenticate into my site using IE6 - it's not a supported browser.

    I will try this on the server itself tonight and see what comes of this with Option 1 combined.

    @Mike You have a good point here that I will explore - we have Office 2003 client here :) but how would that affect Open with Explorer option?

    Things to try out tonight.

    Thanks to all responses.

    Blog: Alpesh Nakar's Blog | Twitter: Follow Alpesh on Twitter |SharePoint Resources: Just SharePoint Resource Center | Follow Just SharePoint updates on Twitter
    Friday, November 13, 2009 1:08 AM
  • >>@Mike You have a good point here that I will explore - we have Office 2003 client here :) but how would that affect Open with Explorer option?

    Thanks to Mike for reminding us about Office :)

    With SharePoint 2007, when you install SharePoint without any Office products present in your system, the WebDAV component will not be installed. The WebDAV component gets installed by Office 2007 (no idea why!). However there is a fix for this so that you dont go installing Office in your server :)

    Try that and check whether Open With Explorer works.


    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Friday, November 13, 2009 1:36 AM
  • Still have not tried any of these. Now that Beta2 is out, will rebuild and see what happens. Will update this post on rebuild.

    Thanks for the insights.
    Blog: Alpesh Nakar's Blog | Twitter: Follow Alpesh on Twitter |SharePoint Resources: Just SharePoint Resource Center | Follow Just SharePoint updates on Twitter
    Monday, November 16, 2009 10:44 PM
  • I have the same problem, "Upload Multiple Documents" is greyed out. I'm using IE 8 and I don't have any office applications installed. I'm using the public Beta.

    "Open with windows explorer" is working fine, though.

    The message that I get when I hover over "upload multiple documents" is as follows:
    "
    This control is currently disabled.

    You might not have the right permission level to use this, you might need to select an object or item, or the control might not work in this context.
    "

    I don't think that this explanation applies in this context.

    I have the client integration enabled.

    thanks

    Sandra 
    Thursday, January 28, 2010 3:37 PM
  • Office only installs the required add-ons in the 32-bit IE. So the features are not available in the 64-bit IE (8).
    Tuesday, April 20, 2010 2:22 PM
  • We also had this issues with one user and turned out to be the windows ts profile (citrix).  Removed this and now all working

    Thursday, June 10, 2010 10:55 AM
  • Another Free Fast Multi Site File Uploader: Multisite Upload works well

    Saturday, July 03, 2010 9:38 PM
  • The "Upload multiple documents" and "Open with Explorer" greyed out on SharePoint 2010 site when used IE 8 64bit. These options will just work fine on IE 8 32bit. Microsoft's following cumulative patch will address these issues.

    http://support.microsoft.com/kb/974455

     

    Thursday, November 18, 2010 7:26 PM
  • multiple upload  option is available in internet explorer 32bit. BUT NOT FOR 64-bit internet explorer nor chrome

     


    stazera
    • Proposed as answer by Echoworx Thursday, May 24, 2012 7:40 PM
    • Unproposed as answer by Echoworx Thursday, May 24, 2012 7:40 PM
    • Proposed as answer by Echoworx Thursday, May 24, 2012 7:40 PM
    Wednesday, July 27, 2011 5:48 AM
  • The Thursday after the Wednesday night install of the Tuesday patches.  14 of them.

    Win7Pro SP1-32, Office 2010 Standard SP1-32, IE9, SPD 2010.

    Before updates "Upload Multiple Files" link always present.  After update link appears for about 3 seconds then the "row" the link is on in the dialog box is deleted, the dialog box gets shorter by one "row", and no more link.  Does the same whether connected direct to LAN or via Citrix.

    Any ideas?

    Friday, June 15, 2012 4:00 AM
  • Mine worked by setting following

    Go to Central admin

    Application management

    select web application associated with the library in which you are trying to upload multi docs

    Go to General settings in the Ribbon

    Scroll down to the  Browser File Handling

    Select Permissive

    It worked a treat.

    Wednesday, August 15, 2012 6:36 AM
  • Thanks Wilson.

    This is the solution. I did this before a while ago. Your solution remimder me today when I am faceing this issues again without Farm admin permission.

    gzhou99


    • Edited by GZhou99 Thursday, November 01, 2012 5:47 PM
    Thursday, November 01, 2012 5:46 PM