none
Report Subscriptions Failing

    Question

  • Hi, We have several reports scheduled to run daily. Some of the reports are failing with the error message "The delivery extension for this subscription could not be loaded."  and some of them are showing "pending" in their status. THey won't send any emails. However, some reports are fully functional. What could be the problem ? I edited the reportconfig file and commented out scheduling policy section. also rebooted the machine. The issue still persists. I don't see anything on the forums. Can someone help me to sort this out? Any help is appreciated. 

    Version : SQL Server 2008 R2 SP2

    Thank you!

    Thursday, July 24, 2014 7:40 PM

All replies

  • Can you do a quick check by deleting and recreating schedule for one of the report? Or create a new schedule for one of the report which is failing. 


    Bipin. P | ERNST & YOUNG GSS

    Friday, July 25, 2014 6:02 AM
  •  I will do that and update again. Thanks a lot Bipin!
    Friday, July 25, 2014 2:22 PM
  • You may also want to look on the machine and see if any services are stopped that should normally be running. I'm not sure exactly which services come into play with subscriptions, or if this is necessarily a potential cause. Perhaps someone else in the forum can enlighten us. Just suggesting an potential path for debugging.
    Friday, July 25, 2014 3:31 PM
  • Hi SQLmaddy,

    According to your description, your e-mail subcription is not working. Right?

    In this scenario,we suggest you look at the logs at <DISKDRIVE>:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\LogFiles folder in the ReportServerService log files. The file would contain error messages for automatic e-mail delivery of the reports through a subscription. Also you can go to rsreportserver.config and try to annoted the Extension below:

    <Extension Name="Report Server DocumentLibrary" Type="Microsoft.ReportingServices.SharePoint.SharePointDeliveryExtension.DocumentLibraryProvider,ReportingServicesSharePointDeliveryExtension">
        <MaxRetries>3</MaxRetries>
        <SecondsBeforeRetry>900</SecondsBeforeRetry>
        <Configuration>
         <DocumentLibraryConfiguration>
          <ExcludedRenderFormats>
           <RenderingExtension>HTMLOWC</RenderingExtension>
           <RenderingExtension>NULL</RenderingExtension>
           <RenderingExtension>RGDI</RenderingExtension>
          </ExcludedRenderFormats>
         </DocumentLibraryConfiguration>
        </Configuration>
       </Extension>

    Wrap the code above in <!-- -->.

    Reference:
    SRS 2008 New Subscription e-mail delivery excel file
    SSRS 2005 Web Farm Error : The delivery extension for this subscription could not be loaded.

    If you have any question, please feel free to ask.

    Best Regards,
    Simon Hou

    Sunday, July 27, 2014 4:03 PM
    Moderator
  •  Thank you for your replies. Some reports are running fine though! I don't see anything weird from the services perspective. I updated the reportserver.config file by commenting out the code above. I will wait until tomorrow for the next scheduled reports and update you.
    Monday, July 28, 2014 5:36 PM
  • Reports are still failing. Is there anything I can do ? Should I open a MSFT case?
    Tuesday, July 29, 2014 2:25 PM