none
Odd jumping behavior with multitouch (WPF)

    General discussion

  • we've noticed a problem that happens on several computers (perhaps all that we've tested with) when using the Bing Maps control, even with it just plopped into a grid in a clean MainWindow in a clean project.

    i've created a video that shows what happens -- basically if you put down two fingers to do a pinch or zoom gesture, the map jumps. usually this happens on the down, but sometimes happens in the up. 

    WPF 4.5, running under Windows 8. a coworker has tried it under Windows 7 and while it appears to be better (maybe is not at all), it still happens.

    http://i30.photobucket.com/albums/c340/jonathankhoo/IMG_7239_zpsf5dec9f3.mp4

    any ideas as to what's going on? 

    thanks!

    jon



    • Edited by jonkjonk Friday, February 15, 2013 6:56 AM
    Friday, February 15, 2013 6:55 AM

All replies

  • This also happens with a Windows 8 Touch Tablet.

    I think it's time to release a Bing Maps WPF 2.0, performance-optimized for the latest touch devices.
    Thursday, March 07, 2013 5:08 AM
  • Our development team is aware of this issue. At this time there is no plans for a next version of the WPF control. Note that if you are targeting Windows 8 you should use the Bing Maps Native control for Windows 8 which works great on all Windows 8 devices and has a lot more features than the WPF control.

    http://rbrundritt.wordpress.com


    Friday, March 08, 2013 7:20 PM
    Owner
  • Hi Richard!

    Thank you for replying!

    Were you talking about the Bing Maps Native Control for Windows RT Apps? We cannot use that, as our app is WPF-based.

    Our app is also strictly designed to be like Microsoft Office apps, in that they work in Desktop Mode, but can support touch mode via Large Buttons.

    We really hope you would update the Bing Maps WPF Control, Not just for Windows 8, but also for:

    • Perceptive Pixel running Windows 7
    • Microsoft Pixelsense running Windows Vista
    • Microsoft Pixelsense 2 running Windows 7

    Those platforms are the reasons we need to stick with WPF.

    Regards,
    thenonhacker



    Wednesday, March 13, 2013 7:16 AM
  • Give this a shot. I was having the same problem with my surface pro. After messing with setting I found setting the IsManipulationEnabled to true stops the jumping but did not want  to leave it on all the time since the default is false. So the following code turns it on/off on my map control.

     

     Private Property MapIsManipulationEnabled As Boolean
     
        Private Sub Map_TouchDown(sender As Object, e As TouchEventArgsHandles mMap.TouchDown, mMap.TouchUp
            CheckMapManipulation()
        End Sub
     
        Private Sub CheckMapManipulation()
            If Not MapIsManipulationEnabled Then
                MapIsManipulationEnabled = Not MapIsManipulationEnabled
                mMap.IsManipulationEnabled = MapIsManipulationEnabled
            Else
                MapIsManipulationEnabled = Not MapIsManipulationEnabled
                mMap.IsManipulationEnabled = MapIsManipulationEnabled
            End If
        End Sub
    Saturday, April 13, 2013 12:33 AM